Duplication

There are two types of object duplication, being Duplicate and Linked Duplicates which instance their Object Data.

Duplicate

Reference

Mode

Edit and Object Modes

Panel

Tool Shelf ‣ Tools ‣ Edit ‣ Duplicate

Menu

Object ‣ Duplicate Objects

Hotkey

Shift-D

This will create a visually-identical copy of the selected object(s). The copy is created at the same position as the original object and you are automatically placed in Grab mode. See the examples below.

This copy is a new object, which shares some data-blocks with the original object (by default, all the Materials, Textures, and F-Curves), but which has copied others, like the mesh, for example. This is why this form of duplication is sometimes called “shallow link”, because not all data-blocks are shared; some of them are “hard copied”!

Tip

You can choose which types of data-block will be linked or copied when duplicating: in the User Preferences.

Examples

../../../../_images/editors_3dview_object_editing_duplication_example.png

The Cube object was duplicated.

The object Cube was duplicated, using Shift-D. Both these cubes has separate meshes with unique names: Cube and Cube.001.

  • The original left cube is being edited, the duplicated right cube remains unchanged. The mesh data has been copied, not linked.

  • Likewise, if one cube is edited in Object Mode, the other cube remains unchanged. The new object’s transform properties or data-block is a copy, not linked.

  • When the cube was duplicated, it inherited the material of the original cube. The material properties were linked, not copied.

See above if you want separate copies of the data-blocks normally linked.

Linked Duplicates

Reference

Mode

Object Mode

Panel

Tool Shelf ‣ Tools ‣ Edit ‣ Duplicate Linked

Menu

Object ‣ Duplicate Linked

Hotkey

Alt-D

You also have the choice of creating a Linked Duplicate rather than a Duplicate; this is called a deep link. This will create a new object with all of its data linked to the original object. If you modify one of the linked objects in Edit Mode, all linked copies are modified. Transform properties (object data-blocks) still remain copies, not links, so you still can rotate, scale, and move freely without affecting the other copies. Reference Expl. Duplicate Example for the discussions below.

Linked

In the Duplicate Objects Operator panel the Linked checkbox is checked unlike with Duplicate.

Hint

If you want to make changes to an object in the new linked duplicate independently of the original object, you will have to manually make the object a “single-user” copy by LMB the number in the Object Data panel of the Properties editor. (See Data-Block Menu).

See also

Make Single User for unlinking data-blocks.