Introduction

In this section will be described tools for manipulating objects in Object Mode. All editing tools can be found in Object menu and/or in Tools Shelf.

Delete

Reference

Mode: Object Mode
Panel: Tool Shelf ‣ Tools ‣ Edit ‣ Delete
Menu: Object ‣ Delete
Hotkey: X

The selected objects are deleted from the scene.

Delete Globally Shift-X
This checkbox in the Operator panel will cause the objects to be deleted from all the scenes where they are linked.

Show/Hide

Reference

Mode: All Modes
Menu: Object ‣ Show/Hide
Show Hidden Alt-H
Reveals all hidden objects.
Hide Selected H
Hides all selected objects.
Hide Unselected Shift-H
Hides all unselected objects of the scene. The Unselected checkbox in the Set Restrict View/Hide Selected Operator panel will be checked.

Convert To

Curve from Mesh/Text

Reference

Mode: Object Mode
Menu: Object ‣ Convert to ‣ Curve from Mesh/Text
Hotkey: Alt-C

Mesh objects and text objects can be converted into curve objects. In mesh objects, only edges belonging to no faces will be taken into account. The resulting curve will be a Poly curve type, but can be converted to have smooth segments as described in Set Spline Type.

Mesh from Curve/Metaball/Surface/Text

Reference

Mode: Object Mode
Menu: Object ‣ Convert to ‣ Mesh from Curve/Metaball/Surface/Text
Hotkey: Alt-C

Converts the selected curve, metaball, surface and text objects to mesh objects. The actual defined resolution of these objects will be taken into account for the conversion. Note that it also keeps the faces and volumes created by closed and extruded curves.

Options

Keep Original
Duplicates the original object before converting it.

Join

Reference

Mode: Object Mode
Panel: Tool Shelf ‣ Tools ‣ Edit ‣ Join
Menu: Object ‣ Join
Hotkey: Ctrl-J

Join merges all selected objects into the last selected Active object. All object data is linked to the active object (which must be selected). All objects must be of the same type: mesh, curve, surface or armature. If several curves are joined, each one will keep its subtype (NURBS or Bézier).

Note

Object data has many attributes which may be handled when joining.

Materials, vertex-groups, UV and Vertex layers will be merged.

Modifiers, constraints, groups and parent relationships are ignored when joining and will not be applied to the active object.