Layout

After unwrap, you will likely need to arrange the UV maps into something that can be logically textured or painted. Your goals for editing are:

  • Stitch some pieces (UV maps) back together.

  • Minimize wasted space in the image.

  • Enlarge the faces where you want more detail.

  • Re-size/enlarge the faces that are stretched.

  • Shrink the faces that are too grainy and have too much detail.

With a minimum of dead space, the most pixels can be dedicated to giving the maximum detail and fineness to the UV texture. A UV face can be as small as a pixel (the little dots that make up an image) or as large as an entire image. You probably want to make some major adjustments first, and then tweak the layout.

Transforms

Reference

Mode

View Mode and Mask Mode

Panel

Tool Shelf ‣ Tools ‣ Transform

Menu

UVs ‣ Transform

  • Translate G

  • Rotate R

  • Scale S

  • Shear Shift-Ctrl-Alt-S

Axis Locking

Transformations can be locked to an axis by pressing X or Y after one of the transform tools. Also, holding the MMB will constrain movement to the X or Y axis.

UV Options

Reference

Mode

View Mode and Mask Mode

Panel

Tool Shelf ‣ Options ‣ UV Options

Menu

UVs

Live Unwrap

Continuously unwraps the selected UV islands while transforming pinned vertices.

Snap to pixel

Will force the UVs to snap to the nearest pixels of an image if loaded.

Constraining to Image Bounds

Turning on Constrain to Image Bounds will prevent UVs from being moved outside the 0 to 1 UV range.

Pin and Unpin

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ UV Unwrap: Pin/Unpin

Menu

UVs ‣ Pin/Unpin

Hotkey

P, Alt-P

You can pin UVs so they do not move between multiple unwrap operations. When Unwrapping a model it is sometimes useful to “Lock” certain UVs, so that parts of a UV layout stay the same shape, and/or in the same place. Pinning is done by selecting a UV, then selecting Pin from the UVs menu, or the shortcut P. You can Unpin a UV with the shortcut Alt-P.

Pinning is most effective when using the Unwrap method of UV mapping, for organic objects. An example is when you are modeling a symmetrical object using the Mirror Modifier. Some of the UVs on the mirror axis may be shared across the mirrored counterparts. You could pin the UVs that correspond to the midline, then align them on the X axis, and they will stay in that location.

Pinning also work great with the Live Unwrap tool. If you pin two or more UVs, with Live Unwrap on, dragging pinned UVs will interactively unwrap the model. This helps with fitting a UV island to a certain shape or region.

Seams

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ UV Unwrap: Mark/Clear Seam

Menu

UVs ‣ Mark/Clear Seam

See Seams.

Pack Islands

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ Pack Islands

Menu

UVs ‣ Pack Islands

Hotkey

Ctrl-P

The Pack Islands tool generates an optimized UV layout with non-overlapping islands that tries to efficiently fill the texture space.

First it will uniformly scale the selected island, then individually transform each island so that they fill up the UV space as much as possible.

Average Island Scale

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ Average Island Scale

Menu

UVs ‣ Average Island Scale

Hotkey

Ctrl-A

Using the Average Island Scale tool, will scale each UV island so that they are all approximately the same scale.

Minimize Stretch

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ Minimize Stretch

Menu

UVs ‣ Minimize Stretch

Hotkey

Ctrl-V

The Minimize Stretch tool, reduces UV stretch by minimizing angles. This essentially relaxes the UVs.

Stitch

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ Stitch

Menu

UVs ‣ Stitch

Hotkey

V

The Stitch tool, will join selected UVs that share vertices. You set the tool to limit stitching by distance in the Operator panel, by activating Use Limit and adjusting the Limit Distance

Copy Mirrored UV Coordinates

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ Copy Mirrored UV Coordinates

Menu

UVs ‣ Copy Mirrored UV Coordinates

Copies UVs from one side of the mirrored mesh to the other. Affects only selected vertices (on both sides).

Axis Direction

Positive/Negative

Precision

Tolerance for finding vertex duplicates.

Mirror

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Align ‣ Mirror X/Y

Menu

UVs ‣ Mirror

Hotkey

Ctrl-M

UVs can be mirrored on the Y axis or the X axis:

  • Mirror X

  • Mirror Y

You can also use the hotkey Ctrl-M, then enter X or Y, or hold the MMB and drag in the mirror direction.

Snap

Reference

Mode

View mode

Menu

UVs ‣ Snap

Hotkey

Shift-S

Snapping in the UV/image editor is similar to Snapping in 3D. For the snap to pixel options to work an image has to be loaded.

Selected to Pixels

Moves selection to nearest pixel. See also Snap to pixel above.

Selected to Cursor

Moves selection to 2D cursor location.

Selected to Cursor (Offset)

Moves selection center to 2D cursor location, while preserving the offset of the vertices from the center.

Selected to Adjacent Unselected

Moves selection to adjacent unselected element.

Cursor to Pixels

Snaps the cursor to the nearest pixels.

Cursor to Selected

Moves the Cursor to the center of the selection.

Weld

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ Weld

Menu

UVs ‣ Weld/Align ‣ Weld, Specials ‣ Weld

Hotkey

W

The Weld tool will move selected UVs to their average position.

Remove Doubles UV

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ Remove Doubles UV

Menu

UVs ‣ Weld/Align ‣ Remove Doubles UV, Specials ‣ Remove Doubles UV

The Remove Doubles UV tool will merge selected UVs within the specified Margin.

Straighten/Align

Reference

Mode

View mode

Panel

Tool Shelf ‣ Tools ‣ UV Tools ‣ UV Align ‣ Straighten/Align

Menu

UVs ‣ Weld/Align ‣ Straighten/Align, Specials ‣ Straighten/Align

Hotkey

W

Straighten

Auto, X, Y

Align

Will line up the selected UVs on the X axis, Y axis, or automatically chosen axis.

Auto, X, Y

Proportional Editing

Reference

Mode

View mode

Header

Proportional Editing

Menu

UVs ‣ Proportional Editing

Hotkey

O

Proportional Editing is available in UV editing. The controls are the same as in the 3D View. See Proportional Editing in 3D for a full reference.

Show/Hide Faces

Reference

Mode

View mode

Menu

UVs ‣ Show/Hide Faces

  • Reveal Hidden Alt-H

  • Hide Select H

  • Hide Unselect Shift-H

Export UV Layout

Reference

Mode

View mode

Menu

UVs ‣ Export UV Layout

This is an add-on activated by default.

3D View

Face Mirror and Rotate UVs

Reference

Editor

3D View

Mode

Edit mode

Menu

Mesh ‣ Face ‣ Rotate UVs/Reverse UVs

The orientation of the UV texture is defined by each face. If the image is, for example, upside down or laying on its side, use the Face ‣ Rotate UVs (in the 3D View in Face Select mode) menu to rotate the UVs per face in 90-degree turns.

The Face ‣ Reverse UVs tool mirrors the UVs per face, which flips the image over, showing you the image reversed.