Edge Tools

Reference

Mode: Edit Mode
Menu: Mesh ‣ Edges
Hotkey: Ctrl-E

Make Edge/Face

Reference

Mode: Edit Mode
Panel: Tool Shelf ‣ Tools ‣ Mesh Tools ‣ Add: Make Edge/Face
Menu: Mesh ‣ Edges ‣ Make Edge/Face
Hotkey: F

It will create an edge or some faces, depending on your selection.

See also Creating Geometry.

Set Edge Attributes

Edges can have several different attributes that affect how certain other tools affect the mesh.

Mark Seam and Clear Seam

Reference

Mode: Edit Mode (Vertex or Edge select modes)
Menu: Mesh ‣ Edges ‣ Mark Seam/Clear Seam

Seams are a way to create separations, “islands”, in UV maps. See the UVTexturing section for more details. These operators set or unset this flag for selected edges.

Mark Sharp and Clear Sharp

Reference

Mode: Edit Mode (Vertex or Edge select modes)
Menu: Mesh ‣ Edges ‣ Mark Seam/Clear Seam (or the same options in Edge Specials menu)

The Sharp flag is used by the Edge Split Modifier, which is part of the smoothing techniques. As seams, it is a property of edges, and these operators set or unset it for selected ones.

Adjust Bevel Weight

Reference

Mode: Edit Mode (Vertex or Edge select modes)
Menu: Mesh ‣ Edges ‣ Edge Bevel Weight

This edge property, a value between (0.0 to 1.0), is used by the Bevel Modifier to control the bevel intensity of the edges. This operator enters an interactive mode (a bit like transform tools), where by moving the mouse (or typing a value with the keyboard) you can set the (average) bevel weight of selected edges.

Edge Crease

Reference

Mode: Edit Mode (Vertex or Edge select modes)
Menu: Mesh ‣ Edges ‣ Edge Crease
Hotkey: Shift-E

This edge property, a value between (0.0 to 1.0), is used by the Subdivision Surface Modifier to control the sharpness of the edges in the subdivided mesh. This operator enters an interactive mode (a bit like transform tools), where by moving the mouse (or typing a value with the keyboard) you can set the (average) crease value of selected edges. A negative value will subtract from the actual crease value, if present. To clear the crease edge property, enter a value of -1.

Edge Slide

Reference

Mode: Edit Mode (Vertex or Edge select modes)
Panel: Tool Shelf ‣ Tools ‣ Mesh Tools ‣ Deform: Slide Edge
Menu: Mesh ‣ Edges ‣ Slide Edge

Slides one or more edges across adjacent faces with a few restrictions involving the selection of edges (i.e. the selection must define a valid loop, see below).

Even E
Forces the edge loop to match the shape of the adjacent edge loop. You can flip to the opposite vertex using F. Use Alt-Wheel to change the control edge.
Flip F
When Even mode is active, this flips between the two adjacent edge loops the active edge loop will match.
Clamp Alt or C
Toggle clamping the slide within the edge extents.

In Proportional mode, Wheel, or Left and Right changes the selected edge for calculating a proportion. Unlike Percentage mode, Proportional

Factor
Determines the amount of slide performed. Negative values correspond to slides toward one face, while positive ones, refer to the other one. It is also displayed in the 3D View footer.
Mirror Editing
Lets you propagate the operation to the symmetrical elements of the mesh (if present, in local X direction).
Correct UVs
Corrects the corresponding UV coordinates, if these exist, to avoid image distortions.

Usage

By default, the position of vertices on the edge loop move as a percentage of the distance between their original position and the adjacent edge loop, regardless of the edges’ lengths.

../../../_images/modeling_meshes_editing_edges_edge-slide-before.png

Selected Edge Loop.

../../../_images/modeling_meshes_editing_edges_edge-slide-after.png

Repositioned Edge Loop.

Even Mode

Even mode keeps the shape of the selected edge loop the same as one of the edge loops adjacent to it, rather than sliding a percentage along each perpendicular edge.

In Even mode, the tool shows the position along the length of the currently selected edge which is marked in yellow, from the vertex that as an enlarged red marker. Movement of the sliding edge loop is restricted to this length. As you move the mouse the length indicator in the header changes showing where along the length of the edge you are.

To change the control edge that determines the position of the edge loop, use the Alt-Wheel to scroll to a different edge.

../../../_images/modeling_meshes_editing_edges_edge-slide-even.png

Even Mode Enabled.

../../../_images/modeling_meshes_editing_edges_edge-slide-even-flip.png

Even Mode with Flip Enabled.

Moving the mouse moves the selected edge loop towards or away from the start vertex, but the loop line will only move as far as the length of the currently selected edge, conforming to the shape of one of the bounding edge loops.

Limitations & Workarounds

There are restrictions on the type of edge selections that can be operated upon. Invalid selections are:

Loop crosses itself
This means that the tool could not find any suitable faces that were adjacent to the selected edge(s). Fig. Loop crosses is an example that shows this by selecting two edges that share the same face. A face cannot be adjacent to itself.
Multiple edge loops
The selected edges are not in the same edge loop, which means they do not have a common edge. You can minimize this error by always selecting edges end to end or in a “Chain”. If you select multiple edges just make sure they are connected. This will decrease the possibility of getting looping errors.
Border Edge
When a single edge was selected in a single sided object. An edge loop cannot be found because there is only one face. Remember, edge loops are loops that span two or more faces.

A general rule of thumb is that if multiple edges are selected they should be connected end to end such that they form a continuous chain. This is literally a general rule because you can still select edges in a chain that are invalid because some of the edges in the chain are in different edge loops.

Rotate Edge

Reference

Mode: Edit Mode (Vertex or Edge select modes)
Menu: Mesh ‣ Edges ‣ Rotate Edge CW / Rotate Edge CCW

Rotating an edge clockwise or counter-clockwise spins an edge between two faces around their vertices. This is very useful for restructuring a mesh’s topology. The tool can operate on one explicitly selected edge, or on two selected vertices or two selected faces that implicitly share an edge between them.

../../../_images/modeling_meshes_editing_edges_edge-flip-before.png

Selected Edge.

../../../_images/modeling_meshes_editing_edges_edge-flip-after.png

Edge, rotated CW.

Using Face Selection

To rotate an edge based on faces you must select two faces, Fig. Adjacent selected faces, otherwise Blender notifies you with an error message, "ERROR: Could not find any select edges that can be rotated". Using either Rotate Edge CW or Rotate Edge CCW will produce exactly the same results as if you had selected the common edge shown in Fig. Selected edge rotated CW and CCW.

Edge Split

Reference

Mode: Edit Mode
Menu: Mesh ‣ Edges ‣ Edge Split

Edge Split is similar to the Rip tool. When two or more touching interior edges, or a border edge is selected when using Edge Split, a hole will be created, and the selected edges are duplicated to form the border of the hole.

../../../_images/modeling_meshes_editing_edges_edge-split-before.png

Selected Edges.

../../../_images/modeling_meshes_editing_edges_edge-split-after.png

Adjacent face moved to reveal hole left by split.

Bridge Edge Loops

Reference

Mode: Edit Mode
Menu: Mesh ‣ Edges ‣ Bridge Edge Loops

Bridge Edge Loops connects multiple edge loops with faces.

Connect Loops
Open Loop
Loops connected with open ends.
Closed Loop
Tries to connect to a circular loop (where start and end is merged).
Loop pairs
Connects each even count of loops individually.
Merge
ToDo 2.68.
Merge Factor
ToDo 2.68.
Twist
Determines which vertices in both loops are connected to each other.
Number of Cuts
The number of intermediate edge loops used to bridge the distance between two loops.
Interpolation
Linear, Blend Path, Blend Surface
Smoothness
Smoothness of the Blend Path and Blend Surface.
Profile Factor
ToDo 2.68.
Profile Shape
ToDo 2.68. Compare to Proportional Editing Falloff.

Examples

Simple example showing two closed edge loops.

../../../_images/modeling_meshes_editing_edges_bridge-simple-before.png

Input.

../../../_images/modeling_meshes_editing_edges_bridge-simple-after.png

Bridge Result.

Example of the Bridge tool between edge loops with different numbers of vertices.

../../../_images/modeling_meshes_editing_edges_bridge-uneven-before.png

Input.

../../../_images/modeling_meshes_editing_edges_bridge-uneven-after.png

Bridge Result.

Example using the Bridge tool to punch holes in face selections and connect them.

../../../_images/modeling_meshes_editing_edges_bridge-faces-before.png

Input.

../../../_images/modeling_meshes_editing_edges_bridge-faces-after.png

Bridge Result.

Example showing how Bridge tool can detect multiple loops and loft them in one step.

../../../_images/modeling_meshes_editing_edges_bridge-multi-before.png

Input.

../../../_images/modeling_meshes_editing_edges_bridge-multi-after.png

Bridge Result.

Example of the subdivision option and surface blending with UV’s.

../../../_images/modeling_meshes_editing_edges_bridge-advanced-before.png

Input.

../../../_images/modeling_meshes_editing_edges_bridge-advanced-after.png

Bridge Result.