Subdivide

Reference

Mode: Edit Mode
Panel: Tool Shelf ‣ Tools ‣ Mesh Tools ‣ Add: Subdivide
Menu: Mesh ‣ Edges ‣ Subdivide, Specials ‣ Subdivide/Subdivide Smooth

Subdividing splits selected edges and faces by cutting them in half or more, adding new vertices, and subdividing accordingly the faces involved. It adds resolution to the mesh by divide faces or edges into smaller units.

This process follows a few rules, depending on the settings:

  • When only one edge of a face is selected (Triangle mode), triangles are subdivided into two triangles, and quads, into three triangles.
  • When two edges of a face are selected:
    • If the face is a triangle, a new edge is created between the two new vertices, subdividing the triangle in a triangle and a quad.
    • If the face is a quad, and the edges are neighbors, we have three possible behaviors, depending on the setting of Corner Cut Type (the select menu next to the Subdivide button, in Mesh Tools panel) See below for details.
    • If the face is a quad, and the edges are opposite, the quad is just subdivided in two quads by the edge linking the two new vertices.
  • When three edges of a face are selected:
    • If the face is a triangle, this means the whole face is selected and it is then sub-divided in four smaller triangles.
    • If the face is a quad, first the two opposite edges are subdivided as described above. Then, the “middle” edge is subdivided, affecting its new “sub-quad” as described above for only one edge.
  • When four edges of a face (a quad) are selected, the face is subdivided into four smaller quads.

Options

These options are available in the Tool Panel after running the tool;

Number of Cuts
Specifies the number of cuts per edge to make. By default this is 1, cutting edges in half. A value of 2 will cut it into thirds, and so on.
Smoothness

Displaces subdivisions to maintain approximate curvature, The effect is similar to the way the Subdivision Surface Modifier might deform the mesh.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_smooth-before.png

Mesh before subdividing.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_smooth-none.png

Subdivided with no smoothing.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_smooth-after.png

Subdivided with smoothing of 1.

Quad/Tri Mode
Forces subdivide to create triangles or quads instead of n-gons (see examples below). This mode doesn’t allow the use of Straight Cut on quad corners.
Corner Cut Type

This select menu controls the way quads with only two adjacent selected edges are subdivided.

Fan
The quad is sub-divided in a fan of four triangles, the common vertex being the one opposite to the selected edges.
Inner vertices
The selected edges are sub-divided, then an edge is created between the two new vertices, creating a small triangle. This edge is also sub-divided, and the “inner vertex” thus created is linked by another edge to the one opposite to the original selected edges. All this results in a quad sub-divided in a triangle and two quad.
Path
First an edge is created between the two opposite ends of the selected edges, dividing the quad in two triangles. Then, the same goes for the involved triangle as described above.
Straight Cut
../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-fan2.png

Fan cut type.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-innervert.png

Inner vertices cut type.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-path.png

Path cut type.

Fractal

Displaces the vertices in random directions after the mesh is subdivided.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-before.png

Plane before subdivision.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-none.png

Regular subdivision.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-after1.png

Same mesh with fractal added.

Along Normal

Causes the vertices to move along the their normals, instead of random directions.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-along-normal.png

Along normal set to 1.

Random Seed

Changes the random seed of the Fractal noise function, producing a different result for each seed value.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-after2.png

Same mesh with a different seed value.

Examples

Below are several examples illustrating the various possibilities of the Subdivide and Subdivide Multi tools. Note the selection after subdivision.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_before.png

The sample mesh.

One Edge

../../../../_images/modeling_meshes_editing_subdividing_subdivide_one-edge.png

One Edges.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_one-edge-tri.png

Quad/Tri Mode.

Two Tri Edges

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-tri.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-tri-tri.png

Quad/Tri Mode.

Two Opposite Quad Edges

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-opposite.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-opposite-tri.png

Quad/Tri Mode.

Two Adjacent Quad Edges

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-fan2.png

Fan cut type.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-fan.png

Quad/Tri Mode.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-innervert.png

Innervert cut type.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-innervert-tri.png

Quad/Tri Mode.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-path.png

Path cut type.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-path-tri.png

Quad/Tri Mode.

Three Edges

../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges-tri2.png

Quad/Tri Mode.

Tri

../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges-tri.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges-tri-tri.png

Quad/Tri Mode.

Quad/Four Edges

../../../../_images/modeling_meshes_editing_subdividing_subdivide_four-edges.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_four-edges-tri.png

Quad/Tri Mode.

Multicut

../../../../_images/modeling_meshes_editing_subdividing_subdivide_tri-multi.png

Tri with two cuts.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_quad-multi.png

Quad with two cuts.

Un-Subdivide

Reference

Mode: Edit Mode
Menu: Mesh ‣ Edges ‣ Un-Subdivide

Unsubdivide functions as the reverse of subdivide by attempting to remove edges that were the result of a subdivide operation. If additional editing has been done after the subdivide operation, unexpected results may occur.

Iterations
How many subdivisions to remove.