POV-Ray 3.7

POV-Ray es un motor de render basado en SDL (Scene Description Language) con un largo historial que lo hace muy estable y rico en características. La última versión de POV-Ray 3.7 puede ser encontrada en el sitio del proyecto.

Características

Algunas características claves del exportador incluyen:

  • Importación y exportación de geometría con sus modificadores, animación con keyframes y física

  • Agrega las primitivas, que no son mallas, específicas a POV-Ray (nunca muestra teselado)

  • Instancias

  • Partículas de pelo

  • Simulaciones de humo

  • Materiales atmosféricos (niebla de volumen)

  • Mapeo de entorno HDRI

  • Profundidad de apertura del campo

  • Propiedades del material tales como filtrado, emisión, translucidez, esparcimiento de subsuperficie, niebla (absorción teñida), reflejos borrosos/con brillo…

  • Texturas procedurales (emuladas desde Blender y POV-Ray nativo)

  • Texturas de imágenes

  • Canales de influencia de texturas: Alpha, Diffuse, Bump, Specular, Mirror (utiliza el mismo canal que Specular)

  • Iluminación global: Radiosity (iluminación indirecta), photons caustics (reflejo/refracción), mesh lights

  • Entrada de código POV-Ray personalizada, dando acceso a cualquier característica de POV-Ray que no sea soportada por el exportador.

Características de POV-Ray 3.7

Volumétricos y materiales (esparcimiento/absorción), reflejos borrosos (uberPOV), imagen fantasma para el blureado de movimientos (uberPOV), desplazamiento micropoligonal (HGPOV), etc.

Activación

  • ¡Por supuesto, no olvides descargar e instalar a POV-Ray!

  • Abre Blender y ve a Preferences, entonces a la pestaña Add-ons.

  • Selecciona Render: POV-3.7 para habilitar el script.

Uso

Comienzo Rápido

  1. Elige POV-Ray 3.7 desde el selector del motor de renderizado. Entonces, puedes hacer el renderizado, como lo haces usualmente, con el botón Render.

  2. La imagen será renderizada de acuerdo con los parámetros establecidos en las Propiedades.

Los ajustes de renderización globales principales para las instancias, pueden ser cambiados en la pestaña Render. Pero también hay propiedades para el entorno, los materiales (texturas), los objetos, etc., todas accesibles desde otras pestañas, dependiendo del objeto seleccionado (geometría, cámara, luz, …)

Ramas de POV-Ray

Abajo hay una comparación de algunas características de los dos motores disponibles para el exportador:

Característica/Motor/Soporte

POV-Ray

UberPOV

Full Spectral Resolution

✓ (en desarrollo)

Supersampling

Alpha Mapping

Bump Mapping

Normal Mapping

Displacement Mapping

Motion Blur

Subsurface Scattering (SSS)

Volumetric Scattering (Medium)

Blurred Reflections

✓ (muy complicado)

Clay Render

Depth of Field

Material Layering

Thin Film Coating

Dispersion

Anisotropy

Thin Film Interference

Complex IOR Files

Coating Thickness Absorption

Custom Reflectance 90

Custom Fresnel Curve

✓ (tricky)

✓ (tricky)

Sigma Texture

Sun-Pool Caustics

Ambient Occlusion

✗ (tricky)

✓ (en desarrollo)

Lens Shift

Diaphragm Circular/Polygonal

Per-Object Texture Coordinates

Texture Projection Modes

Front/Camera Mapping

✓ (tricky)

✓ (tricky)

Multiple UV Channels

Texture Tone Mapping

✓ (tricky)

✓ (tricky)

Procedural Textures

Texture Layering

Synthesis Texture Layering

Point Lighting

Mesh Lighting

Image-based Lighting

Physical Sun/Sky

✓ (tricky)

✓ (tricky)

HDRI Support

IES Texture Support

Instance Support

Resume/Merge Render

Interactive Render

Vignetting / Bloom / Glare (Post)

✓ (tricky)

✓ (tricky)

Camera Response Function (CRF) (Post)

Color Balance (Post)

Multithreading

Region Rendering

Passive Emitter

Invisible Emitter

Invisible Object

Shadowless Object

Shadowless Point Lights

Bucket Rendering

Propiedades Exportadas de la Interfaz de Usuario

Propiedades del Render

Radiosity

En POV-Ray, «Radiosity» es una interreflexión difusa que no tiene nada que ver con el color de los vértices basado en la radiosidad. En efecto, es más similar a la recopilación de los muestreos de irradiancia y provee un ruido libre de la luz indirecta.

Son incluidos algunos preajustes para la radiosidad, sus nombres y los ajustes de rad_def incluyen el archivo entregado con POV-Ray, estos establecen las propiedades así no necesitas incluir rad_def.inc en el archivo pov exportado, es uno de los muchos ejemplos de lo puede traer una interfaz como Blender a todos los usuarios que no estén acostumbrados al programa.

Ver también

Más detalles en la Wiki de POV-Ray.

Anti-Aliasing

Son soportados tres métodos de muestreo:

  • Non-recursive

  • Recursive

  • Stochastic (Monte Carlo) Sólo disponible para UberPOV.

Sampling Depth

Los valores deben estar comprendidos entre 1 y 9. Los valores más altos incrementan el tiempo de renderizado y pueden introducir algún efecto de blureado no deseado.

Anti-Alias Threshold

En el método simple, no recursivo, inicialmente POV-Ray traza un rayo por píxel. Si el color de un píxel difiere del de sus vecinos (a la izquierda o por encima), por al menos el valor del umbral establecido, entonces el píxel es supermuestreado al lanzar un número dado, fijo, de rayos adicionales. El umbral por defecto es 0.3, pero puede cambiarse usando la opción Antialias_Threshold=n.n.

Ver también

Más detalles en la Wiki de POV-Ray.

Truco

Profundidad del Campo Sin Anti-Aliasing

No usar anti-aliasing cuando esté activada la profundidad de la cámara del campo, acelerará el renderizado y, generalmente, proveerá imágenes suficientemente decentes.

Bounding Method

También llamada aceleración, es establecida por el exportador para BSP automático (Binary Space Partitioning), puesto que generalmente es la más eficiente (sólo POV-Ray 3.7), pero hay disponibles otros métodos de aceleración en POV-Ray.

Ver también

Más detalles en la Wiki de POV-Ray.

Command Line Switches

Pueden ser pasados algunos argumentos de línea de comando a POV-Ray. Los argumentos son separados por espacios. Los interruptores de línea de comando consisten de un signo / (barra), + (más) o - (menos), seguido por uno o más caracteres alfanuméricos y posiblemente un valor numérico.

Ver también

Más detalles en la Wiki de POV-Ray.

Algunos Comandos Comúnmente Usados:

-D: Oculta la imagen mientras renderiza

Usa este interruptor de línea de comando para no mostrar la imagen renderizada en POV-Ray (ligeramente más rápido y más liviano en memoria). La imagen será enviada de vuelta a Blender después de completarse (en Linux éste es un interruptor oculto por defecto, para evitar los problemas del editor específicos al sistema operativo).

+WT: Limita el número de hilos utilizados

Limita a POV-Ray a usar sólo un hilo de renderizado simple. (Así mismo, +WT2 instruiría a POV-Ray a utilizar dos hilos de renderizado.)

+C: Continua un renderizado interrumpido

«Continue trace» es capaz de recuperar el punto en el que se detuvo tu último renderizado y continuar desde allí (incluso si apagaste tu computadora).

/EXIT: Cierra POV-Ray después de renderizar la imagen

There is an option in POV-Ray for Windows interface to do the same: The «On Completion» option to «Exit POV-Ray for Windows» (in the Render menu).

Truco

Fast Preview Renders

Cuando ajustes tu escena por primera vez, y para un renderizado de vista previa rápido, desactiva anti-aliasing, depth of field, photons, Radiosity, expensive material features, y el panel Shading de la escena , desactiva shadows. (Otras características podrían ser desactivadas desde este panel en futuras versiones del exportador.)

Alternativamente, utiliza a los interruptores de línea de comando Quality +q1 a +q11. Estos te permiten deshabilitar fácilmente la mayoría de las características con uso intensivo de la CPU.

Formatting

El archivo POV-Ray exportado puede ser personalizado:

  • Se pueden elegir diferentes caracteres para la sangría.

  • Opción para agregar comentarios al archivo POV-Ray.

  • Opción para escribir listas de coordenadas largas en una línea, para una navegación más fácil del archivo pov (y un parseo ligeramente más rápido por parte del renderizador).

Scene Properties

Color Management

En este momento, se supone que sRGB va a ser usado siempre.

World Properties

Background (Fondo)

World de Blender es exportado:

  • Como background{} de POV-Ray si tiene un solo color.

  • Al usar la opción Blend Sky de Blender, se dispara su exportación como un sky_sphere{} de POV-Ray.

(Actualmente, la textura de cielo aparece un poco diferente a causa de su mapeo).

Atmospheric Media

(Para crear luces volumétricas):

  • Número de muestreos para el cálculo de los materiales.

  • Atmospheric media color

Object Properties

Importance Sampling

Es un valor de prioridad entre 0 y 1, que puede ser establecido por objeto en la pestaña de propiedades de Object para Radiosity, para lanzar más rayos a los objetos que lo requieran. Toca esto de forma cuidadosa cuando intentes mejorar los tiempos del renderizador.

Data Properties

El script exporta cielos, luces, partículas de pelo, humo, fluidos, mallas, blobs (metaballs).

Cámara

Depth of Field

Tiene que estar habilitada para que la propiedad de abajo funcione:

El punto de profundidad focal del campo está basado en el campo Distance o en Object de la interfaz de usuario de Blender.

Aperture

Establece la cantidad de bluring (incrementa para obtener más)

Perturbation

Mapa de normales para el plano de la cámara, pueden ser usados patrones procedurales nativos a POV con la variable:

  • Strength (Fuerza)

  • Turbulence

  • Scale

Lights

El botón conmutador No Shadows, puede ser utilizado para desactivar el trazado de sombras, sólo para luces específicas.

Truco

Para la Atenuación Realista de la Luz

Usar el declive de la inversa del cuadrado, y un pequeño valor de distancia de declive con una intensidad de luz mayor, dará los mejores resultados con la implementación de la ley inversa del cuadrado de POV-Ray. Mira esta discusión.

Smoke

Un archivo DF3 (formato voxel de POV-Ray) es exportado y usado con un contenedor de materiales POV-Ray, con la misma dimensión y resolución que el dominio de humo de Blender.

Hair

Por cada pelo, es exportada y usada una unión de POV-Ray sphere_sweep. Estas pueden tomar el color de una textura aplicada al objeto emisor, y la forma del barrido de la esfera intenta emular la forma de los pelos.

Material Properties

Emission

Truco

Mesh Lights

Cuando es usada conjuntamente con Radiosity, la propiedad Emit te permitirá crear focos o cualquier forma luminosa que realmente ilumine a otros objetos

SSS / SSLT

Notar que SSS en POV-Ray (llamado SSLT) es muy sensible y dará diferentes resultados si las normales de la malla tienen un sombreado suave o uno plano.

Translucency

Iluminación desde atrás de una superficie.

Ver también

Más detalles en la Wiki de POV-Ray.

IOR Mirror

Esta opción es para usar un IOR consistente para el reflejo y la refracción trazados por rayos, y no rompe la ley de conservación de energía entre los dos.

Iridescence

(Fina capa de revestimiento de Newton)

Caustics

  • Dispersión cromática por cáusticos refractivos

  • Cáusticos simulados rápidos (algo así como la Transparencia de Rayos de Blender)

  • Cáusticos refractivos usando fotones

  • Cáusticos refractivos usando fotones (IOR alto o ningún IOR de reflejo para un efecto más fácil.)

Truco

Faster Photons

Para establecer algunos cáusticos, intenta mover desde el valor de profundidad del fotón más pequeño a un mínimo en el que comiences a ver el efecto que estás buscando. Desmarca la propiedad Receive Photons para cualquier objeto que realmente no lo necesite. (Un objeto de vidrio arrojando cáusticos, por lo general no necesita recibir ninguno él mismo.) Entonces, puedes balancear otros parámetros para afinar la distribución de los fotones y el alisado (recolección). No establezcas el espaciado global con mucho detalle en los ajustes de escena, porque entonces aún puedes refinarlo en cada objeto usando su multiplicador de espaciado. Si tu sistema tiene varios hilos, éstos pueden ser usados en la etapa de los fotones: un hilo por luz, así entonces puedes hacer que la iluminación de tu escena sea más compleja sin otros costes.

Shaders

La emulación es intentada desde Blender para:

  • Dibujos animados especulares y difusos (sin bordes aún)

  • Phong and Cook Torrance (ambos lo mismo)

  • Blinn (no es perfectamente correspondido)

  • Ward isotropic

  • Fresnel and Minnaert, empezado pero aún no finalizado

Truco

Vidrios Como Materiales

Cuando intentas conseguir algo de vidrio como material, mantén bajo el valor difuso, oscuro o totalmente negro, para evitar una superficie apagada, y mantén una transparencia clara.

Texture Properties

UV Coordinates

Por ahora, mejor con una proyección plana. (Silvio Falcinelli)

Texture Channels

Las influencias de las texturas actualmente soportadas son: Alpha, Diffuse, Bump, Specular, Mirror utiliza el mismo canal que Specular). (Ningún otro canal, dada la sintaxis no uniforme de POV-Ray para ellos.)

Custom Gamma

Para texturas de imágenes (lee la documentación de POV-Ray 3.7 antes de usarla, puesto que por lo general no necesita ser usada).

Ver también

Más detalles en la Wiki de POV-Ray.

Custom POV Code

Los archivos POV-Ray no sólo son archivos de datos puros (a diferencia de la mayoría de los otros renderizadores). Son programas, con loops, funciones, etc. Esto significa que no importa cuántas características pueda soportar este exportador, POV-Ray siempre tendrá muchas más para ofrecer.

Video Tutorial

Aquí hay una demostración del exportador de SMcA. Actualmente se está trabajando sobre este video y podría ser reemplazado en el futuro.

Paso a Paso

Puedes agregar código POV personalizado directamente en el editor de texto de Blender, todo lo que tienes que hacer es asegurarte de que este código POV tenga directa o indirectamente una palabra clave #declare, seguida por el nombre de tu elección, y el ítem POV que quieras utilizar. (Actualmente, la sintaxis de POV es más cercana a C que a Python, así que cualquier cosa que le siga a la doble barra (//) es un comentario.)

Agregando Código POV Directamente

Los ítems POV pueden ser cualquier cosa, pero por ahora sólo puede ser reemplazado el equivalente de los materiales de Blender con este método. En POV-Ray, se llama texture {}, no te confundas, realmente incluye todas las propiedades del material.

Aunque puedes especificar directamente un bloque texture {} en los archivos POV-Ray, la directiva #declare te permite asignarlo a una variable y reutilizarlo más fácilmente. El exportador hace uso de esta característica por defecto, así que no serás capaz de usar tu textura personalizada a menos que la declares. Aquí hay un ejemplo:

#declare MyTexture =
texture{
    pigment{
        brick color rgb< 0.99, 0.99, 0.99>  // color mortar
        color rgb< 0.75, 0.5, 0.30>*0.75  // color brick
        brick_size <0.25, 0.0525, 0.125> // format in X, Y and Z-direction
        mortar 0.01                      // size of the mortar
        scale 3
    } // end of pigment
    normal {wrinkles 0.75 scale 0.01}
    finish {ambient 0.15 diffuse 0.95 phong 0.2}
    rotate<0,0,0>  translate< 0.01, 0.00, 0.00>
} // end of texture
  1. Abre el Sidebar del Editor de Texto.

  2. En la opción de las propiedades de la vista de texto, puedes elegir la Vista en 3D y/o el texto del render. Habilita Both.

  3. Extensiones para detectar el resaltado de la sintaxis pov/inc/mcr/ini.

  4. Algunas escenas POV-Ray completas están disponibles en el menú de la cabecera Templates.

  5. Y un menú Insert para agregar sólo algunos fragmentos de código POV en la ubicación del cursor.

  6. Entonces tienes que ir en las propiedades del material al campo*Custom POV Code*, y escribir el nombre del ítem que declares para utilizar: «MyTexture» en el ejemplo dado. Entonces puedes renderizar normalmente a tu imagen y el material será reemplazado.

Blender y POV-Ray no tienen los mismos sistemas de coordenadas: POV tiene Y hacia arriba, mientras que Blender tiene Z hacia arriba, así que se espera que el texto del contenido generado no resulte ser el mismo que los ítems exportados de la interfaz de usuario, puesto que el exportador agrega una matriz de transformación a todas las entidades exportadas. Así que si quieres especificar orientaciones más intuitivamente, al mirar la interfaz, tienen que ser especificadas algunas transformaciones al final de tus bloques personalizados, por ejemplo como a continuación:

scale <-1, 1, 1>
rotate <90, 0, -90>
}

Agregando código POV a partir de los Archivos Incluidos

Puedes usar la directiva #include en cualquier escena de POV-Ray para agregar ítems desde un archivo POV-Ray externo. Es como la función import de Python. Los archivos incluidos tienen a .inc como la extensión de su nombre. Entonces en el campo de reemplazo, puedes escribir cualquiera de los nombres disponibles declarados en el archivo incluido. Pov-Ray se entrega con un montón de archivos incluidos «listos para usarse». Así que que puedes usarlos para tus texturas, pero también puedes usarlos para algunos de sus elementos. Por ejemplo, un archivo incluido, muy comúnmente usado, es aquel que permite llamar a los colores por sus nombres, en lugar de usar números, llamado colors.inc, de esta forma, el ejemplo previo también podría ser escrito:

#include "colors.inc"
#declare MyTexture =
texture{
    pigment{
        brick color White*0.99  // color mortar
        color rgb< 0.75, 0.5, 0.30>*0.75  // color brick
        brick_size <0.25, 0.0525, 0.125> // format in x, y and z- direction
        mortar 0.01                      // size of the mortar
        scale 3
    } // end of pigment
    normal {wrinkles 0.75 scale 0.01}
    finish {ambient 0.15 diffuse 0.95 phong 0.2}
    rotate<0,0,0>  translate< 0.01, 0.00, 0.00>
} // end of texture

También están disponibles algunos otros objetos específicos a POV-Ray: En POV-Ray una malla de triángulos es sólo una primitiva entre muchas otras. Puedes explorar el lenguaje de POV-Ray al modificar el archivo de salida y, con el mismo método, agregar estas primitivas a mano, o puedes seleccionar algunas del menú Add.

Primitivas de POV-Ray

The Add menu in the 3D Viewport allows you to add POV-Ray specific objects in addition to native Blender objects.

A diferencia de las mallas, son formas definidas matemáticamente. Los lados de la esfera, el toroide, el cilindro o el cono siempre estarán redondeados y alisados cuando sean renderizados, sin importar cuán cerca los tengas, e independientemente de su apariencia en el 3D Viewport, que sólo es una representación.

Estos objetos son el tipo de objetos que son creados cuando importas un archivo POV-Ray, así que, idealmente, podrías «intercambiar» los datos entre POV-Ray y Blender, de un lado hacia el otro.

Plano Infinito

El plano renderizado en realidad es infinito, pero en el 3D Viewport se ve una representación, que es muy grande, pero aún finita. Por favor, reporta si te gustaría tener una escala por defecto diferente.

Ver también

Más detalles en la Wiki de POV-Ray.

Box (Caja)

Basado en un cubo de malla, el objeto puede ser transformado usando mover/rotar/escalar

Ver también

Más detalles en la Wiki de POV-Ray.

Sphere (Esfera)

La esfera tiene un parámetro radio, una ubicación y una escala.

Ver también

Más detalles en la Wiki de POV-Ray.

Cylinder

En POV-Ray, los cilindros son definidos por un radio, un punto base y un punto final. Por conveniencia, pueden ser usados mover/rotar/escalar para obtener el mismo efecto.

Ver también

Más detalles en la Wiki de POV-Ray.

Cone (Cono)

Los conos tienen un radio de base y un radio final.

Ver también

Más detalles en la Wiki de POV-Ray.

Torus

El toroide tiene un radio principal y un radio de sección.

Ver también

Más detalles en la Wiki de POV-Ray.

Parametric

Esta es una superficie generada a partir de la combinación de tres ecuaciones matemáticas.

Ver también

Más detalles en la Wiki de POV-Ray.

Rainbow

El arco iris es un efecto dependiente de la vista.

Ver también

Más detalles en la Wiki de POV-Ray.

Lathe

Este objeto se comporta como el modificador Blender Screw, para crear superficies al girar un spline, excepto que en lugar de estar teselado de ante mano, éste sigue la curvatura matemática del spline así que no verás ningún polígono, sin importar lo cerca que pongas el zoom.

Ver también

Más detalles en la Wiki de POV-Ray.

Prism

Esta es una primitiva de POV-Ray que simplemente extrude una forma.

Ver también

Más detalles en la Wiki de POV-Ray.

Superquadric Ellipsoid

Una herramienta bastante versátil, que puede proveer rápidamente modelos para objetos como almohadones o estrellas.

Ver también

Más detalles en la Wiki de POV-Ray.

Height Field

Este es el desplazamiento de una superficie siguiendo a una textura. El teselado también ocurre en tiempo de renderizado, así que no tienes que subdividir nada de antemano.

Ver también

Más detalles en la Wiki de POV-Ray.

Sphere Sweep

Esta primitiva de POV-Ray barre una esfera de acuerdo al largo de un spline, para crear una forma interpolada que puede tener variaciones del radio a lo largo del spline. También es usado para exportar mechones de pelo.

Ver también

Más detalles en la Wiki de POV-Ray.

Blob Sphere

Como el metaballs de Blender.

Ver también

Mas detalles en la Wiki de POV-Ray.

Isosurfaces

En las isosuperficies de POV-Ray están los objetos que se pueden combinar, y que pueden ser deformados, usando pigmentos o ecuaciones.

Ver también

Más detalles en la Wiki de POV-Ray.

Isosurface Box

Un componente de isosuperficie formado como una caja.

Isosurface Sphere

Un componente de isosuperficie formado como una esfera.

Supertorus

Una isosuperfice formada como un toroide, con los parámetros de deformación equivalentes a aquellos del superelipsoide.

Parámetros (nombres de POV-Ray):

MajorRadius, MinorRadius

Radios base para el toroide.

MajorControl, MinorControl

Controles para la redondez del supertoroide. Usa números en el rango [0, 1].

Accuracy

El parámetro accuracy.

MaxGradient

El parámetro max_gradient.

Macro Based Primitives

Dos primitivas que en realidad son macros que generan una malla a partir de curvas, antes del tiempo de renderizado:

  • Polygon to Circle Blending

  • Loft

Importando Archivos POV-Ray

  1. Desde el mismo menú Add, también puedes importar archivos POV-Ray.

  2. O sino, haciendo click en File ‣ Import, desde el menú Topbar.

  3. Entonces puedes seleccionar uno o varios archivos.

Referencia

Categoría

Render

Descripción

Integración de POV-Ray 3.7 para Blender.

Location

Render ‣ Engine ‣ POV-Ray 3.7

Archivo

Carpeta render_povray

Autor

Campbell Barton, Maurice Raybaud, Leonid Desyatkov, Bastien Montagne, Constantin Rahn, Silvio Falcinelli

License

GPL

Nota

Este add-on está empaquetado con Blender.