Introduction

La simulation de fumée est un sous-ensemble de système de fluides, et peut être utilisée pour simuler des collections de solides aériens, des particules liquides et des gaz, tels que ceux constituant la fumée. Elle simule le mouvement fluide de l’air et produit des textures de voxel animées représentant la densité, la chaleur, et la vitesse d’autres fluides ou de particules suspendues (ex. la fumée) qui peuvent être utilisés pour le rendu.

../../_images/physics_smoke_types_domain_note-on-resolution.jpg

Exemple de simulation de fumée.

La fumée et le feu sont émis dans un domaine depuis un objet mesh ou un système de particules. Le mouvement de la fumée est contrôlé par l’écoulement de l’air à l’intérieur du domaine, lequel peut être influencé par les objets de collision de fumée. La fumée va aussi être affectée par la gravité de la scène et les champs de force. L’écoulement de l’air à l’intérieur du domaine peut affecter d’autres simulations physiques via le champ de force de Smoke Flow (flux de fumée).

Flux de travail

Au moins un objet Domain et un objet Flow sont requis pour créer une simulation de fumée. Un flux de travail de base ressemble à ceci :

  1. Créer un objet domaine qui définit les limites du volume de simulation.

  2. Définir un/des objet(s) flux qui va/vont émettre de la fumée et du feu.

  3. Configurer les objets de collision pour faire interagir la fumée avec les objets dans la scène.

  4. Assigner un matériau volumétrique à l’objet domaine.

  5. Sauvegarder le fichier blend.

  6. Précalculer la simulation.

Note

Il existe un opérateur Quick Smoke (fumée rapide) qui va automatiquement créer un objet domaine avec un matériau fumée/feu de base. Il se trouve dans le 3D View ‣ Object ‣ Quick Effects ‣ Quick Smoke, ou avec le menu de recherche de l’opérateur Espace.

Note

La simulation de fumée dans Blender est fondée sur l’article Wavelet Turbulence for Fluid Simulation et le code d’exemple associé.