Édition

../../../_images/rigging_armatures_posing_editing_tools.png

Outils de Pose.

En Mode Pose, les os se comportent comme des objets. Ainsi les actions de transformation (grab/rotate/scale, etc.) sont très semblables aux mêmes actions en Mode Objet (toutes celles disponibles sont regroupées dans le sous-menu Pose ‣ Transform). Cependant, il y a quelques spécificités importantes :

  • Les relations des os sont cruciales (voir bone_relations_parenting).

  • Le « centre de transformation » d’un os donné (càd. que son point pivot par défaut, quand il est le seul sélectionné) est sa racine. Notez d’ailleurs que certains options de point pivot semblent ne pas fonctionner proprement. En fait, à l’exception de celle du Curseur 3D, toutes les autres semblent toujours utiliser le point médian de la sélection (et pas par ex. la racine de l’os actif quand Active Object est activé, etc.).

Posing de base

Comme indiqué précédemment, les transformations d’os sont effectuées par rapport à la Position de repos de l’armature, qui est l’état tel que défini en Mode Édition. Ce qui signifie qu’en position de repos, en Mode pose, chaque os a une échelle de 1.0, et une rotation et une position nulles (comme vous pouvez le voir dans le panneau Transform, dans les Vues 3D).

../../../_images/rigging_armatures_posing_editing_local-rotation.png

un exemple de rotation verrouillée sur l’axe Y local, avec deux os sélectionnés.

Notez que les deux lignes vertes matérialisant les axes sont centrées sur le centre de l’armature, et non sur la racine de chaque os…

De plus, l’espace local pour ces actions est celui propre à l’os (visible quand vous activez l’option Axes du panneau Armature), C’est particulièrement important dans le verrouillage d’axes, par exemple, il n’y a pas d’outil de « roulis d’os » spécifique en Mode Pose, étant donné que vous pouvez tourner autour de l’axe principal de l’os simplement en verrouillant l’axe Y local R-Y-Y… Cela fonctionne aussi avec plusieurs os sélectionnés ; chaque os est verrouillé sur son propre axe local !

When you pose your armature, you are supposed to have one or more objects skinned on it! And obviously, when you transform a bone in Pose Mode, its related objects or object’s shape is moved/deformed accordingly, in real-time. Unfortunately, if you have a complex rig set-up and/or a heavy skin object, this might produce lag, and make interactive editing very painful. If you experience such troubles, try enabling the Delay Deform button of the Armature panel the skin objects will only be updated once you validate the transform operation.

Auto IK

Référence

Mode

Mode Pose

Panneau

Tool Shelf ‣ Options ‣ Pose Options

L’option auto IK dans le Tool Shelf active une contrainte IK temporaire au positionnement des os. La chaîne agit depuis la pointe de l’os sélectionné à la racine de l’os parent du plus haut rang. Notez que ce mode manque d’options, et fonctionne uniquement en appliquant la transformation résultante aux os de la chaîne.

Clear Transform

Référence

Mode

Mode Pose

Menu

Pose ‣ Clear Transform

Raccourci

Alt-G, Alt-R, Alt-S

Une fois certains os transformés, si vous voulez revenir à leur position de repos, effacez simplement leurs transformations.

Location, Rotation, Scale Alt-G, Alt-R, Alt-S

Efface les transformations individuelles.

All

Pour tout effacer d’un coup.

Reset Unkeyed

Efface les transformations de l’état de leur trame clé. Cet opérateur est aussi disponible dans le menu Specials ‣ Clear User Transform.

Only Selected

Opérer sur les seuls os sélectionnés ou tous les os.

Notez que dans la visualisation Envelope, Alt-S n’efface pas l’échelle, mais met plutôt à l’échelle la zone d’influence Distance des os sélectionnés (aussi disponibles à travers l’entrée de menu Pose ‣ Scale Envelope Distance, qui est uniquement effective dans la visualisation Envelope, même si elle est toujours disponible…).

Apply

Référence

Mode

Mode Pose

Menu

Pose ‣ Apply

Raccourci

Ctrl-A

Inversement, vous pouvez définir la pose courante comme la nouvelle position de repos (càd. « appliquer » les transformations courantes au Mode Édition), en utilisant l’entrée de menu Pose ‣ Apply Pose as Restpose (ou Ctrl-A et confirmer le menu déroulant). Quand vous procédez ainsi, les objets/géométrie skinné(s) sont/est également remis à leur/sa valeur par défaut, état non déformé, ce qui signifie généralement que vous devrez le skinner à nouveau.

In-Betweens

Il y a plusieurs outils pour l’édition des poses dans une animation.

Il y a aussi en Mode Pose un ensemble d’options/outils d’édition spécifiques d’armature, comme auto-bones naming, properties switching/enabling/disabling, etc., que nous avons déjà décrits dans les pages d’édition d’armature. Voir les liens ci-dessus…

Push Pose

Référence

Mode

Mode Pose

Panneau

Tool Shelf ‣ Tool ‣ Tool ‣ Pose Tools ‣ In-Betweens: Push

Menu

Pose ‣ In-Betweens ‣ Push Pose

Raccourci

Ctrl-E

Push pose exagère la pose courante.

Relax Pose

Référence

Mode

Mode Pose

Panneau

Tool Shelf ‣ Tool ‣ Pose Tools ‣ In-Betweens: Relax

Menu

Pose ‣ In-Betweens ‣ Relax Pose

Raccourci

Alt-E

Relax pose is somewhat related to the above topic, but it is only useful with keyframed bones. When you edit such a bone (and hence take it « away » from its « keyed position »), using this tool will progressively « bring it back » to its « keyed position », with smaller and smaller steps as it comes near it.

Breakdowner

Référence

Mode

Mode Pose

Panneau

Tool Shelf ‣ Tool ‣ Pose Tools ‣ In-Betweens: Breakdowner

Menu

Pose ‣ In-Betweens ‣ Pose Breakdowner

Raccourci

Maj-E

Creates a suitable breakdown pose on the current frame.

L’outil Breakdowner peut être contraint à fonctionner sur des transformations et des axes spécifiques, en pressant les touches suivantes pendant que l’outil est actif :

  • G, R, S: translate, rotate, scale

  • B: Bendy bones

  • C: propriétés personnalisées (custom properties)

  • X, Y, Z: vers les axes corrspondants

Copy/Paste Pose

Référence

Mode

Mode Pose

Header

Copy/Paste (copy-paste)

Panneau

Tool Shelf ‣ Tool ‣ Pose Tools ‣ Pose: Copy, Paste

Menu

Pose ‣ Copy Current Pose, Pose ‣ Paste Pose, Pose ‣ Paste X-Flipped Pose

Blender vous permet de copier et de coller une pose, soit via le menu Pose, soit directement en utilisant les trois boutons de copier/coller dans la partie droite de l’entête de la Vue 3D :

Copy Current Pose

Copier la pose courante des os sélectionnés dans le tampon pose.

Paste Pose

Coller la pose en tampon dans l’armature en cours de posing.

Paste X-Flipped Pose

Coller la pose en tampon X axis mirrored dans l’armature en cours de posing.

Voici des points importants :

  • Cet outil fonctionne au niveau d’une session de Blender, ce qui signifie que vous pouvez l’utiliser avec les armatures, les scènes, et même les fichiers. Cependant, le tampon pose n’est pas enregistré, de sorte que vous le perdez quand vous fermez Blender.

  • il y a un seul tampon pose.

  • Seuls les os sélectionnés sont pris en compte pendant la copie (càd. que vous copiez uniquement la pose des os sélectionnés).

  • During pasting, on the other hand, bone selection has no importance. The copied pose is applied on a per-name basis (i.e. if you had a forearm bone selected when you copied the pose, the forearm bone of the current posed armature will get its pose when you paste it – and if there is no such named bone, nothing will happen…).

  • Ce qui est copié et collé est en fait la position/rotation/échelle de chaque os, dans son propre espace. Ce qui signifie que la pose collée résultante pourrait être très différente de celle copiée originellement, selon : - la position de repos des os, et - la pose courante de leurs parents.

../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-1.png

La position de repos de notre armature d’origine.

../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-2.png

La position de repos de notre armature de destination.

Exemples de copie/collage de pose.
../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-3.png

la première pose copiée (notez que seuls deux os sont sélectionnés et par conséquent copiés).

../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-4.png

… collés sur l’armature de destination…

../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-5.png

… et collés en miroir sur l’armature de destination.

../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-6.png

La même pose que ci-dessus est copiée, mais cette fois avec tous les os sélectionnés, …

../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-7.png

… pasted on the destination armature…

../../../_images/rigging_armatures_posing_editing_copy-paste-pose-examples-8.png

… et collés en miroir sur l’armature de destination.

Propagate

Référence

Mode

Mode Pose

Panneau

Tool Shelf ‣ Tool ‣ Pose Tools ‣ Pose: Propagate

Menu

Pose ‣ Propagate

Raccourci

Alt-P

The Propagate tool copies the pose of the selected bones on the current frame over to the keyframes delimited by the Termination Mode. It automates the process of copying and pasting.

Options

Termination Mode

Modes qui déterminent la manière dont il décide quand arrêter l’écrasement des trames clés.

While Held

Le plus compliqué des modes disponibles, étant donné qu’il essaie de deviner quand arrêter la propagation en examinant les pauses dans les courbes d’animation par contrôle (toutes les F-Curses pour un os, au lieu d’un par F-Curve).

To Next Keyframe

Copie simplement la pose dans la première kexframe après (mais ne comprenant aucune kexframe) la frame courante.

To Last Keyframe

Va simplement remplacer la dernière keyframe (càd en rendant l’action cyclique).

Before Frame

À toutes les trames clés entre la trame courante et l’option End frame. Cette option est mieux adaptée pour une utilisation dans des scripts du fait des difficultés dans le réglage de la valeur de cette trame, bien qu’il est possible de la définir manuellement via le panneau Operator si nécessaire.

Before Last Keyframe

à toutes les trames clés depuis la trame courante jusqu’à ce qu’il y en ait plus aucune.

On Selected Keyframes

Va appliquer la pose des os sélectionnés à toutes les trames clés sélectionnées.

On Selected Markers

À toutes les trames clés apparaissant dans des trames avec des marqueurs de scène après la trame courante.

End Frame

Définit la limite supérieure de l’intervalle de trames dans laquelle des trames clés seront affectées (avec la trame courante comme la limite inférieure).

Show/Hide

Référence

Mode

Tous modes

Panneau

Properties editor ‣ Bone ‣ Display

Menu

… ‣ Show/Hide

Vous n’avez pas à utiliser les calques d’os pour afficher/cacher certains os. Comme avec les objets, les sommets ou les points de contrôles, vous pouvez utiliser H :

  • H va cacher le(s) os sélectionné(s).

  • Maj-H va cacher tous les os sauf le(s) os sélectionné(s).

  • Alt-H va afficher tous les os cachés.

Vous pouvez aussi utiliser la case à cocher Hide de Bone tab ‣ Display panel.

Notez que les os cachés sont spécifiques à un mode, càd. que vous pouvez cacher certains os en Mode Édition, ils seront toujours visibles en Mode Pose, et vice-versa. Les os cachés en Mode Pose sont aussi invisibles en Mode Objet. Et en Mode Édition, l’os à cacher doit être entièrement sélectionné, pas simplement sa racine ou sa pointe.