Subdividir

Referência

Mode:Edit Mode
Panel:Tool Shelf ‣ Tools ‣ Mesh Tools ‣ Add: Subdivide
Menu:Mesh ‣ Edges ‣ Subdivide, Specials ‣ Subdivide/Subdivide Smooth

Subdividing splits selected edges and faces by cutting them in half or more, adding new vertices, and subdividing accordingly the faces involved. It adds resolution to the mesh by divide faces or edges into smaller units.

This process follows a few rules, depending on the settings:

  • When only one edge of a face is selected (Triangle mode), triangles are subdivided into two triangles, and quads, into three triangles.
  • When two edges of a face are selected:
    • If the face is a triangle, a new edge is created between the two new vertices, subdividing the triangle in a triangle and a quad.
    • If the face is a quad, and the edges are neighbors, we have three possible behaviors, depending on the setting of Corner Cut Type (the select menu next to the Subdivide button, in Mesh Tools panel). See below for details.
    • If the face is a quad, and the edges are opposite, the quad is just subdivided in two quads by the edge linking the two new vertices.
  • When three edges of a face are selected:
    • If the face is a triangle, this means the whole face is selected and it is then subdivided in four smaller triangles.
    • If the face is a quad, first the two opposite edges are subdivided as described above. Then, the «middle» edge is subdivided, affecting its new «sub-quad» as described above for only one edge.
  • When four edges of a face (a quad) are selected, the face is subdivided into four smaller quads.

Opções

These options are available in the Tool Panel after running the tool;

Número de cortes
Specifies the number of cuts per edge to make. By default this is 1, cutting edges in half. A value of 2 will cut it into thirds, and so on.
Suavidade

Displaces subdivisions to maintain approximate curvature. The effect is similar to the way the Subdivision Surface Modifier might deform the mesh.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_smooth-before.png

A malha antes da operação de subdividir.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_smooth-none.png

Subdividida sem suavização.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_smooth-after.png

Subdividida com suavização de valor 1.

Modo de quadriláteros e triângulos
Forces subdivide to create triangles or quads instead of n-gons (see examples below). This mode doesn’t allow the use of Straight Cut on quad corners.
Tipo de cortes para quinas

This select menu controls the way quads with only two adjacent selected edges are subdivided.

Aletas
The quad is subdivided in a fan of four triangles, the common vertex being the one opposite to the selected edges.
Vértices internos
The selected edges are subdivided, then an edge is created between the two new vertices, creating a small triangle. This edge is also subdivided, and the «inner vertex» thus created is linked by another edge to the one opposite to the original selected edges. All this results in a quad subdivided in a triangle and two quads.
Caminho
First an edge is created between the two opposite ends of the selected edges, dividing the quad in two triangles. Then, the same goes for the involved triangle as described above.
Cortes retos
The selected edges are subdivided, then an edge is created between the two new vertices, creating a small triangle and n-gon.
../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-fan2.png

Tipo de corte em aletas.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-innervert.png

Inner vertices cut type.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-path.png

Tipo de corte em caminho.

Fractal

Displaces the vertices in random directions after the mesh is subdivided.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-before.png

O plano antes da subdivisão.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-none.png

Subdivisão regular.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-after1.png

Same mesh with fractal added.

Ao longo das normais

Causes the vertices to move along their normals, instead of random directions.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-along-normal.png

Ao longo das normais definido para 1.

Semente aleatória

Changes the random seed of the Fractal noise function, producing a different result for each seed value.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_fractal-after2.png

Same mesh with a different seed value.

Exemplos

Below are several examples illustrating the various possibilities of the Subdivide and Subdivide Multi tools. Note the selection after subdivision.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_before.png

A malha de exemplo.

Uma aresta

../../../../_images/modeling_meshes_editing_subdividing_subdivide_one-edge.png

One Edge.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_one-edge-tri.png

Modo de quadriláteros e triângulos

Duas arestas de triângulos

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-tri.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-tri-tri.png

Modo de quadriláteros e triângulos

Two Opposite Quad Edges

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-opposite.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-opposite-tri.png

Modo de quadriláteros e triângulos

Two Adjacent Quad Edges

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-fan2.png

Tipo de corte em aletas.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-fan.png

Modo de quadriláteros e triângulos

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-innervert.png

Tipo de corte nos vértices internos.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-innervert-tri.png

Modo de quadriláteros e triângulos

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-path.png

Tipo de corte em caminho.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_two-edges-quad-path-tri.png

Modo de quadriláteros e triângulos

Três arestas

../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges-tri2.png

Modo de quadriláteros e triângulos

Triângulos

../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges-tri.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_three-edges-tri-tri.png

Modo de quadriláteros e triângulos

Quadriláteros / Quatro arestas

../../../../_images/modeling_meshes_editing_subdividing_subdivide_four-edges.png
../../../../_images/modeling_meshes_editing_subdividing_subdivide_four-edges-tri.png

Modo de quadriláteros e triângulos

Múltiplos cortes

../../../../_images/modeling_meshes_editing_subdividing_subdivide_tri-multi.png

Triângulo com dois cortes.

../../../../_images/modeling_meshes_editing_subdividing_subdivide_quad-multi.png

Quadrilátero com dois cortes.

(De-)Subdividir

Referência

Mode:Edit Mode
Menu:Mesh ‣ Edges ‣ Un-Subdivide

Unsubdivide functions as the reverse of subdivide by attempting to remove edges that were the result of a subdivide operation. If additional editing has been done after the subdivide operation, unexpected results may occur.

Interações
Quantas subdivisões serão removidas.