Editing

Transform

A ser feito.

Snap

A ser feito.

Gerando e gravando ações

Reference

Editor

Nonlinear Animation (animação não linear)

Menu

Edit ‣ Bake Action

Reference

Editor

3D Viewport

Mode

Object and Pose Modes

Menu

Header ‣ Object Animation ‣ Bake Action…

The final motion of objects or bones depends not only on the keyframed animation, but also on any active F-Curve modifiers, drivers, and constraints. On each frame of all the scene’s frames, the Bake Action operator computes the final animation of the selected objects or bones with all those modifiers, drivers, and constraints applied, and keyframes the result.

This can be useful for adding deviation to a cyclic action like a Walk Cycle, or to create a keyframe animation created from drivers or constraints.

Duplicar

Reference

Menu

Menu: Editar ‣ Duplicar

Creates a new instance of the selected strips with a copy of the action.

Duplicar vinculando

Reference

Menu

Menu: Editar ‣ Duplicar vinculando

Atalho

Alt-D

The contents of one Action strip can be instanced multiple times. To instance another strip, select a strip, go to Edit ‣ Linked Duplicate. It will uses the same action as the selected strips.

Now, when any strip is tweaked, the others will change too. If a strip other than the original is tweaked, the original will turn to red.

../../_images/editors_nla_editing_linked-strip-edit.png

Linked duplicated strip being edited.

Split Strips

A ser feito.

Recarregar faixas

A ser feito.

Delete Tracks

A ser feito.

Toggle Muting

A ser feito.

Apply Scale

A ser feito.

Clear Scale

A ser feito.

Sync Action Length

A ser feito.

Tornar usuário único

Reference

Menu

Menu: Editar ‣ Duplicar vinculando

Atalho

U

This tool ensures that none of the selected strips use an action which is also used by any other strips.

Nota

This does not recursively go inside meta strips.

Trocar faixas

A ser feito.

Move Strips Up

A ser feito.

Move Strips Down

A ser feito.

Track Ordering

A ser feito.

Remover dados de animação vazios

Reference

Menu

Menu: Editar ‣ Remover dados de animação vazios

Este operador remove todos os blocos de animação («AnimData») que estiverem «vazios» (restritos para aqueles que estiverem visíveis no editor de animação a partir do qual eles foram executados), ou seja, aqueles que não possuírem ações, controladores, e trilhas ou faixas de animação não linear).

Em alguns casos é possível que você termine com muitos blocos de dados que possuem contêineres de dados de animação antigos e / ou não utilizados que ainda estejam anexados. Isto ocorre mais comumente quando se fazem trabalhos de animações de aberturas (movimentações gráficas), (ou seja, quando alguns objetos vinculados podem ter sido anteriormente usados para o desenvolvimento de um conjunto de recursos de biblioteca reutilizável), e que sejam particularmente distrativos dentro do editor de animação não linear.

Iniciar a edição da ação armazenada

Reference

Menu

Edit ‣ Start Editing Stashed Action

Atalho

Atalho: Shift-Tab

It will enter and exit Tweak Mode as usual, but will also make sure that the action can be edited in isolation (by flagging the NLA track that the action strip comes from as being «solo»). This is useful for editing stashed actions, without the rest of the NLA Stack interfering.

When you finished editing the strip, simply go to Edit ‣ Stop Editing Stashed Action or press Shift-Tab.

../../_images/editors_nla_editing_nla-mode.png

Faixa no modo de animação não linear.

../../_images/editors_nla_editing_edit-mode.png

Faixa no modo de ajuste.

Start Tweaking Strips Actions (Full Stack)

Reference

Menu

Edit ‣ Start Tweaking Strips Actions (Full Stack)

Allows you to edit the contents of the strip without disabling all the tracks above the tweaked strip. This allows keyframing to work as expected, and preserves the pose that you visually keyed.

When you finished editing the strip, simply go to Edit ‣ Stop Tweaking Strips Actions or press Tab.

Nota

For transitions above the tweaked strip, keyframe remapping will fail for channel values that are affected by the transition. A work around is to tweak the active strip without evaluating the upper NLA stack.

Start Tweaking Strips Actions (Lower Stack)

Reference

Menu

Edit ‣ Start Tweaking Strips Actions (Lower Stack)

Atalho

Atalho: Tab

The contents of Action strips can be edited, but you must be in Tweak Mode to do so. The keyframes of the action can then be edited in the Dope Sheet.

When you finished editing the strip, simply go to Edit ‣ Stop Tweaking Strips Actions or press Tab.