旋绕

参考

模式:编辑模式
面板:工具栏 ‣ 工具 ‣ 网格工具 ‣ 添加: 旋绕
快捷键:Alt-R

旋绕 工具绕特定点和轴向旋转,挤出(当选中项为流形时复制)选中元素。

使用 旋绕 工具来生成类似车床做出的结果(因为这个原因,该工具常被称做"旋转"或"扫掠" )。事实上,它确实是以3D游标为中心,并且围绕着垂直于工作视图的轴向,生成选中元素的某种环状挤出。

  • 观察点决定挤出围绕的轴向。
  • 3D游标的位置将是旋绕的中心。

选项

步数
指定"扫掠"后挤出的复制体数量。
复制
选中时,原始结构与旋绕结果是分开的独立结构(即与旋绕挤出的结果断开)。
角度
指定旋绕"扫过"的角度,单位度(比如,180表示半圈)。
中心
指定旋绕的中心,默认使用3D游标位置。
轴向
指定旋绕表示轴向的向量,默认使用当前视角轴向(视图)。

范例

../../../../_images/modeling_meshes_editing_duplicating_spin_glass-profile.png

杯子轮廓。

首先,为物体创建表示轮廓的网格。如果需要建模的是中空物体,对轮廓线直接加厚也不错。图 杯子轮廓。 展示了我们即将演示建模过程的酒杯的轮廓。

进入 编辑模式,按下 A 全选轮廓的所有顶点。

我们将在顶视图围绕3D游标旋绕这个对象,因此按下 Numpad7 切换到顶视图。

../../../../_images/modeling_meshes_editing_duplicating_spin_glass-profile-before.png

旋绕之前,编辑模式下杯子轮廓的顶视图。

沿中心线选择一个顶点,再使用 网格 ‣ 游标 ‣ 选中项 将3D游标吸附到选中点的位置,这样将游标置于轮廓的中心。(图 旋绕之前,编辑模式下杯子轮廓的顶视图。)显示了顶视图下的酒杯轮廓,游标已放置到正确位置。

点击 旋绕 按钮。若打开的3D视图不只1个,光标将变成带问号的箭头,需要在顶视图所在区域单击方可继续。若你只打开了1个3D视图,旋绕操作将立即进行。图 旋绕后的轮廓。 显示了成功旋绕的结果。

角度

旋绕后的轮廓。
../../../../_images/modeling_meshes_editing_duplicating_spin_spun-profile360.png

360度旋绕后的轮廓。

../../../../_images/modeling_meshes_editing_duplicating_spin_spun-profile120.png

120度旋绕后的轮廓。

复制

../../../../_images/modeling_meshes_editing_duplicating_spin_result.png

旋绕操作的结果。

../../../../_images/modeling_meshes_editing_duplicating_spin_dubli.png

勾选复制的结果。

合并重叠点

../../../../_images/modeling_meshes_editing_duplicating_spin_dublicate-vertices.png

重叠点。

旋绕操作会留下重叠点。你可以用框选 B 来选择接缝处所有的顶点(如图 重叠点。),然后执行 移除重叠点 操作。

注意 移除重叠点 前后选中顶点的数目。若一切顺利,最终顶点数(本例中为38)应该与原始轮廓的顶点数量一致,顶点数量的查看方式在 网格数据 ‣ 顶点与面数量 已经介绍过了。如不一致,应该是遗漏了某些顶点,你需要手动焊接。如果太多的顶点需要合并,情况会更糟。

Note

合并两个顶点为一个

要把两个顶点合并(焊接)到一起, Shift-RMB 点击同时选中两个顶点。按下 S 开始缩放,并在缩放时按住 Ctrl ,沿X,Y,Z方向都缩放到0。 LMB 单击完成缩放操作,并点击工具栏中的 移除重叠点 按钮(也可以使用 专用项 ‣ 移除重叠点)。

另外,还可以在专用项菜单选择 专用项 ‣ 合并 (或快捷键 Alt-M)。然后,在弹出菜单中,选择合并的顶点位于选中点的中心还是在3D游标处。在本例中第一个选择更好!

重新计算法线

现在就只剩下全选所有顶点,按下 Ctrl-N ,在弹出菜单中选择 向外重算法线方向