法向

简介

在几何中,法向是指垂直于某种元素(通常是一个三角面或一个曲面) 的方向或直线,但也可以是相对于一条直线、曲线上一点的切线或曲面上一点的相切面。

../../../_images/modeling_meshes_editing_normals_viewport.png

环体面法向可视化。

在上图中,每条蓝线都表示环体上一个面的法向。这些直线都是垂直于其所在面的。可以在 网格显示面板 启用显示法线。

着色

参考

模式:物体模式
面板:Tool Shelf ‣ Tools ‣ Edit ‣ Shading

参考

模式:编辑模式
面板:Tool Shelf ‣ Shading / UVs ‣ Shading
菜单:网格 ‣ 面 ‣ 光滑着色/平直着色

平直

平直(左)与光滑(右)着色范例。 blend文件范例
../../../_images/modeling_meshes_editing_normals_example-flat.png
../../../_images/modeling_meshes_editing_normals_example-smooth.png

如前面的章节所见,多边形对于Blender很重要。大多数物体是使用多边形表示的,并且真正的曲面物体也是多边形网格的近似效果。在渲染图像时,你可能注意到这些多边形看上去就是一系列平直的小平面。有时候要的就是这样的效果,但是通常我们还是希望物体看上去漂亮而光滑的。

光滑

../../../_images/modeling_meshes_editing_normals_shading-smooth-flat.png

工具栏上的着色按钮。

最简单的办法是在 物体模式 下,选择网格物体,然后在 工具栏 单击 光滑/平直 按钮,设定整个物体为光滑或平直。该按钮不会一直保持按下状态;该操作强制对网格中的每个面指定 光滑 属性,继续添加或删除几何体也一样。

可以注意到物体的轮廓仍然是棱角分明的。激活光滑属性实际上并没有修改物体的几何形状,只是改变了表面着色的计算方式(对法向进行插值),造成光滑表面的错觉而已。

单击 工具栏着色面板 上的 平直 按钮,恢复为上面第一张图中的着色状态(法向为常数)。

平滑部分网格

另外,还可以进入 编辑模式,选择需要光滑的面,然后单击 光滑按钮,有选择地光滑边线。被选中的边线显示为黄色。

当网格处于 编辑模式,只有选中的边线能够接受 光滑 属性。同样可以通过选择边线,单击 平直 按钮的方式设置边线为平直(移除 光滑 属性)。

See also

自动光滑 过滤选项是一种对同一个物体结合使用光滑和平直的多边形的便捷方法。

Properties

参考

面板:Properties editor ‣ Object Data ‣ Normals
../../../_images/modeling_meshes_properties_object-data_normals-panel.png

Normals panel.

Auto Smooth

Edges where an angle between the faces is smaller than specified in the Angle button will be smoothed, when shading of these parts of the mesh is set to smooth. This is an easier way to combine smooth and sharp edges.

Angle
Angle number button.
Double Sided
Lighting with positive normals on back-faces of the mesh in the viewport (OpenGL).

Example

../../../_images/modeling_meshes_properties_object-data_example-auto-smooth.png

Example mesh with Auto Smooth enabled.

See also

Edge Split Modifier

With the Edge Split Modifier a result similar to Auto Smooth can be achieved with the ability to choose which edges should be split, based on angle.

编辑

反转方向

参考

模式:编辑模式
面板:工具栏 ‣ 着色/UV ‣ 着色 ‣ 法向: 反转方向
菜单:网格 ‣ 法向 ‣ 翻转法线专用项 ‣ 翻转法线

好吧,该工具仅用于反转选中面的法线方向。注:由于只有选中面的法线方向会被翻转,故可用于精准调整法线方向(不是朝向 ,法线总是垂直于面的)。

重算法线方向

参考

模式:编辑模式
面板:工具栏 ‣ 着色/UV ‣ 着色 ‣ 法向: 重计算
菜单:网格 ‣ 法向 ‣ 向外重算法线方向网格 ‣ 法向 ‣ 向内重算法线方向
快捷键:Ctrl-NShift-Ctrl-N

该工具用于重新计算选中面的法线方向,使其指向面所属物体的外侧(或内侧)。物体无需闭合。实际上,这意味着选中面必须与至少一个不共面的面相邻。例如,对于 栅格 物体,重算法线方向不存在有意义的结果。

Set from Face

参考

模式:编辑模式
面板:工具栏 ‣ 着色/UV ‣ 着色 ‣ 法向: Set from Face

Sets the custom vertex normals from the selected face's normals.

Custom Split Normals

Custom Split Normals is a way to tweak/fake shading by pointing them towards other directions than default, auto-computed ones. It is mostly used in game development, where it allows to counterbalance some issues generated by low-poly objects (the most common examples are low-poly trees/bushes/grass/etc., and the 'rounded' corners).

Blender supports custom normals on a 'smooth fan' base, defined as a set of neighbor face corners sharing the same vertex and 'linked' by smooth edges. This means you can have normals per face corners, per a set of neighbor face corners, or per vertex.

Enabling Custom Split Normals Support

  1. Enable custom split normals using Add Custom Split Normals Data.
  2. Make sure to enable Auto Smooth.

Note

Once you have custom normals, the angle threshold of the Auto Smooth behavior is disabled -- all non-sharp-tagged edges will be considered as smooth, disregarding the angle between their faces.

Creating/Editing Custom Split Normals

Currently, editing is only possible by using the 法线编辑修改器.

You can also copy normals from another mesh using Data Transfer (operator or modifier).

Importing Custom Split Normals

Some tools, in particular CAD ones, tends to generate irregular geometry when tessellating their objects into meshes (very thin and long triangles, etc.). Auto-computed normals on such geometry often gives bad artifacts, so it is important to be able to import and use the normals as generated by the CAD tool itself.

Note

Currently, only the FBX importer is capable of importing custom normals.