简介

UV纹理是一张用于模型表面着色的图像(图片、图像序列或者影片),它通过一张或者多张纹理UV贴图映射到模型上的。有三种方法来建立UV贴图:

  1. 在UV/图像编辑器中当前选中的UV纹理上绘制平面图像,然后通过UV映射将图像中的颜色映射到模型网格表面。
  2. 在3D视图中直接在网格模型上绘制,让Blender使用当前选中的UV贴图更新UV纹理。(参见 投影绘制 )。
  3. 使用任意图像编辑软件来创建图像。在UV/图像编辑器中,选中该UV纹理,并加载图像。Blender会使用该纹理的UV将色彩传递到网格的各个面。

Blender有内置的绘画模式叫纹理绘制,它是特别为编辑UV纹理和在UV/图像编辑器窗口或或者3D视图窗口简单快速绘制图像而设计的。由于UV纹理仅仅是一张特殊用途的图像,你也可以用其它任何外部程序来创建,比如GIMP就是一个全功能的图像处理程序,而且它也是开源的。

../../../_images/sculpt-paint_painting_texture-paint_introduction_example.png

在Blender绘制纹理。

由于一个模型可以有多层UV纹理,可能会有许多图像为网格着色,但是每个UV纹理只有一个图像。

在3D视图窗口中和UV/图像编辑器窗口中中都可以绘制纹理。在绘制模式下的3D视图,可以直接在模型上绘制 投影至UV.

入门

一旦你将你的模型展开成UV贴图。你就可以开始纹理处理。你不能在没有 首先 展开网格的情况下在纹理绘制模式中绘制网格, 执行以下任一步骤:

参见 : 应用图像.

在完成下面两件事中的一件之后,你就可以在纹理绘制模式中修改图像了:

../../../_images/sculpt-paint_painting_texture-paint_introduction_paint-mode.png

启用绘制模式。

  • 在3D视图窗口中,在窗口标题栏的模式选择器中选择纹理绘制模式,之后就可以直接在模型上绘制纹理。
  • 在UV/图像编辑器窗口,将模式从视图切换到绘制(如右图所示)。

Note

2次方

当图像大小设置为2的n次方,比如256×256、512×512、1024x1024等等的时候,在3D视图窗口绘制纹理反应非常快。

一旦启用了纹理绘制,鼠标就会变成笔刷;要使用UV布局(例如,移动坐标),您必须返回到“视图”模式。

只要你启用纹理绘制或者切换到纹理绘制模式,在工具架面板中,笔刷设置才可用。

在UV/图像编辑器窗口,画布上绘制的内容会包裹到模型上,UV/图像编辑器里的任何变化都会在3D视图窗口立即显示出来,反之亦然。

在UV/图像编辑器窗口,笔刷和颜色的全部相关内容可以在属性面板中选取。笔刷的变化在UV/图像编辑器窗口和3D视图窗口的属性面板上都是立即同步反应出来的。尽管如此,修改过的纹理 不会 自动保存;你必须通过在UV/图像编辑器窗口点击 Image ‣ Save 来保存改动过的UV图像。

丢失数据

When no UV layers or texture slots can be detected, the system will display a warning and a few controls to add the relevant data in the Tool Shelf. You will not be able to paint until all missing data have been added.

添加简单的UVs
添加简单的UV 做一个简单的立方体,然后是一个展开包装操作。但仍然建议手动展开UV。
添加纹制槽
Add a material (if missing) and/or a texture slot. (Todo 2.72)

纹理预览

如果纹理已经使用的颜色纹理,凹凸贴图,置换,Alpha透明,等等,在场景中模型的表面(用专业技术人员的话说,通过UV映射,对应的将不同的贴图映射到对应的通道上),就可以在场景中的看到绘制的效果。

要做到这一点,设置并排区域,3D视图中的一个区域设置为 纹理 阴影选项,在第二个UV /图像编辑器区域加载图像。在3D视图以显示UV映射到加载的图像的物体。在右侧的图像中,被绘制的纹理被映射到“正常”属性,并被称为“凹凸贴图”,其中使用灰度图像使平坦的表面看起来颠簸。有关凹凸贴图的更多信息,请参见纹理贴图输出。

保存

如果标题栏的图像菜单旁边有一个星号,它代表图像被更改,但是还没有保存。使用 图像 ‣ 保存图像 选项来另存你的成果或者覆盖原文件保存。

Note

UV纹理

由于用作UV纹理的图像和其他图像功能不同,你应当把它们放在单独的目录下,区别于其他图像。

保存的图像格式与渲染格式无关。在文件浏览器的标题栏中选择保存UV图像的格式,默认为 PNG ( .png ) 。

如果在文件浏览器的窗口标题栏启用了打包,或者手动使用 图像 ‣ 打包图像,则不需要将图像保存到单独的文件中。

使用外部图像编辑器

如果你使用外部软件编辑uv纹理,你必须:

  1. 运行该绘画程序 (GIMP, Photoshop® , etc.).
  2. 载入或创建一个新图像。
  3. 改变图像。
  4. 在外部软件中重新保存。
  5. 返回Blender,在UV/图像编辑器重新载入图像。

如果你的团队成员使用不同的uv纹理制作软件,或者是你想使用一些纹理绘制不具备的特效,或者是你熟悉其他绘画软件的时候,你就需要使用外部软件来处理uv纹理。

已知的限制

UV重叠

通常情况下,重叠的UV是不支持的(比如烘焙贴图)。

尽管如此,这只是单个笔触多个面上绘制共享纹理的时候会出现的问题。

透视图 &视图背面

透视模式下,当绘制的面的一部分在视图的背面时,这个面绘制不了。为了避免这种情况,可以采用放大或者切换到正交投影视图的方式来绘制。

透视图&低面多边体

透视模式下,在法线远离视口(译者注:即法线指向屏幕内侧)的低多边形数物体上绘制时可能会失败,解决办法是在绘制面板中禁用 法线 选项。

这种典型的情况发生在绘制立方体的侧面的时候(参见 Bug report T34665 )。