在macOS上安装

本指南包含以下主题:

  1. 安装依赖关系

  2. 下载代码库

  3. 设置编译环境

Note

本指南十分依赖命令行工具,所以假设你对masOS终端应用有所熟悉。

安装依赖关系

安装下面的包,或者确保你的系统已经安装好。

下载代码库

使用下面的命令检出Blender手册代码库

cd ~
svn checkout https://svn.blender.org/svnroot/bf-manual/trunk/blender_docs

代码库下载需要几分钟时间,这取决于你的网络连接。

设置编译环境

  • 打开终端窗口。

  • 进入刚刚SVN检出新建的 blender_docs 文件夹:

    cd ~/blender_docs
    
  • 文件夹中有一个名为 requirements.txt 的文件,包含了一系列需要安装的依赖关系。要安装这些依赖关系,可以使用 pip 命令:

    sudo pip install -r requirements.txt
    

Note

时不时使用下面的命令确认你的依赖库是不是最新的:

sudo pip install -r requirements.txt --upgrade --upgrade-strategy eager

Continue with the next step: Building.