Magic UV

Activation

  • Open Blender and go to Preferences then the Add-ons tab.

  • Click UV then Magic UV to enable the script.

Interface

Located in the 3D Viewport ‣ Sidebar ‣ Edit and UV Editor ‣ Sidebar ‣ Magic UV.

Instructions

Copy/Paste UV

3D Viewport (Edit)

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Copy/Paste UV

Panel

Sidebar ‣ Magic UV ‣ Copy/Paste UV ‣ Copy/Paste UV

Copy and paste UV coordinates among same/different object's faces in 3D View. Copy/Paste UV sometimes fails to paste UV correctly because of the incorrect UV index. Instead, you can try Transfer UV which you can copy and paste based on the topology.

Target UV Map
Default

Copy/paste UV maps currently displayed.

All

Copy/Paste all UV maps.

New

Allocate new UV map and paste to it.

Copy/Paste Mode
Selection Sequence

provides a way to specify the ordering of copied/pasted faces by face selection.

Seams

If enabled, you can also copy/paste seams.

Strategy

Provides a way to decide copy/paste UV repeatedly if a number of copied faces is differs from pasted faces.

Tip

You can flip or rotate UV by changing Flip Copied UV property or Rotate Copied UV property.

Usage

  1. Click check box Copy/Paste UV to show Copy/Paste UV menu.

  2. Select faces whose UV you want to copy.

  3. Click Copy ‣ (Target UV Map).

  4. Select faces whoe UV you want to paste.

  5. Click Paste ‣ (Target UV Map)`.

3D Viewport (Object)

Reference

Editor

3D Viewport

Mode

Object

選單

Object ‣ Copy/Paste UV

Panel

Sidebar ‣ Magic UV ‣ Copy/Paste UV

Copy and paste UV coordinates among same topology objects.

Copy/Target UV Map
[Default]

Copy/paste UV maps currently displayed.

[All]

Copy/Paste all UV maps.

[New]

Allocate new UV map and paste to it.

Seams

If enabled, you can also copy/paste seams.

Usage

  1. Select object whose UV you want to copy.

  2. Click Copy ‣ (Target UV Map).

  3. Select objects whose UV you want to paste.

  4. Click Paste ‣ (Target UV Map).

Tip

You can paste UV to the multiple objects.

UV Editor

Reference

Editor

UV Editor

選單

UV ‣ Copy/Paste UV

Panel

Sidebar ‣ Magic UV ‣ Copy/Paste UV

Copy and paste UV coordinates among same/different object's faces in UV Editor.

Usage

  1. Select UVs you want to copy.

  2. Click Copy.

  3. Select UVs you want to paste.

  4. Click Paste.

Note

You must select UVs which consist closed loop (i.e. face).

Transfer UV

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Transfer UV

Panel

Sidebar ‣ Magic UV ‣ Copy/Paste UV ‣ Transfer UV

Copy and paste UV coordinates based on the mesh's topology. Transfer UV can solve the Copy/Paste UV issue raised when the meshes don't have same UV indices. However, Transfer UV also can not solve the issue raised when you try the meshes which don't have same topology.

Invert Normals

If enabled, you can copy/paste to the mirrored mesh.

Seams

If enabled, you can also copy/paste seams.

Usage

  1. Click check box Transfer UV to show Transfer UV menu.

  2. Select 2 adjacent faces of the mesh whose UV you want to copy.

  3. Click Copy.

  4. Select 2 adjacent faces of the mesh whose UV you want to paste.

  5. Click Paste.

Note

  • Copied/Pasted mesh must have the same number of faces.

  • Transfer UV ignore the hidden faces.

  • You can paste UV to the multiple meshes.

Flip/Rotate UV

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Flip/Rotate UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Flip/Rotate UV

Flip or rotate UV.

Seams

If enabled, you can also flip/rotate seams.

Usage

  1. Click check box Flip/Rotate UV to show Flip/Rotate UV menu.

  2. Select faces whose UV you want to flip or rotate.

  3. Click Flip/Rotate.

  4. Change value Flip UV or Rotate UV.

Mirror UV

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Mirror UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Mirror UV

Make mirrored UV.

Error

Changes the error threshold for mirror.

Origin

Specifies the origin of the mirror operation.

Usage

  1. Click check box Mirror UV to show Mirror UV menu.

  2. Select faces you want to refer.

  3. Choose the axis of the mirror direction.

  4. Click Mirror.

Move UV

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Move UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Move UV

Move UV with a mouse in the 3D Viewport.

Usage

  1. Click check box Move UV to show Move UV menu.

  2. Select vertices/edges/faces whose UV you want to move.

  3. Click Start.

  4. Press Mouse Left Button to start moving UV.

  5. You can move UV with mouse.

  6. Press Mouse Left Button to stop moving UV.

If you want to cancel moving UV, press RMB.

World Scale UV

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ World Scale UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ World Scale UV

Measure and set texel density.

Texture

Texture to be used for the size calculation of density.

[Average]

Average size of textures assigned to the selected object.

[Max]

Max size of textures assigned to the selected object.

[Min]

Min size of textures assigned to the selected object.

(Texture Name)

Size of selected texture.

Origin

Changes the UV origin after applying texel density.

Area Calculation Method

Method to calculate mesh area, UV area and density.

Only Selected

If enabled, measure/apply only to the selected faces.

Mode: Manual

Usage

  1. Click check box World Scale UV to show World Scale UV menu.

  2. Select mode Manual.

  3. Change value Texture Size referred as virtual texture size.

  4. Change value Density referred as target texel density.

  5. Select face you want to apply texel density.

  6. Click Apply.

Mode: Same Density

Usage

  1. Click check box World Scale UV to show World Scale UV menu.

  2. Select mode Same Density.

  3. Select face you want to measure a texel density.

  4. Click Measure.

  5. You can see the target texel density.

  6. Select face you want to apply texel density.

  7. Click Apply.

Mode: Scaling Density

Usage

  1. Click check box World Scale UV to show World Scale UV menu.

  2. Select mode Scaling Density.

  3. Select face you want to measure a texel density.

  4. Click Measure.

  5. You can see the measured texel density.

  6. Change value Scaling Factor for the scale factor of the texel density.

  7. Select face you want to apply texel density.

  8. Click Apply.

Mode: Proportional to Mesh

Usage

  1. Click check box World Scale UV to show World Scale UV menu.

  2. Select mode Proportional to Mesh.

  3. Select face you want to measure a texel density.

  4. Click Measure.

  5. You can see the measured mesh area, UV area and density.

  6. Select face you want to apply texel density.

  7. Click Apply.

Preserve UV Aspect

Reference

Editor

3D Viewport

選單

UVs ‣ Preserve UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Preserve UV Aspect

Change assigned texture with preserving UV aspect.

Origin

Changes the UV origin after changing texture.

Usage

  1. Click check box Preserve UV Aspect to show Preserve UV Aspect menu.

  2. Select face you want to change texture.

  3. Select texture you want to assign.

  4. Click Change Image.

Texture Lock

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Texture Lock

Panel

Sidebar ‣ Edit ‣ UV Manipulation ‣ Texture Lock

Preserve UV while you edit the mesh.

Normal Mode

Connect

If enabled, you can keep UV connection by changing other face's UV.

Usage

  1. Click check box Texture Lock to show Texture Lock menu.

  2. Select vertices/edges/faces which you want to preserve UV.

  3. Click Lock.

  4. Transform vertices/edges/faces as you like.

  5. Click Unlock, you can return to the UV before locking.

Interactive Mode

Usage

  1. Click check box Texture Lock to show Texture Lock menu.

  2. Select vertices/edges/faces which you want to preserve UV.

  3. Click Lock.

  4. Transform vertices/edges/faces while preserving UV.

  5. Click Unlock.

Texture Wrap

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Texture Wrap

Panel

Sidebar ‣ Edit ‣ UV Manipulation ‣ Texture Wrap

Set texture coordinate along to the mesh structure.

Set and Refer

If enabled, you don't need to click Refer after Set as long as you refer same face.

Selection Sequence

If enabled, you can select multiple faces and apply Set at once. The application order follows the selection sequence.

Usage

  1. Click check box Texture Wrap to show Texture Wrap menu.

  2. Select a face whose UV you want to refer as initial position.

  3. Click Refer.

  4. Select an adjacent face whose UV you want to set.

  5. Click Set.

UV Sculpt

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ UV Sculpt

Panel

Sidebar ‣ Edit ‣ UV Manipulation ‣ UV Sculpt

UV Sculpt in the 3D Viewport. Same features are supported as the UV sculpt in UV Editor.

Radius

Provides a way to change the brush radius.

Strength

Provides a way to change the effectiveness.

Tools
Grab

Move UV along to the mouse movement while you press Mouse Left Button.

Relax

Relax UV while you press Mouse Left Button.

Method

Provides a way to change the relax method.

Pinch

Pinch UV while you press Mouse Left Button.

Invert

If enabled, the direction of pinch will be inverted.

Show Brush

If enabled, display the brush's effective range while sculpting.

Usage

  1. Click check box UV Sculpt to show UV Sculpt menu.

  2. Select faces whose UV you want to sculpt.

  3. Click Enable.

  4. Sculpt UV as you like (See detail each tool's usage).

  5. Click Disable.

Unwrap Constraint

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Unwrap Constraint

Panel

Sidebar ‣ Edit ‣ UV Mapping ‣ Unwrap Constraint

Unwrap UV with an axis fixed.

Usage

  1. Click check box Unwrap Constraint to show Unwrap Constraint menu.

  2. Select faces whose UV you want to unwrap.

  3. Enable or disable U-Constraint property and V-constraint property to fix axis while unwrapping.

  4. Click Unwrap.

Texture Projection

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ Texture Projection

Panel

Sidebar ‣ Edit ‣ UV Mapping ‣ Texture Projection

Project the texture to the mesh while displaying texture image in 3D View.

Transparency

Provides a way to change transparency of the displayed texture.

Adjust Window

If enabled, size of the displayed texture is adjusted to the window.

Scaling, Rotation, Translation

Provide a way to apply the affine transformation to the displayed texture. Available when Adjust Window is disabled.

Texture Aspect Ratio

If enabled, keep the original aspect of the displayed texture.

Assign UV Map

If enabled, assign new UV map when no UV is assigned to the mesh.

Usage

  1. Click check box Texture Projection to show Texture Projection menu.

  2. Select faces whose UV you want to apply Texture Projection.

  3. Select a texture to be projected.

  4. Click Enable to display the texture.

  5. Adjust texture size and the mesh location to decide the location of projection.

  6. Click Project to project texture to UV.

  7. Click Disable.

UVW

Reference

Editor

3D Viewport

Mode

Edit

選單

UV ‣ UVW

Panel

Sidebar ‣ Edit ‣ UV Mapping ‣ UVW

UVW mapping.

Assign UV Map

If enabled, assign new UV map when no UV is assigned to the mesh.

Force Axis

Specifies the axis to apply force mapping.

Usage

  1. Click check box UVW to show UVW menu.

  2. Select faces you want to apply UVW mapping.

  3. Click Box if you apply Box mapping, or click Best Planner if you apply Best Planner mapping.

Align UV

Reference

Editor

UV Editor

選單

UVs ‣ Align UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Align UV

Align

Align UV.

Circle

Selects all the outermost UVs and aligns them to a round shape.

Straighten

Selects the endmost UVs and aligns them to a straight line between begin UV and end UV.

XY-axis

Selects the endmost UVs and aligns them to a straight line along to X or Y axis.

Align Location

In case of XY-axis alignment, you can change the location (Middle, Right/Bottom, Left/Top) after UV alignment.

Transmission

Align UVs with vertical direction.

Select

The aligned UVs will be selected after operation.

Vertical

Align UVs to vertical direction with using the influence of mesh vertex location.

Horizontal

Align UVs to horizontal direction with using influence of mesh vertex location.

Mesh Influence

Provides a way to change the influence of mesh structure.

Usage

  1. Click check box Align UV to show Align UV menu.

  2. Select UVs you want to align (see details below).

  3. Click Circle or Straighten or XY-axis depending on your purpose.

Snap

Snap UV coordinates to the specified location.

Snap Method
Point

Snap UV coordinates to the location specified by Target Point.

Edge

Snap UV coordinates to the location specified by Target Edge.

Snap: Point
Group
Vertex

All selected vertices will snap to Target Point.

Face

Center of all selected faces will snap to Target Point.

UV Island

Center of all selected islands will snap to Target Point.

Usage

  1. Click check box Align UV to show Align UV menu.

  2. Select snap method Point.

  3. Set Target Point where UV coordinate will snap to.

  4. Set snap Group (See below for details).

  5. Select vertices or faces or UV islands which you want to snap.

Snap: Edge
Group
Edge

Selected edge will snap to the center of Target Edge.

Face

All edges belonging to faces which are included in selected edge will snap to the center of Target Edge.

UV Island

All edges belonging to UV islands which are included in selected edge will snap to the center of Target Edge.

Usage

  1. Click check box Align UV to show Align UV menu

  2. Select snap method Edge.

  3. Set Target Edge where UV edge will snap to.

  4. Set snap Group (See below for details).

  5. Select edges which you want to snap.

Smooth UV

Reference

Editor

UV Editor

選單

UVs ‣ Smooth UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Smooth UV

Smooth UV.

Transmission

If enabled, smooth UVs which are located on vertical direction of selected UV.

Select

If enabled, the smoothed UVs are selected.

Mesh Influence

Provides a way to change the influence of mesh structure.

Usage

  1. Click check box Smooth UV to show Smooth UV menu.

  2. Select UVs you want to smooth (The endmost UVs must be selected).

  3. Click Smooth.

Select UV

Reference

Editor

UV Editor

選單

UVs ‣ Select UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Select UV

Select UV under the specific condition.

Overlapped

Selects all overlapped UVs.

Flipped

Selects all flipped UVs.

Same Polygon Threshold

Provides a way to set a threshold for judging the same polygons.

Selection Method

Specifies how to select the faces.

Sync Mesh Selection

Select the mesh's faces as well as UV's faces.

Zoom Selected UV

Zoom to the selected UV in 3D Viewport.

Usage

  1. Click check box Select UV to show Select UV menu.

  2. Click Overlapped or Flipped depending on your purpose (see details below).

Pack UV (Extension)

Reference

Editor

UV Editor

選單

UVs ‣ Pack UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Pack UV (Extension)

Apply island packing and integrate islands which have same shape.

Allowable Center Deviation

Provides a way to specify the center deviation that regards as the same island.

Allowable Size Deviation

Provides a way to specify the size deviation that regards as the same island.

Usage

  1. Click check box Pack UV (Extension) to show Pack UV (Extension) menu.

  2. Select faces whose UV you want to pack.

  3. Click Pack UV.

Clip UV

Reference

Editor

UV Editor

選單

UVs ‣ Clip UV

Panel

Sidebar ‣ Magic UV ‣ UV Manipulation ‣ Clip UV

Clip UV coordinate to the specified range.

Range

Specifies the clipping range.

Usage

  1. Click check box Clip UV to show Clip UV menu.

  2. Select faces you want to clip UV coordinates.

  3. Click Clip UV.

Align UV Cursor

Reference

Editor

UV Editor

選單

UVs ‣ Align UV Cursor

Panel

Sidebar ‣ Magic UV ‣ Editor Enhancement ‣ Align UV Cursor

Align UV cursor (2D Cursor in UV Editor).

Align Method
Texture

The UV cursor aligns to the selected texture.

UV

The UV cursor aligns to the d UV (includes non-selected UV).

UV (Selected)

The UV cursor aligns to the displayed UV (only selected UV).

Usage

  1. Click check box Align UV Cursor to show Align UV Cursor menu.

  2. Select Texture or UV or UV (Selected) depending on your purpose (See details below).

  3. Click the position button (You can choose the position from 9 buttons).

UV Cursor Location

Reference

Editor

UV Editor

Panel

Sidebar ‣ Magic UV ‣ Editor Enhancement ‣ UV Cursor Location

Set and display UV Cursor (2D Cursor in UV Editor) location.

Usage

  1. Click check box UV Cursor Location to show UV Cursor Location menu.

  2. UV cursor location is displayed, and you can set the new location as you like.

UV Bounding Box

Reference

Editor

UV Editor

選單

UVs ‣ UV Bounding Box

Panel

Sidebar ‣ Magic UV ‣ Editor Enhancement ‣ UV Bounding Box

Transform UV with Bounding Box like a Photoshop/GIMP's Bounding Box.

Uniform Scaling

If enabled, you can transform uniformly.

Boundary

Specifies the boundary of the bounding box.

Usage

  1. Click check box UV Bounding Box to show UV Bounding Box menu.

  2. Click Show to show the bounding box.

  3. Transform UV with the bounding box as you like (You can transform UV same as Photoshop/Gimp).

  4. Click Hide.

UV Inspection

Reference

Editor

UV Editor

選單

UVs ‣ Inspect UV

Panel

Sidebar ‣ Magic UV ‣ Editor Enhancement ‣ UV Inspection

Inspect UV

Inspect UV and help you to find which UV is on the abnormal condition.

Overlapped

The overlapped part/face is enhanced.

Flipped

The flipped part/face is enhanced.

Mode
Part

Enhance only to the overlapped/flipped part.

Face

Enhance the overlapped/flipped face.

Same Polygon Threshold

Provides a way to set a threshold for judging the same polygons.

Display View3D

Display overlapped/flipped faces on View3D as well as UV Editor.

Usage

  1. Click check box UV Inspection to show UV Inspection menu.

  2. Click Show to enhance the part on which is under specific condition.

  3. Click Update if you want to update to the latest status.

  4. Click Hide.

Paint UV island

Paint UV island with random color.

Usage

  1. Click check box UV Inspection to show UV Inspection menu.

  2. Click Paint UV island.

Other Resources

The supplemental documentation (e.g. FAQ) and early release can be found in Magic UV's Github repository.

Reference

Category

UV

Description

UV tool set. See add-ons preferences for details.

Location

3D Viewport ‣ Sidebar ‣ Edit and UV Editor --> Sidebar ---> Magic UV

File

magic_uv folder

Author

Nutti, Mifth, Jace Priester, kgeogeo, mem, imdjs, Keith (Wahooney) Boshoff, McBuff, MaxRobinot, Alexander Milovsky

License

GPL 3+

Note

This add-on is bundled with Blender.