Particle Edit Mode

Using Particle Edit Mode you can edit the key-points (Keyframes) and paths of Baked Hair, Particle, Cloth, and Soft Body simulations. (You can also edit and style hair before baking).

Since working in Particle Edit Mode is pretty easy and very similar to working with vertices in the 3D View, we will show how to set up a particle system and then give a reference of the various functions.

Usage

Tip

Only Frames Baked to Memory are Editable!

If you cannot edit the particles, check that you are not baking to a Disk Cache.

Setup for Hair Particles

  1. Create a Hair particle system.
  2. Give it an initial velocity in the Normal direction.
  3. Create a simulation.
  4. Check the Hair Dynamics box.
../../_images/physics_particles_mode_example.png

Editing hair strands in Particle Edit Mode.

Setup for Particle, Cloth, and Soft Body Simulations

  1. Use Emitter particles, or a cloth/soft-body simulation.
  2. Create a simulation by setting up objects and or emitters, set your time range (use a small range if you are just starting out and experimenting), set up the simulation how you want it, using Alt-A to preview it.

Bake the Simulation

Once you are happy with the general simulation, bake the simulation from object mode. The simulation must be baked to enable editing.

Edit the Simulation

Switch to Particle Edit from the Mode select menu in the header of the 3D View to edit the particle’s paths/Keyframes. You may need to press T from within the 3D View to see the Particle Edit panel. Move to the frame you want to edit and use the various Particle Edit tools to edit your simulation. Work slowly, previewing your changes with Alt-A, and save often so that you can go back to the previous version should something happen, or that you do not like the latest changes you have made.

Tip

To be able to clearly see what you are working on:

  1. Open the Options panel in the Tool shelf.
  2. Select Point select mode (see below) in the header of the 3D View. This will display key points along the particle path.

Selecting

  • Single: RMB.
  • All: A.
  • Linked: Move the mouse over a keypoint and press L.
  • Border select: B.
  • First/last: Specials ‣ Select First / Select Last.

You may also use the Select Menu.

Tip

Selections

Selections are extremely useful for modifying only the particles that you want. Hover over a particle path and press L to link-select it, hover over the next and press L to add that path to the selection. To remove a path, hold Shift and press L. To Deselect all press A.

The method to select individual points is the same as in edit mode. RMB to select, Shift-RMB to add/remove a point from the selection.

Select Random

ToDo 2.73.

Select Modes

../../_images/physics_particles_mode_select-modes.png

Select Modes.

Path
No keypoints are visible, you can select/deselect only all particles.
Point
You see all of the keypoints.
Tip
You can see and edit (including the brushes) only the tip of the particles, i.e. the last keypoint.

Brush

Reference

Mode: Particle Edit Mode
Panel: Tool Shelf ‣ Tools ‣ Brush

With the buttons you can select the type of “Comb” utility you want to use.

None
No special tool, just edit the keypoints as “normal” vertices.
Comb
Moves the keypoints (similar to “proportional editing”).
Smooth
Parallels visually adjacent segments.
Add

Adds new particles.

Count
The number of new particles per step.
Interpolate
Interpolate the shape of new hairs from existing ones.
Steps
Amount of brush steps
Keys
How many keys to make new particles with.
Length
Scales the segments, so it makes the hair longer with Grow or shorter with Shrink.
Puff

Rotates the hair around its first keypoint (root). So it makes the hair stand up with Add or lay down with Sub.

Puff Volume
Apply puff to unselected end-points, (helps maintain hair volume when puffing root).
Cut
Scales the segments until the last keypoint reaches the brush.
Weight
This is especially useful for softbody animations, because the weight defines the softbody Goal. A keypoint with a weight of 1 will not move at all, a keypoint with a weight of 0 subjects fully to softbody animation. This value is scaled by the GMin to GMax range of softbody goals…

Common Options

Below the brush types, their settings appear:

Radius F
Set the radius if the brush.
Strength Shift-F
Set the strength of the brush effect (not for Add brush).
Add/Sub Grow/Shrink
Sets the brush to add the effect or reverse it.

Options

Reference

Mode: Particle Edit Mode
Panel: Tool Shelf ‣ Tools ‣ Options
Deflect Emitter

Hair particles only – Do not move keypoints through the emitting mesh.

Distance
The distance to keep from the Emitter.
Keep
Length
Keep the length of the segments between the keypoints when combing or smoothing the hair. This is done by moving all the other keypoints.
Root
Keep first key unmodified, so you cannot transplant hair.
Correct
ToDo.
X Mirror
Enable mirror editing across the local X axis.
Shape Object

A mesh object which boundary is used by the Shape Cut tool.

Shape Cut
This grooming tool trims hairs to a shape defined by the Shape Object. This is a quicker way of avoiding protruding hair sections from lengthening than using the Cutting tool. It works especially well for characters with extensive fur, where working in a single plane with the Cutting tool becomes tedious.
Shape Cut example.
../../_images/physics_particles_mode_shapecut-before.png

Before.

../../_images/physics_particles_mode_shapecut-after.png

After.

Draw

Path Steps
Drawing steps, sets the smoothness of the drawn path.
Fade Time
Frames
ToDo.
Show Children
Draws the children of the particles too. This allows to fine tune the particles and see their effects on the result, but it may slow down your system if you have many children.

Editing

Warning

Beware of Undo!

Using Undo in Particle Edit Mode can have strange results. Remember to save often!

Moving Keypoints or Particles

  • To move selected keypoints press G, or use one of the various other methods to grab vertices.
  • To move a particle root you have to turn off Keep Root in the Tool Shelf.
  • You can do many of the things like with vertices, including scaling, rotating and removing (complete particles or single keys).
  • You may not duplicate or extrude keys or particles, but you can subdivide particles which adds new keypoints Specials ‣ Subdivide or Numpad2.
  • Alternatively you can rekey a particle Specials ‣ Rekey or Numpad1 and choose the number of keys.

How smoothly the hair and particle paths are displayed depends on the Path Steps setting in the Tool Shelf. Low settings produce blocky interpolation between points, while high settings produce a smooth curve.

Mirror

Reference

Mode: Particle Edit Mode
Menu: Particle ‣ Mirror

If you want to create an X-Axis symmetrical haircut you have to do following steps:

  1. Select all particles with A.
  2. Mirror the particles with Ctrl-M, or use the Particle ‣ Mirror menu.
  3. Turn on X-Axis Mirror Editing in the Particle menu.

It may happen that after mirroring two particles occupy nearly the same place. Since this would be a waste of memory and render time, you can Remove doubles either from the Specials W or the Particle menu.

Unify Length

Reference

Mode: Particle Edit Mode
Menu: Particle ‣ Unify Length, Specials ‣ Unify Length

This tool is used to make all selected hair uniform length by finding the average length.

Show/Hide

Reference

Mode: Particle Edit Mode
Menu: Particle ‣ Show/Hide

Hiding and unhiding of particles works similar as with vertices in the 3D View. Select one or more keypoints of the particle you want to hide and press H. The particle in fact does not vanish, only the key points.

Hidden particles (i.e. particles whose keypoints are hidden) do not react on the various brushes. But:

If you use Mirror Editing even particles with hidden keypoints may be moved, if their mirrored counterpart is moved.

To un-hide all hidden particles press Alt-H.