Editing(編集)

展開した後、テクスチャやペイントで使用できるように、UVマップを配置する必要があります。編集のゴールは次のとおりです:

  • (UVマップの)ピースをつなぎ合わせます。

  • 画像の無駄なスペースを最小限に抑えます。

  • 詳細が必要な面を拡大します。

  • ストレッチした面をサイズ変更/拡大します。

  • 粗悪で、ディテールが多すぎる面を縮小します。

デッドスペースを最小限に抑えることで、ほとんどのピクセルをUVテクスチャに最大限のディテールと細かさを与えることに専念することができます。UV面は、ピクセル(画像を構成する小さなドット)のように小さくすることも、画像全体のように大きくすることもできます。おそらく、最初に大きな調整を行ってから、レイアウトを微調整することをお勧めします。

Transform(トランスフォーム)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Tool(ツール)

Toolbar(ツールバー) ‣ Move(移動)、Rotate(回転)、Scale(スケール)、Transform(トランスフォーム)

Menu(メニュー)

UV ‣ Transform(トランスフォーム)

  • Move(移動) G

  • Rotate(回転) R

  • Scale(スケール) S

  • Shear(せん断) Shift-Ctrl-Alt-S

軸のロック

トランスフォームツールの1つを実施後、 XY を押すことでトランスフォーム変換を軸にロックできます。また、 MMB を押し続けると、X軸やY軸への移動が制限されます。

Mirror(ミラー)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Mirror(ミラー)

ショートカットキー

Ctrl-M

UVは、Y軸やX軸でミラーできます。

  • Mirror X(ミラー X)

  • Mirror Y(ミラー Y)

ホットキー XY を使用するか、 MMB を押したままミラー方向にドラッグすることもできます。

Copy Mirrored UV Coordinates(UV座標をミラー反転コピー)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Copy Mirrored UV Coordinates(UV座標をミラー反転コピー)

ミラーしたメッシュの一方からもう一方へUVをコピーします。選択した頂点(両側)にのみ影響します。

Axis Direction(軸方向)

Positive(正方向)/Negative(負)

Precision(精度)

頂点の重複を見つけるための許容値。

Snap(スナップ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Snap(スナップ)

ショートカットキー

Shift-S

UVエディタでのスナップは、 3DでのSnapping(スナップ) に似ています。ピクセルへのスナップオプションを機能させるには、画像をロードする必要があります。

Selected to Pixels(選択物 → ピクセル)

Moves selection to nearest pixel. See also Snap to pixel above.

Selected to Cursor(選択物 → カーソル)

選択物を2Dカーソル位置に移動します。

Selected to Cursor (Offset)(選択物 → カーソル(オフセット))

中心からの頂点のオフセットを維持しながら、選択物の中心を2Dカーソル位置に移動します。

Selected to Adjacent Unselected(選択物 → 近くの非選択物)

選択物を隣接する選択されていない要素に移動します。

Cursor to Pixels(カーソル → ピクセル)

カーソルを最も近いピクセルにスナップします。

Cursor to Selected(カーソル → 選択物)

カーソルを選択物の中心に移動します。

Cursor to Origin

Places the cursor to the location (0, 0, 0).

Merge(マージ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Merge(マージ)

ショートカットキー

M

At Center(中心に)

選択したUVを平均位置に移動します。

At Cursor(カーソル位置に)

選択したUVを2Dカーソル位置に移動します。

By Distance(距離で)

指定された Merge Distance(結合距離) 内で選択されたUVをマージします。

Split(分割)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Split(分割)

ショートカットキー

Alt-M

Selection(選択) Y

選択物を残りのUVから分割(切断)します。選択されていない要素の境界の辺が複製されます。

"コピー"は元の位置とまったく同じ位置にあるため、はっきりと見るためには、移動する必要があることに注意してください。

Unwrap(展開)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Unwrap(展開)

ショートカットキー

U

BlenderはUVをマッピングするいくつかの方法を提供します。より単純な投影方法では、サーフェスを通る点、軸、または平面に向かって点の位置を補間することにより、3D空間を2D空間にマッピングする式を使用します。より高度な方法は、より複雑なモデルを使用でき、より具体的な用途があります。

Pin(ピン止め) & Unpin(ピンを外す)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Pin(ピン止め)/Unpin(ピンを外す)

ショートカットキー

P, Alt-P

UVをピン止めして、複数の展開操作間で移動しないようにすることができます。モデルを展開するときに、特定のUVを "ロック" して、UVレイアウトの一部が同じ形状や同じ場所にとどまるようにすると便利な場合があります。ピン止めは、UVを選択し、UV メニューから Pin(ピン止め) を選択するか、またはショートカット P で実行できます。ショートカット Alt-P を使用して、UV の Unpin(ピンを外す) ことができます。

ピン止めは、有機オブジェクトに対してUVマッピングの展開メソッドを使用する場合に最も効果的です。例として、 Mirror Modifier(ミラーモディファイアー) を使用して対称オブジェクトをモデリングしている場合があります。ミラー軸上のUVの一部は、ミラー対応するものとの間で共有される場合があります。中線に対応するUVをピン止めしてから、X軸上に揃えると、その位置に留まります。

ピン止めは、Live Unwrap(ライブ展開)ツールでもうまく機能します。Live Unwrap(ライブ展開) をオンにして2つ以上のUVをピン止めすると、ピン止めされたUVをドラッグすると、モデルがインタラクティブに展開されます。これは、UVアイランドを特定の形状や領域に適合させるのに役立ちます。

Mark/Clear Seams(シームをマーク/クリア)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Mark/Clear Seam(シームをマーク/クリア)

Seams(シーム) を参照してください。

Seams from Islands(アイランドによるシーム)

参照

Mode(モード)

View(ビュー) モード

Menu(メニュー)

UV ‣ Seams from Islands(アイランドによるシーム)

既存のUVアイランドの境界にシームを追加します。これは、すでに展開されたメッシュのUVを変更するときに役立ちます。

Pack Islands(アイランドを梱包)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Pack Islands(アイランドを梱包)

Pack Islands(アイランドを梱包) ツールは、 Texture Space(テクスチャ空間) を効率的に埋めようとする、重なり合わないアイランドを使用して最適化されたUVレイアウトを生成します。

まず、選択したアイランドを均一にスケールし、次に各アイランドを個別にトランスフォームして、UVスペースを可能な限り埋めます。

Pack To(梱包の対象)

UVアイランドを梱包する UDIM グリッド。

Closest UDIM(一番近いUDIM)

アイランドを最も近いUDIMに梱包します。

Active UDIM(アクティブUDIM)

2Dカーソルが配置されているアクティブなUDIMイメージタイル、または、UDIMグリッドタイルにアイランドを梱包します。

Rotate(回転)

アイランドを回転させて、可能な限りぴったりとフィットさせます。

Margin(余白)

アイランド間のターゲットの空きスペース。

Average Island Scale(アイランドの大きさを平均化)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Average Island Scale(アイランドの大きさを平均化)

Average Island Scale(アイランドの大きさを平均化) ツールを使用して、すべてがほぼ同じスケールになるように各UVアイランドをスケールします。

Non-Uniform

Reduces average texture stretching within islands by scaling the U and V axes independently.

Shear(せん断)

Reduces average texture shearing within islands by shearing the U axis.

Minimize Stretch(最小ストレッチ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Minimize Stretch(最小ストレッチ)

Minimize Stretch(最小ストレッチ) ツールは、角度を最小化することでUVストレッチを減らします。これは本質的にUVを緩和します。

Stitch(スティッチ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Stitch(スティッチ)

ショートカットキー

Alt-V

Stitch(スティッチ) ツールは、頂点を共有する選択されたUVに結合します。 Adjust Last Operation(最後の操作を調整) パネルで、 Use Limit(範囲を制限) をアクティブにして Limit Distance(距離制限) を調整することにより、距離によってスティッチを制限するようにツールを設定します。

Align(整列)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Align(整列)

ショートカットキー

Shift-W

The Align tool will move the selected UVs to a line, where that line is specified in different ways by Axis.

The Straighten option will calculate a line segment between two endpoints and move all selected UVs onto that line.

The Align X and Align Y options will axis-align all selected UVs to the midpoint of the current selection.

Axis(座標軸)
Straighten(直線で整列)

Move UV to closest point on line segment.

Straighten X

Move U co-ordinates onto the line.

Straighten Y

Move V co-ordinates onto the line.

Align X

Move U co-ordinates to the midpoint of the selection.

Align Y

Move V co-ordinates to the midpoint of the selection.

Align Auto

Choose between Align X or Align Y automatically.

Show/Hide Faces(面を表示/隠す)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Show/Hide Faces(面を表示/隠す)

  • Reveal Hidden(隠したものを表示) Alt-H

  • Hide Selected(選択物を隠す) H

  • Hide Unselected(非選択物を隠す) Shift-H

Export UV Layout(UV配置をエクスポート)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Export UV Layout(UV配置をエクスポート)

外部アプリケーションを使用している場合は、メッシュのどこにペイントしているかを知ることが必要になります。

注釈

これは、デフォルトでアクティブ化されている アドオン です。

Proportional Editing(プロポーショナル編集)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

ヘッダー

Proportional Editing(プロポーショナル編集)

Menu(メニュー)

UV ‣ Proportional Editing(プロポーショナル編集)

ショートカットキー

O

Proportional Editing(プロポーショナル編集)はUV編集で利用できます。コントロールは3D Viewport(3Dビューポート)と同じです。完全なリファレンスについては、 3DでのProportional Editing(プロポーショナル編集) を参照してください。

UVのオプション

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UVs(UV)

Live Unwrap(ライブ展開)

ピン止めされた頂点を変換しながら、選択したUVアイランドを継続的に展開します。これは、3D Viewport(3Dビューポート)の Live Unwrap(ライブ展開) オプションとは異なることに注意してください。

Snap to Pixels
Disabled(無効)

UVs will not be snapped.

Corner(コーナー)

Will force the UVs to snap to the corners of the nearest pixels of an image if loaded.

Center(中心)

Will force the UVs to snap to the center of the nearest pixels of an image if loaded.

Constraining to Image Bounds(画像の範囲に拘束)

標準のテクスチャの場合、このオプションは、UVが0から1のUV範囲外に移動するのを防ぎます。 UDIMs テクスチャの場合、このオプションは、UVが一番近いUDIMタイルの外側に移動するのを防ぎます。

3D Viewport(3Dビューポート)

Rotate UVs(UVを回転)

参照

Editor(エディター)

3D Viewport(3Dビューポート)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

Face(面) ‣ Face Data(面データ) ‣ Rotate UVs(UVを回転)

UVテクスチャの方向は、各面によって定義されます。例えば、画像が上下逆になっている場合や横向きになっている場合は、 Face(面) ‣ Rotate UVs(UVを回転) (3D Viewport(3Dビューポート)のFace Select(面選択)モード)メニューを使用して、面ごとに90度回転してUVを回転させます。

Reverse UVs(UVを反転)

参照

Editor(エディター)

3D Viewport(3Dビューポート)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

Face(面) ‣ Face Data(面データ) ‣ Reverse UVs(UVを反転)

Face(面) ‣ Reverse UVs(UVを反転) ツールは、面ごとのUVをミラーします。これにより、画像が反転し、画像が反転して表示されます。