打开 & 保存

通常使用 文件浏览器 来完成 .blend 文件的保存和打开操作。

Tip

Blender 文件的打开也可以通过把 .blend 文件拖入 Blender 窗口来完成。这个方法同时也允许 关联/追加 一个文件。

Note

未保存的改动

默认情况下,当退出 Blender 或者打开一个新 .blend 文件时,如果你有未保存的改动,会有一个弹出框询问你是否丢弃改动,或者保存改动。

可以使用用户设置中 保存&加载 部分中的 保存提示 选项禁用此行为。

打开文件

参考

菜单

文件 ‣ 打开...

快捷键

Ctrl-O

靠上面的文本框显示当前目录路径,下面的文本框包含选中的文件名。

../../_images/files_blend_open-save_file-browser-open.png

文件浏览器打开文件。

选项

加载用户界面

被选中时,将使用保存在每个 .blend 文件中的屏幕布局替换当前的布局和 工作区. 否则忽略文件中的屏幕布局。

Tip

如果你要使用自己默认的环境编辑 .blend 文件,启动一个新的 Blender,打开文件浏览器并关闭 Load UI 按钮,然后打开所需的文件。

可信任源

当被选中时,然会自动运行包含在文件中的 Python 脚本和驱动程序。只有在你自己创建的文件中才能启用此选项,或者你相信给你提供文件的人没有在文件中包含恶意代码。请参阅 脚本与安全 来配置默认的信任选项。

最近打开

参考

菜单

File ‣ Open Recent

快捷键

Shift-Ctrl-O

列出最近使用过的文件,单击打开。

恢复

最近的对话

参考

菜单

文件 ‣ 恢复 ‣ 最近的会话

加载上次退出之前 Blender 自动保存的 quit.blender 文件。如果你意外关闭了 Blender,这个选项可以让你恢复上一次的工作会话。

自动保存

参考

菜单

File ‣ Recover ‣ Auto Save

允许你打开自动的保存文件。

See also

自动保存

保存文件

参考

菜单

文件 —> 保存

快捷键

Ctrl-S

保存当前 .blend 文件(如果当前文件从来没有被保存过,会切换到 另存为… )。

../../_images/files_blend_open-save_file-browser-save.png

文件浏览器保存文件。

See also

自动保存

另存为

参考

菜单

文件 —> 另存为…

快捷键

Shift-Ctrl-S

选择一个 .blend 文件的保存路径。

Warning

如果已存在具有相同名称的文件,则文本框会变为红色,表示将覆盖该文件。

Tip

使用文件名右边的 按钮,或者 NumpadPlusNumpadMinus 来增加/减少在文件名末尾的数字(比如改变 file_01.blendfile_02.blend)。

选项

压缩文件

When enabled, the saved file will be smaller, but take longer to save and load.

Note

While compression is useful for distributing files online and saving drive space for large projects it has drawbacks too.

This option may slow down Blender when you quit, or under normal operation when Blender is saving your backup files. See 压缩和内存使用 for more information.

更新相对路径

这个选项在将文件保存到一个新位置的时候更新 相对路径 (比如一个关联的库或者是图片)。

保存副本

This option saves a copy of the actual working state but does not make the saved file active.

保存副本

参考

菜单

文件 ‣ 保存副本…

选择一个 .blend 文件的保存路径,在保存后继续编辑原始文件。这可用于在不影响原始文件的情况下备份当前工作状态。

For options see 另存为.

相对路径

许多 .blend 文件都会引用外部图像或其它链接的 .blend 文件。 会使用路径来告诉 Blender 在哪里查找这些被引用的外部文件。 如果改变外部文件的位置,引用它们的 .blend 文件将会出错。

当你指定一个外部文件时,默认选项是将路径变成相对路径。 Blender 保存相对于引用 blender 文件的目录位置的部分路径。 当您需要重新组织文件夹或移动文件时,这个选项会很有用。

使用相对路径,你可以把 .blend 文件移动到新位置,前提是外部关联的文件也一起移动。比如,你可以把一个包含 blend文件及其所引用的外部图像的子目录的文件夹一起发给某个人。

当支持相对路径时,文件管理器提供一个 相对路径 的复选框,当在文本框中输入路径时,使用双斜线(//)前缀来实现使用相对路径。

相对路径是默认的,但是可以在 用户设置文件 标签页中进行更改。

Note

你不能在 untitledblend 文件中使用相对路径。在关联外部文件需要前先保存当前的文件。

Hint

If it is necessary to relocate a blend-file relative to its linked resources, use Blender's File Save As function which has an option to Remap Relative file links.