はじめに

../../_images/editors_dope-sheet_introduction_overview.png

Dope Sheet。

Dope Sheetは、アニメーターにシーン内のキーフレームの鳥瞰図を提供します。

Dope Sheetは、アニメーターがチャートを利用して、各描画、サウンド、カメラの動きがいつ、どのくらいの時間発生するかを正確に示す、古典的な手描きのアニメーションプロセスに触発されています。これは、露光シートまたは「Dope Sheet」と呼ばれます。CGの基礎は古典的な手描きのアニメーションとは劇的に異なりますが、Blenderの Dope Sheet は同様のディレクティブを継承しています。

Dope Sheetのモード

../../_images/editors_dope-sheet_introduction_modes.png

Dope Sheet モード。

Dope Sheet モードでは、一度に複数のアクションを編集できますが、他のモードは、アニメーションのさまざまなコンテキストで使用される特定のデータブロックの表示と編集専用です。

主なリージョン

キーフレーム

../../_images/editors_dope-sheet_introduction_types.png

Dope Sheet エディターのオブジェクトチャネル。

この領域には、表示されているすべてのアクションチャネルのキーフレームが含まれています。他の時間ベースのエディターと同様に、X軸は時間を表します。Y軸は、アクションチャネルのスタックを表します。

これらのチャネルには、さまざまな情報を表示するキーフレームがあります:

灰色

未選択

黄色

Selected

Diamond

Free Keyframe Handle

Round (丸め)

Auto-Clamped Keyframe Handle

Circle

Automatic Keyframe Handle

Square

Vector Keyframe Handle

ひし形

Aligned Keyframe Handle

さまざまな色

これらは、ユーザーが設定したカスタムキーフレームタグを表します(Key ‣ Keyframe Type)。

キーの間の灰色のバー

保持されたキー(2つのキーフレームは同一です)

キーの間の緑色のバー

修正されたキーフレーム補間 (Key ‣ Interpolation Mode で設定)

上向き矢印

最大エクストリームキーフレーム(View ‣ Show Curve Extremes が有効のときに表示されます)

下向き矢印

最小エクストリームキーフレーム(View ‣ Show Curve Extremes が有効のときに表示されます)

キーフレームの選択

選択ツールはヘッダーの Select メニューで使用でき、主なショートカットは次のとおりです:

選択

キーをクリックして選択します。 Shift を押しながら、現在の選択物を拡張できます。

ボックス選択

クリックしドラッグすることで、複数のキーフレームを一度にボックス選択します。 Shift を押しながらで現在の選択物を拡張し、 Ctrl を押しながらで現在の選択物から減らすことができます。

Select Lasso

See Lasso Select.

すべてを選択/すべての選択を解除
  • すべてのキーを選択するには、 A を押します。

  • すべてのキーの選択を解除するには、 Alt-A を押します。

  • 選択状態を逆にするには、 Ctrl-I を押します。

現在のフレームの前/後 [, ]

右、または、左のすべてを選択します。または、再生ヘッドのいずれかの側を Shift-Ctrl を押したままクリックします。

選択ツールの完全なリストについては、 Select メニューを参照してください。

キーフレームの操作

キーフレームツールは、ヘッダーの Key メニューと、以下に示す主なショートカットで使用できます:

キーフレームの移動

単一のキーフレームを移動するには、キーをクリックしてドラッグします。複数のキーフレームを移動するには、複数のキーを選択して、 G を押します。

キーフレームの拡大縮小

選択したキーを拡大縮小(ストレッチ)するには、 S を押します。

キーフレームの拡張

2つのキー間の時間を拡張するには、 A ですべてを選択し、再生ヘッドを2つのキーフレームの間に配置して、 E を押します。

選択ツールの完全なリストについては、 Key メニューを参照してください。

チャンネル領域

../../_images/editors_dope-sheet_introduction_action-editor-sliders.png

アクションエディターのチャネル領域。

Channels を参照してください。