アンドゥとリドゥ

以下のツールを使用することで、不測のアクションを巻き戻したり、最後のアクションをやり直したりできます。また、Blenderに記録された最近の実行履歴リストから特定の時点を選択し、復元することができます。

Undo

Reference

Mode

全てのモード

Menu

Edit ‣ Undo

ショートカットキー

Ctrl-Z

直前の実行を取り消すには、Ctrl-Z を押してください。

参考

Editing Preferences の undo セクションで、デフォルトを変更できます。

Redo

Reference

Mode

全てのモード

Menu

Edit ‣ Redo

ショートカットキー

Shift-Ctrl-Z

元に戻したアクションを再度実行するには、Shift-Ctrl-Z を押します。

Adjust Last Operation

Reference

Mode

全てのモード

Menu

Edit ‣ Adjust Last Operation...

ショートカットキー

F9

操作が完了した後で、その操作のパラメータを微調整できます。これをサポートするエディタでは、最後に実行された操作とモード、コンテキストに基づいて左下に「ヘッドアップディスプレイ」パネルが表示されます。また、F9 でもポップアップを表示させることができます。

たとえば、最後の操作が Objectモード での回転だった場合、Blender は変更された最後の角度を表示します (図の左側、回転 (Objectモード、60度)。 を参照)。そこへ Numpad0 と入力すれば、完全にアクションを取り消すことができます。これらはオペレータに基づく便利なオプションで、アンドゥのみに頼らなくとも、使用可能なオプションから完全な変更が可能になります。

Editモード の場合も Blender は、最後に実行したアクションに基づいて内容を変更します。2 番目の例 (右) では、直近の操作はオブジェクトモードでの移動でしたが Edit モードで面の Scale を行いました。それにより (Edit モードであったことにより)、図に示すとおり Adjust Last Operation の内容が違うものになります (図の右側 スケール (Editモード、面をサイズ変更)。 を参照)。

Adjust Last Operation。
../_images/interface_undo-redo_redo-last-object-mode.png

回転 (Objectモード、60度)。

../_images/interface_undo-redo_redo-last-edit-mode.png

スケール (Editモード、面をサイズ変更)。

ちなみに

一部の操作では、Adjust Last Operation を使用することで特に有用な結果が得られます。たとえば、3D Viewportで円を追加します。そして Vertices を 3 に減らすと、完全な正三角形が得られます。

ちなみに

Adjust Last Operation リージョンは、View ‣ Adjust Last Operation によって非表示にすることができます。

Undo History

Reference

Mode

全てのモード

Menu

Edit ‣ Undo History

../_images/interface_undo-redo_undo-history-menu.png

Undo Historyメニュー。

Blenderによって記録された最近のアクションに対する、Undo History機能もあります。

先頭の項目は、最新のアクションに対応しています。項目の横にある小さな点のアイコンは、現在のステータスを示します。Undo History 機能を使用したロールバックによって、選択したアクションの時点まで戻ることができます。新しい変更を加えない限り自由に、過去の操作をさかのぼる Undo や、同様にやり直す Redo で飛び回ることができます。新しい変更を行うと、その時点で Undo History は切り捨てられます。リスト内の項目の 1 つを選択すると、現在の状態がその項目の時点になります。

Repeat Last

Reference

Mode

全てのモード

パネル

Edit ‣ Repeat Last

ショートカットキー

Shift-R

Shift-R を押すと、Repeat Last機能によって最後のアクションを繰り返します。

下図の例では、Monkey メッシュを複製した際にオブジェクトを少し移動させました。引き続き Shift-R を押すことで、Monkey が複製され、移動されました。

../_images/interface_undo-redo_repeat-last1.png

スザンヌ。

../_images/interface_undo-redo_repeat-last2.png

Shift-D と移動の後。

../_images/interface_undo-redo_repeat-last3.png

Shift-R を押した後。

Repeat History

Reference

Mode

全てのモード

Menu

Edit ‣ Repeat History...

../_images/interface_undo-redo_repeat-history-menu.png

Repeat Historyメニュー。

Repeat History 機能により、最近行ったアクションがリストに表示され、繰り返したいアクションを選択することができます。上記で説明したUndo Historyと同じように動作しますが、リストには繰り返し可能なアクションのみが含まれます。

重要

Blenderを終了すると、その前にファイルを保存した場合であっても、アクションのリストは完全に失われます。

参考

失われた作業の回復 に関するトラブルシューティングのセクション。