Editing(編集)

テキストの編集はBlenderの他のオブジェクトタイプとはかなり異なり、主に2つの領域で行われます。まずは、テキストを入力する3D Viewport(3Dビューポート)であり、例えばスタイルを適用する( Font(フォント) を参照)ためのショートカットがいくつかあります。ただし、Edit Mode(編集モード)のほとんどのBlenderショートカットはテキストに対しては存在しないことに注意してください。2つ目の場所は、 Properties(プロパティ)、特に Font(フォント) タブです。

Text(テキスト)

参照

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

3D Viewport(3Dビューポート) ‣ Text(テキスト)

テキストオブジェクトの編集は、標準のテキストエディタを使用する場合と似ていますが、フル機能ではないなど、いくつかの違いがあります。3D Viewport(3Dビューポート)のヘッダーのメニューには、いくつかのオプションがあります。トランスフォームツールやミラーツールなどはありません。Edit Mode(編集モード)を終了するには、他のオブジェクトタイプと同様に、Edit Mode(編集モード)を開始および終了するために、 Tab 使用します。テキストにタブ文字は挿入されません。

Cut(カット) Ctrl-X

テキストをカットしてバッファにコピーするには、 Edit(編集) メニューのショートカットか対応するエントリを使用します。

Copy(コピー) Ctrl-C

テキストをバッファにコピーするには、 Edit(編集) メニューのショートカットか対応するエントリを使用します。

Paste(貼り付け) Ctrl-V

テキストをバッファから貼り付けるには、 Edit(編集) メニューのショートカットか対応するエントリを使用します。

Paste File(ファイルの貼り付け)

外部テキストファイルからテキストを挿入します。有効なUTF-8ファイルに移動するための File Browser(ファイルブラウザー) が表示されます。いつものように、インタラクティブな応答が遅くなるので、ファイルにあまり多くの文字が含まれていないことに注意してください。

To Uppercase(大文字化)

選択したテキストを大文字に変更します。

To Lowercase(小文字化)

選択したテキストを小文字に変更します。

Special Characters(特殊文字)

キーボードから入力できない文字を挿入するための限定された文字コード表です。他の多くの特殊文字を "構成" することができます。 アクセント文字 を参照してください。他の文字が必要な場合は、外部のエディターまたは文字コード表プログラムからコピーして貼り付ける必要があります。

注釈

テキストバッファはデスクトップクリップボードと同期しています。ただし、Blender内で使用されている場合は、テキストの書式もコピーされます。テキストを挿入する他の方法については、 テキストの挿入 を参照してください。

Toggle Bold(太字を切替え)、Italics(斜体)、Underline(下線)、Small Caps(スモールキャピタル)

Bold(太字)Italics(斜体)Underline(下線)Small Caps(スモールキャピタル) 属性を文字のセットに適用するには、文字を入力する前に関連する設定をオンにするか、既存のテキストを選択して、メニューから望みのスタイルへ切り替えます。

警告

Blenderの Bold(太字) ボタンと Italic(斜体) ボタンは、他のフォントを手動でロードするためのプレースホルダーとしても機能するため、他のアプリケーションと同じようには機能しません。

Kerning(カーニング)

フォントカーニングは、個々の文字間のスペースです。

Decrease Kerning(カーニングを減少) Alt-Left

カーソルの両側の文字間隔を狭めます。

Increase Kerning(カーニングを増加) Alt-Right

カーソルの両側の文字間隔を広げます。

Reset Kerning(カーニングをリセット)

カーソルの両側の文字間隔を初期値に設定します。

Delete(削除)
Previous/Next Character(前/次の文字)

カーソルの前/後の文字を削除します。

Previous/Next Word(前/次の単語)

カーソルの前/後の単語を削除します。

テキストの挿入

テキストは、2つの方法で挿入できます: 内部テキストバッファ(上記のとおり)からと、テキストファイルからです。

既存のテキストデータブロックを使用して、テキストエディターのヘッダーから、必要に応じて、 Edit(編集) ‣ Text to 3D Object(テキストを3Dオブジェクトに) で選択し、 One Object(1つのオブジェクトに)One Object per Line(行ごとに別のオブジェクトに) で、オブジェクトに変換できます。

3Dテキストの編集中に、クリップボードから貼り付けたり、 Edit(編集) メニューからファイルを貼り付けたりすることもできます。

アクセント文字

多くの特殊文字(キーボードでは直接入力できないアクセント付き文字など)は、他の2つの文字の組み合わせを使用して "構成" できます。これを行うには、メイン文字を入力し、 Alt-Backspace を押してから、目的の "修飾" を押して特殊文字を生成します。いくつかの例を以下に示します。

  • ã: A, Alt-Backspace, ~

  • á: A, Alt-Backspace, '

  • à: A, Alt-Backspace, \

  • â: A, Alt-Backspace, ^

  • å: A, Alt-Backspace, O

  • æ: A, Alt-Backspace, E

  • ª: A, Alt-Backspace, -

  • ë: E, Alt-Backspace, "

  • ç: C, Alt-Backspace, ,

  • ¢: C, Alt-Backspace, |

  • ø: O, Alt-Backspace, /

  • §: S, Alt-Backspace, S

  • †: |, Alt-Backspace, -

  • ‡: |, Alt-Backspace, =

  • ©: O, Alt-Backspace, C

  • ®: O, Alt-Backspace, R

  • ™: T, Alt-Backspace, M

  • ½: 1, Alt-Backspace, 2

  • ÷: -, Alt-Backspace, :

  • ±: -, Alt-Backspace, +

メッシュやカーブへの変換

Object Mode(オブジェクトモード)では、テキストオブジェクトをメッシュやカーブオブジェクトに変換できます。 Convert(変換) を参照してください。

Tip

結果のトポロジーは通常少し厄介なので、メッシュをクリーンアップするために、 Limited Dissolve(限定的溶解) の削除を使用するか、低いしきい値で Remesh modifier(リメッシュモディファイアー) を適用すると便利な場合があります。

マテリアルの割り当て

参照

Mode(モード)

Edit(編集)

Panel(パネル)

Properties(プロパティ) ‣ Materials(マテリアル)

文字ごとに異なるマテリアルを持つために、各文字は異なる Material index(マテリアルインデックス) を持つことができます。

入力時にインデックスを割り当てることも、テキストのブロックを選択して Materials(マテリアル) パネルの Assign(割り当て) ボタンをクリックした後にインデックスを割り当てることもできます。

../../_images/modeling_texts_editing_material-index-example.png

赤、緑、青色のテキストの例。