複製

Reference

Mode

Edit Mode と Object Mode

Menu

Object ‣ Duplicate Objects

ショートカットキー

Shift-D

これにより、選択したオブジェクトの視覚的に同一のコピーが作成されます。コピーは元のオブジェクトと同じ位置に作成され、自動的に移動モードになります。以下の例を参照してください。

このコピーは新しいオブジェクトであり、元のオブジェクト(デフォルトでは、すべてのマテリアル、テクスチャ、およびFカーブ)とデータブロックを共有しますが、例えばメッシュなどの他のデータをコピーします。すべてのデータブロックが共有されているわけではなく、いくつかは "ハードコピー" されていることは、この形式の複製が "浅いリンク" と呼ばれることがある理由です。

ちなみに

Preferences で、データブロックのタイプごとに、複製するときにリンクするかコピーするかを選択できます。

../../../_images/scene-layout_object_editing_duplicate_example.png

Cubeオブジェクトの複製。

Shift-D を使用して、オブジェクト Cube が複製されました。これらの立方体は両方とも、 CubeCube.001 という一意の名前を持つ個別のメッシュを持っています。

  • 元の左側の立方体は編集中ですが、複製された右側の立方体は変更されません。メッシュデータはコピーされており、リンクされていません。

  • 同様に、一方の立方体がObject Modeで編集された場合、もう一方の立方体は変更されません。新しいオブジェクトの変換プロパティやデータブロックはコピーであり、リンクされていません。

  • 立方体が複製されると、元の立方体のマテリアルを継承しました。マテリアルプロパティはリンクされており、コピーされていません。

通常リンクされているデータブロックの個別のコピーが必要な場合は、上記を参照してください。