Duplicate Linked

Reference

Mode

Object Mode

Menu

Object ‣ Duplicate Linked

ショートカットキー

Alt-D

Duplicate の代わりに、 Linked Duplicate を作成することを選択することもできます。これはディープリンクと呼ばれます。これにより、元のオブジェクトに すべての データがリンクされた新しいオブジェクトが作成されます。リンクされたオブジェクトを Edit Mode で修正すると、リンクされたすべてのコピーが変更されます。変換プロパティ(オブジェクトデータブロック)はリンクではなくコピーのままなので、他のコピーに影響を与えることなく、自由に回転、スケール、移動ができます。以下の説明については、 を参照してください。

元のオブジェクトがアニメーション化されている場合、複製は同じ Action にリンクします。つまり、各オブジェクトには個別の変換プロパティがありますが、アニメーションシステムによって同じ値に設定されます。これが望ましくない場合は、 Action または NLA Editor でアクションをシングルユーザーコピーにします。

Linked

In the Duplicate Objects Adjust Last Operation panel the Linked checkbox is checked unlike with Duplicate.

ヒント

元のオブジェクトとは別に、新しいリンクされた複製オブジェクトに変更を加えたい場合は、Propertiesの Object Data パネルで、数値を LMB にてオブジェクトを手動で "シングルユーザー" コピーする必要があります。( データブロックメニュー を参照してください。)

参考

データブロックのリンクを解除するには、Make Single User を参照してください。

../../../_images/scene-layout_object_editing_duplicate-linked_example.png

Cubeオブジェクトのリンク複製。

Alt-D を使用して、オブジェクト Cube がリンク複製されました。これらの立方体は一意の名前: CubeCube.001 を持つ別々のオブジェクトですが、 Cube という名前の一つのメッシュを共有しています。

  • Edit Mode で一方のオブジェクトのメッシュが編集されると、他の立方体でも同じことが発生します。メッシュデータはリンクされており、コピーではありません。

  • 対照的に、これら2つの立方体の一方が Object Mode で回転やスケールされた場合、もう一方は変更されません。変換プロパティはコピーされており、リンクされていません。

  • 前の例と同様に、新しく作成された立方体は元の立方体のマテリアルを引き継いでいます。マテリアルプロパティはリンクされており、コピーされていません。

一般的なテーブルには、天板と4本の脚があります。1つの脚をモデル化し、残りの脚は3回リンク複製を作成します。後でメッシュに変更を加えた場合でも、すべての脚は一致します。リンク複製は、グラスのセット、車のタイヤなど、繰り返しや対称性があるところに応用できます。

参考

リンクされたライブラリの複製

リンクされたライブラリ も複製の一形態です。他のBlendファイル内のオブジェクトやデータブロックは、現在のファイルで再利用できます。

ヒント

変換プロパティ(つまり、オブジェクトデータブロック)を "リンク" するには、 parenting のページを参照してください。