Editing(編集)

展開した後、テクスチャやペイントで使用できるように、UVマップを配置する必要があります。編集のゴールは次のとおりです:

  • (UVマップの)ピースをつなぎ合わせます。

  • 画像の無駄なスペースを最小限に抑えます。

  • 詳細が必要な面を拡大します。

  • ストレッチした面をサイズ変更/拡大します。

  • 粗悪で、ディテールが多すぎる面を縮小します。

デッドスペースを最小限に抑えることで、ほとんどのピクセルをUVテクスチャに最大限のディテールと細かさを与えることに専念することができます。UV面は、ピクセル(画像を構成する小さなドット)のように小さくすることも、画像全体のように大きくすることもできます。おそらく、最初に大きな調整を行ってから、レイアウトを微調整することをお勧めします。

Transform(トランスフォーム)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Tool(ツール)

Toolbar(ツールバー) ‣ Move(移動)、Rotate(回転)、Scale(スケール)、Transform(トランスフォーム)

Menu(メニュー)

UV ‣ Transform(トランスフォーム)

  • Move(移動) G

  • Rotate(回転) R

  • Scale(スケール) S

  • Shear(せん断) Shift-Ctrl-Alt-S

軸のロック

トランスフォームツールの1つを実施後、 XY を押すことでトランスフォーム変換を軸にロックできます。また、 MMB を押し続けると、X軸やY軸への移動が制限されます。

Randomize(ランダム化)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Transform ‣ Randomize

Randomize the scale, rotation and offset of selected UV islands. The Randomize Transform tool in the UV editor works similar to Randomize Transform tool in the 3d view.

Random Seed(ランダムシード)

Changes the random seed used by the pseudo-random number generator, producing a different transform result for each seed value.

Location(位置、場所)

Amount to randomize location.

Rotation(回転)

Amount to randomize rotation.

Scale Even(等しくスケーリング)

Apply the same scale to the U coordinate and V coordinate.

Scale(スケール)

Amount to randomize scale in U and V coordinates.

Mirror(ミラー)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Mirror(ミラー)

ショートカットキー

Ctrl-M

UVは、Y軸やX軸でミラーできます。

  • Mirror X(ミラー X)

  • Mirror Y(ミラー Y)

ホットキー XY を使用するか、 MMB を押したままミラー方向にドラッグすることもできます。

Copy Mirrored UV Coordinates(UV座標をミラー反転コピー)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Copy Mirrored UV Coordinates(UV座標をミラー反転コピー)

ミラーしたメッシュの一方からもう一方へUVをコピーします。選択した頂点(両側)にのみ影響します。

Axis Direction(軸方向)

Positive(正方向)/Negative(負)

Precision(精度)

頂点の重複を見つけるための許容値。

Snap(スナップ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Snap(スナップ)

ショートカットキー

Shift-S

UVエディタでのスナップは、 3DでのSnapping(スナップ) に似ています。ピクセルへのスナップオプションを機能させるには、画像をロードする必要があります。

Selected to Pixels(選択物 → ピクセル)

Moves selection to nearest pixel. See also Round to Pixels below.

Selected to Cursor(選択物 → カーソル)

選択物を2Dカーソル位置に移動します。

Selected to Cursor (Offset)(選択物 → カーソル(オフセット))

中心からの頂点のオフセットを維持しながら、選択物の中心を2Dカーソル位置に移動します。

Selected to Adjacent Unselected(選択物 → 近くの非選択物)

選択物を隣接する選択されていない要素に移動します。

Cursor to Pixels(カーソル → ピクセル)

カーソルを最も近いピクセルにスナップします。

Cursor to Selected(カーソル → 選択物)

カーソルを選択物の中心に移動します。

Cursor to Origin

Places the cursor to the location (0, 0, 0).

Merge(マージ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Merge(マージ)

ショートカットキー

M

At Center(中心に)

選択したUVを平均位置に移動します。

At Cursor(カーソル位置に)

選択したUVを2Dカーソル位置に移動します。

By Distance(距離で)

指定された Merge Distance(結合距離) 内で選択されたUVをマージします。

Split(分割)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Split(分割)

ショートカットキー

Alt-M

Selection(選択) Y

選択物を残りのUVから分割(切断)します。選択されていない要素の境界の辺が複製されます。

"コピー"は元の位置とまったく同じ位置にあるため、はっきりと見るためには、移動する必要があることに注意してください。

Unwrap(展開)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Unwrap(展開)

ショートカットキー

U

BlenderはUVをマッピングするいくつかの方法を提供します。より単純な投影方法では、サーフェスを通る点、軸、または平面に向かって点の位置を補間することにより、3D空間を2D空間にマッピングする式を使用します。より高度な方法は、より複雑なモデルを使用でき、より具体的な用途があります。

Pin(ピン止め) & Unpin(ピンを外す)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Pin(ピン止め)/Unpin(ピンを外す)

ショートカットキー

P, Alt-P

UVをピン止めして、複数の展開操作間で移動しないようにすることができます。モデルを展開するときに、特定のUVを "ロック" して、UVレイアウトの一部が同じ形状や同じ場所にとどまるようにすると便利な場合があります。ピン止めは、UVを選択し、UV メニューから Pin(ピン止め) を選択するか、またはショートカット P で実行できます。ショートカット Alt-P を使用して、UV の Unpin(ピンを外す) ことができます。

ピン止めは、有機オブジェクトに対してUVマッピングの展開メソッドを使用する場合に最も効果的です。例として、 Mirror Modifier(ミラーモディファイアー) を使用して対称オブジェクトをモデリングしている場合があります。ミラー軸上のUVの一部は、ミラー対応するものとの間で共有される場合があります。中線に対応するUVをピン止めしてから、X軸上に揃えると、その位置に留まります。

The sculpting tools, Pinch and Relax, will not move any pinned UVs. This allows you to pin the borders, or around interior holes, and gives even more control to the sculpt tools.

Pinning also works great with the Live Unwrap tool. If you pin two or more UVs, with Live Unwrap on, moving or scaling the pinned UVs will interactively unwrap the model. You can even use the Grab sculpting tool to move the pinned UVs. This helps with fitting a UV island to a certain shape or region.

Mark/Clear Seams(シームをマーク/クリア)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Mark/Clear Seam(シームをマーク/クリア)

Seams(シーム) を参照してください。

Seams from Islands(アイランドによるシーム)

参照

Mode(モード)

View(ビュー) モード

Menu(メニュー)

UV ‣ Seams from Islands(アイランドによるシーム)

既存のUVアイランドの境界にシームを追加します。これは、すでに展開されたメッシュのUVを変更するときに役立ちます。

Pack Islands(アイランドを梱包)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Pack Islands(アイランドを梱包)

Pack Islands(アイランドを梱包) ツールは、 Texture Space(テクスチャ空間) を効率的に埋めようとする、重なり合わないアイランドを使用して最適化されたUVレイアウトを生成します。

First it will uniformly scale the selected islands, then individually translate each island so that they maximize the usage of the UV space.

Pack To(梱包の対象)

UVアイランドを梱包する UDIM グリッド。

Closest UDIM(一番近いUDIM)

Pack islands to the UDIM closest to the center of the selection.

Active UDIM(アクティブUDIM)

Pack islands to active UDIM image tile or, if no image is available, the UDIM grid tile where the 2D cursor is located.

Rotate(回転)

Allow islands to be rotated as well as translated to maximize texture usage.

Margin Method

The method to use when calculating the empty space between islands.

Scaled

Use scale of existing UVs to multiply margin. (The default from Blender 3.3 and later.)

Add(追加)

Simple method, just add the margin. (This is the default margin scale from Blender 2.8 and earlier.)

Fraction(小数部)

Precisely specify the fraction of the UV unit square for margin. (Slower than other two methods.)

Margin(余白)

The scale for the empty space between islands.

Average Island Scale(アイランドの大きさを平均化)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Average Island Scale(アイランドの大きさを平均化)

Average Island Scale(アイランドの大きさを平均化) ツールを使用して、すべてがほぼ同じスケールになるように各UVアイランドをスケールします。

Non-Uniform

Reduces average texture stretching within islands by scaling the U and V axes independently.

Shear(せん断)

Reduces average texture shearing within islands by shearing the U axis.

Minimize Stretch(最小ストレッチ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Minimize Stretch(最小ストレッチ)

The Minimize Stretch tool, reduces UV stretch by minimizing the difference between the angles in 3D and the angles in UV space. This tool is similar to the Relax brush sculpt tool with the Geometry Relaxation Method, but uses a different algorithm.

Fill Holes(穴をフィル)

Just during minimize stretch, internal holes will be filled with temporary polygons to prevent stretching and overlaps of the surrounding UVs.

Blend (混合度)

The fraction between 0 and 1 of the original UVs to blend in once the stretch is minimized. A blend of 0 is the fully minimized stretch. Blend of 0.5 is halfway between the original UVs and the minimize stretch UVs.

Iterations(反復)

More iterations result in smoother UVs, but take longer to process.

Stitch(スティッチ)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Stitch(スティッチ)

ショートカットキー

Alt-V

Stitch(スティッチ) ツールは、頂点を共有する選択されたUVに結合します。 Adjust Last Operation(最後の操作を調整) パネルで、 Use Limit(範囲を制限) をアクティブにして Limit Distance(距離制限) を調整することにより、距離によってスティッチを制限するようにツールを設定します。

Align(整列)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Align(整列)

ショートカットキー

Shift-W

The Align tool will move the selected UVs to a line, where that line is specified in different ways by Axis.

The Straighten option will calculate a line segment between two endpoints and move all selected UVs onto that line.

The Align X and Align Y options will axis-align all selected UVs to the midpoint of the current selection.

Axis(座標軸)
Straighten(直線で整列)

Move UV to closest point on line segment.

Straighten X

Move U co-ordinates onto the line.

Straighten Y

Move V co-ordinates onto the line.

Align X

Move U co-ordinates to the midpoint of the selection.

Align Y

Move V co-ordinates to the midpoint of the selection.

Align Auto

Choose between Align X or Align Y automatically.

Align Rotation

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Align Rotation

The Align Rotation tool aligns entire islands to either the U or V axis.

The tool has three different methods of operation. The different methods specify the source for the alignment, and also whether to align with both the U and V axes, or just the V axis alone.

When using the Auto method, islands are aligned so that UV edges are aligned to either the U axis or the V axis. This method works best with quads and meshes representing organic subjects.

When using the Edge method, only the selected edges are considered, and the islands will be aligned such that the selected edges are aligned with the V axis. This method works with the selection, so it works best when a particular edge, or edge loop, needs to be aligned in UV coordinates.

When using the Geometry method, the geometry is taken into consideration. Either the X axis, the Y axis, or the Z axis can be used. Suppose the X axis is chosen. Using this method, edges which have a positive extent in the X axis will be rotated in the UV map so that the edge extends upwards in the V axis. This method works best to align multiple islands which share some common geometric property, either in the X, Y or Z axis.

Note that in the Auto method, edges can end up aligned either up or down or left or right depending on the orientation of the island prior to activating the tool. In the Edge method, the alignment of selected edges can be either up or down in the V axis, whatever is closest to the current orientation of the UV island. By comparison, in the Geometry method, the alignment will always be pointing up in the V axis, ignoring any previous orientation.

Show/Hide Faces(面を表示/隠す)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Show/Hide Faces(面を表示/隠す)

  • Reveal Hidden(隠したものを表示) Alt-H

  • Hide Selected(選択物を隠す) H

  • Hide Unselected(非選択物を隠す) Shift-H

Export UV Layout(UV配置をエクスポート)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UV ‣ Export UV Layout(UV配置をエクスポート)

外部アプリケーションを使用している場合は、メッシュのどこにペイントしているかを知ることが必要になります。

注釈

これは、デフォルトでアクティブ化されている アドオン です。

Proportional Editing(プロポーショナル編集)

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

ヘッダー

Proportional Editing(プロポーショナル編集)

Menu(メニュー)

UV ‣ Proportional Editing(プロポーショナル編集)

ショートカットキー

O

Proportional Editing(プロポーショナル編集)はUV編集で利用できます。コントロールは3D Viewport(3Dビューポート)と同じです。完全なリファレンスについては、 3DでのProportional Editing(プロポーショナル編集) を参照してください。

UVのオプション

参照

Editor(エディター)

UV Editor(UVエディター)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

UVs(UV)

Live Unwrap(ライブ展開)

ピン止めされた頂点を変換しながら、選択したUVアイランドを継続的に展開します。これは、3D Viewport(3Dビューポート)の Live Unwrap(ライブ展開) オプションとは異なることに注意してください。

Round to Pixels

During UV transforms, you can use Round to Pixels to help with matching features in the image or ensure your UVs have precise horizontal, vertical or diagonal alignment.

Note that Round to Pixels is applied after any snapping modes.

Disabled(無効)

UVs will not be rounded.

Corner(コーナー)

Will force the UVs to round to the corner of the nearest pixel of an image if loaded.

Center(中心)

Will force the UVs to round to the center of the nearest pixel of an image if loaded.

Constraining to Image Bounds(画像の範囲に拘束)

標準のテクスチャの場合、このオプションは、UVが0から1のUV範囲外に移動するのを防ぎます。 UDIMs テクスチャの場合、このオプションは、UVが一番近いUDIMタイルの外側に移動するのを防ぎます。

3D Viewport(3Dビューポート)

Rotate UVs(UVを回転)

参照

Editor(エディター)

3D Viewport(3Dビューポート)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

Face(面) ‣ Face Data(面データ) ‣ Rotate UVs(UVを回転)

UVテクスチャの方向は、各面によって定義されます。例えば、画像が上下逆になっている場合や横向きになっている場合は、 Face(面) ‣ Rotate UVs(UVを回転) (3D Viewport(3Dビューポート)のFace Select(面選択)モード)メニューを使用して、面ごとに90度回転してUVを回転させます。

Reverse UVs(UVを反転)

参照

Editor(エディター)

3D Viewport(3Dビューポート)

Mode(モード)

Edit Mode(編集モード)

Menu(メニュー)

Face(面) ‣ Face Data(面データ) ‣ Reverse UVs(UVを反転)

Face(面) ‣ Reverse UVs(UVを反転) ツールは、面ごとのUVをミラーします。これにより、画像が反転し、画像が反転して表示されます。