简介

UV纹理是一张用于模型表面着色的图像(图片、图像序列或者影片),它通过一张或者多张纹理UV贴图映射到模型上的。有三种方法来建立UV贴图:

  1. 使用任意图像编辑软件来创建图像。在UV/图像编辑器中,选择UV纹理并加载图像。Blender会将该纹理UV贴图的颜色传递到网格面上。

  2. 在UV/图像编辑器中当前选中的UV纹理上绘制平面图像,然后通过UV映射将图像中的颜色映射到模型网格表面。

  3. Paint the mesh in the 3D Viewport, and let Blender use the currently selected UV map to update the UV texture (as discussed below).

Blender内置的绘画模式叫 纹理绘制 ,它是特别为了在UV/图像编辑器窗口或3D视图窗口简单快速绘制UV纹理和图像而设计的。由于UV纹理仅是一张特殊用途的图像,你也可以用任何外部程序来创建,如GIMP或Krita。

../../_images/sculpt-paint_texture-paint_introduction_example.png

在Blender绘制纹理。

由于一个模型可以有多层UV纹理,可能会有许多图像为网格着色,但是每个UV纹理只有一个图像。

纹理绘制 在三维视口和图像编辑器中都能工作。在三维视口的纹理绘制模式中,你可以通过投射到UV上直接在网格上绘制。

Tip

内存优化

纹理绘制 在3D视口中工作时,以及当图像大小为正方形时,边长为两个,例如256 × 256、512 × 512、1024 × 1024等时,速度快且响应迅速。

入门

要绘制的对象必须首先 展开 。UV可以按照传统方式,通过标准的 展开工具 添加,或者在纹理绘制模式下添加 简易UV

Note

当无法检测到UV层时,Blender将显示警告消息。

将模型展开到 UV 贴图后,即可开始纹理处理过程。要使用纹理绘制,您可以执行以下任一操作:

  • 激活纹理绘制工作区。在这里, 3D视口启用了纹理绘制模式,并且图像编辑器已切换到绘制模式。

  • 在3D视口中,从标题中的模式选择器中选择纹理绘制模式,您可以直接在网格上绘制。

  • 在图像编辑器中,切换到绘制模式(如右图所示)。

../../_images/sculpt-paint_texture-paint_introduction_paint-mode.png

启用 "绘制" 模式。

启用纹理绘制后,鼠标将变为画笔。启用纹理绘制或切换到纹理绘制模式后,工具栏中将提供不同的工具。

In the Image Editor, you paint on a flat canvas that is wrapped around the mesh using UV coordinates. Any changes made in the Image Editor show up immediately in the 3D Viewport, and vice versa.

To work with the UV layout (for example, to move coordinates) you must use the UV编辑器.

画笔和颜色可以完整的从UV/图像编辑器的侧栏中选择。在任何一个面板中所做的笔刷更改都会立即反映在另一个面板中。但是修改后的纹理将 不会 自动保存;你必须通过 Image Editor ‣ Image ‣ Save 执行。

纹理预览

如果纹理已经使用的颜色纹理,凹凸贴图,置换,Alpha透明,等等,在场景中模型的表面(用专业技术人员的话说,通过UV映射,对应的将不同的贴图映射到对应的通道上),就可以在场景中的看到绘制的效果。

为此,请设置并排区域,在3D视口中将一个区域设置为 纹理 阴影选项,并在第二个区域中设置图像编辑器加载图像。定位3D视口以显示UV映射到加载图像的对象。在右侧的图像中,正在绘制的纹理映射到 "正常" 属性,并被称为 "凹凸映射" ,其中灰度图像用于使平坦表面看起来凹凸不平。有关凹凸贴图的更多信息,请参阅纹理映射输出。

保存

如果标题栏的图像菜单旁边有一个星号,它代表图像被更改,但是还没有保存。使用 图像 ‣ 保存图像 选项来另存你的成果或者覆盖原文件保存。

Note

UV纹理

由于用作UV纹理的图像和其他图像功能不同,你应当把它们放在单独的目录下,区别于其他图像。

保存的图像格式与渲染格式无关。在文件浏览器的标题栏中选择保存UV图像的格式,默认为 PNG (.png)。

如果在文件浏览器的窗口标题栏启用了打包,或者手动使用 图像 ‣ 打包图像,则不需要将图像保存到单独的文件中。

使用外部图像编辑器

如果你使用外部软件编辑uv纹理,你必须:

  1. 运行绘画程序(GIMP,Krita等)。

  2. 载入或创建一个新图像。

  3. 改变图像。

  4. 在外部软件中重新保存。

  5. 返回Blender,在UV/图像编辑器重新载入图像。

如果你的团队成员使用不同的uv纹理制作软件,或者是你想使用一些纹理绘制不具备的特效,或者是你熟悉其他绘画软件的时候,你就需要使用外部软件来处理uv纹理。

已知局限

UV重叠

通常情况下,重叠的UV是不支持的(比如烘焙贴图)。

尽管如此,这只是单个笔触多个面上绘制共享纹理的时候会出现的问题。

透视图 &视图背面

当绘制的面的有一部分在视图的背面时(透视模式下),这个面将无法被绘制。要避免这种情况,请缩放或者切换到正交视图的方式。

透视图&低面多边体

When painting onto a face in perspective mode onto a low-poly object with normals pointing away from the view, painting may fail; to workaround disable the Normal Falloff option in the stroke settings.

Typically this happens when painting onto the side of a cube (see Blender bug #34665).