集合

场景中可以有许多物体:典型的舞台场景包括家具、道具、灯光和背景。 Blender允许将类似物体组合在一起,从而帮助用户保持一切井井有条。物体可以组合在一起而没有任何类型的变换关系(与设置父级不同)。 集合用于逻辑地组织场景,或方便一步在文件间或跨场景添加或链接。

Collections Tab

参考

菜单

Properties ‣ Collection Properties

限制

可选

Toggles the ability to select the objects from the 3D Viewport. This is useful for if you have placed something in the scene and do not want to accidentally select it when working on something else.

在渲染中禁用

在渲染中启用/禁用集合的可见性。

阻隔

Objects inside this collection will generate a holdout/mask in the active view layer.

仅间接

Objects inside this collection will only contribute to the final image indirectly through shadows and reflections.

实例化

Instance Offset X, Y Z

应用实例化集合与源物体的原点间的空间偏移量。

线条画

待补充。

集合菜单

参考

模式

物体模式

菜单

物体(Object) ‣ 集合(Collection)

快捷键

M, Shift-M, Ctrl-G, 等等。

移动到集合 M

Move selected objects to an existing or new collection.

关联到集合 Shift-M

关联所选物体到集合。可以在弹出菜单中创建新集合。

创建新集合 Ctrl-G

Creates a new collection and adds the selected object(s) to it. The name of the new collection can be specified in the Create New Collection 调整上一步操作 panel. This collection is not linked to the active scene.

从集合中移除 Ctrl-Alt-G

Remove the selected objects from a collection. If the object belongs to more than one collection, a pop-up lets you select the collection and an option to remove it from all collections.

Remove from All Collections Shift-Ctrl-Alt-G

Remove the selected objects from all collections.

所选物体加入到活动集合 Shift-Ctrl-G

将选中的物体加选到活动物体所属的集合。

从活动集合中移除所选物体 Shift-Alt-G

将所选物体从活动物体所在的集合中移除。

集合面板

参考

模式

物体模式

面板

属性编辑器(Properties) ‣ 物体选项卡(Object tab) ‣ 集合(Collections)

../../_images/scene-layout_collections_collections_panel.png

集合面板。

All collections that an object has been assigned to are listed in the Properties Object tab ‣ Collections panel.

添加到集合

Adds the selected object to a collection. A pop-up lets you specify the collection to add to.

新建 +

Creates a new collection and adds the selected object to it.

名称

只需单击集合名称文本框,即可重命名该集合。

删除 X

从集合中移除物体,找到你想要移除的物体所在集合的名称,点击集合名称右侧的 X 按钮。

其他菜单

Unlink Collection, Select Collection, Set Offset from Cursor

偏移量

应用实例化集合与源物体的原点间的空间偏移量。

See also

追加或关联集合

要从其它blend文件中追加集合,参考 此页。简而言之,点击 文件(File) ‣ 关联/追加关联(Link/Append Link) 后选择一个blend文件里面的集合。

Tip

选择集合

集合可以被选择,详情参考 按组选择