编辑

编辑文本与 Blender 中的其他物体类型完全不同,主要发生在两个区域。首先是3D视口,您可以在其中键入文本,并具有一些快捷方式,例如用于应用样式(请参阅 字体 ) - 但是请注意,您在编辑模式下知道的大多数 Blender 快捷方式对于文本都不存在。第二个位置是 "属性",尤其是 字体 选项卡。

编辑文本物体类似于使用标准的文本编辑器,但功能不全并且有一些区别。3D视图标题栏的菜单提供的选项很少。你没有变换也没有镜像工具,等等。要离开编辑模式,请使用 Tab,因为它不会在文本中插入tab字符,而是像其他物体类型一样进入和退出编辑模式。

剪切

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 剪切

快捷键:

Ctrl-X

要将文本剪切并复制到缓冲区,请使用 编辑 菜单中的快捷方式或匹配条目。

复制

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 复制

快捷键:

Ctrl-C

要将文本复制到缓冲区,请使用 编辑 菜单中的快捷方式或匹配条目。

粘贴

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 粘贴

快捷键:

Ctrl-V

要从缓冲区粘贴文本,请使用 编辑 菜单中的快捷方式或匹配条目。

粘贴文件

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 粘贴文件

从外部文本文件中插入文本,这将弹出一个 文件浏览器,用于导航到有效的UTF-8文件。像往常一样,注意文件的字符不要太多,因为响应会变慢。

大写

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 大写

将所选文本改为大写。

小写

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 小写

将所选文本改为小写。

插入Unicode

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 插入Unicode

Opens a dialog box to input the entry of any Unicode character by entering its hexadecimal codepoint value.

See Wikipedia for a List of Unicode characters which list there respective hexadecimal codepoint values.

特殊字符

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 特殊字符

这是一个有限的字符映射,用于插入键盘无法使用的字符。许多其他特殊字符可以 "组合",见下文 音调字符。如果需要其他的,则必须从外部编辑器或字符映射表工具中复制粘贴它们。

Note

文本缓冲区与桌面剪贴板同步。但如果在Blender中使用它,也会复制文本格式。有关插入文本的其他方法,请参阅下文 插入文本

启用或关闭粗体、斜体、下划线、小型大写

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 切换粗体/斜体/下划线/小型大写

要将 粗体斜体下划线小型大写 属性应用于一组字符,可以在键入字符之前打开相关设置,或选择某些现有文本,然后切换菜单中所需的样式。

Warning

Blender的 粗体斜体 按钮与其他应用程序的工作方式不同,因为它们也可以作为其他字体的占位符而手动加载。

字距

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 字距

字距是指单个字符之间的空间。

减小字距 Alt-Left

缩小光标两边字符之间的间距。

增大字距 Alt-Right

增大光标两边字符之间的间距。

重置字距

将光标两边的字符间距设置为初始值。

删除

参考

编辑器:

3D 视图

模式:

编辑模式

菜单:

标题栏 ‣ 文本 ‣ 删除

上/下一字符

删除光标之前或之后的字符。

上/下一单词

删除光标之前或之后的单词。

插入文本

可以通过两种方式插入文本:从内部文本缓冲区或从文本文件。

使用现有的文本数据块,您在文本编辑器标题栏使用 编辑(Edit) ‣ 将文本转换为 3D 物体(Text to 3D Object),根据需要选择 一个物体每行生成一个物体,将现有的文本数据块转换为物体。

在编辑3D文本时,也可以从剪贴板或文件里粘贴文本。

音调字符

许多特殊字符(例如音调字符,键盘上不能直接显示)可以使用两个其他字符的组合 "组合"。为此,键入主字符,按 Alt-回退键,然后按所需的 "修改器" 以生成特殊字符。下面给出一些例子:

  • ã: A, Alt-回退键, ~

  • á: A, Alt-回退键, '

  • à: A, Alt-回退键, \

  • â: A, Alt-回退键, ^

  • å: A, Alt-回退键, O

  • æ: A, Alt-回退键, E

  • ª: A, Alt-回退键, -

  • ë: E, Alt-回退键, "

  • ç: C, Alt-回退键, ,

  • ¢: C, Alt-回退键, |

  • ø: O, Alt-回退键, /

  • §: S, Alt-回退键, S

  • †: |, Alt-回退键, -

  • ‡: |, Alt-回退键, =

  • ©: O, Alt-回退键, C

  • ®: O, Alt-回退键, R

  • ™: T, Alt-回退键, M

  • ½: 1, Alt-回退键, 2

  • ÷: -, Alt-回退键, :

  • ±: -, Alt-回退键, +

转换为网格或曲线

在物体模式下,可以将文本物体转换为网格或曲线,请参见 转换

Tip

结果的拓扑结构通常有点混乱,因此使用 有限融并 删除选项或在低阈值时应用 重构网格修改器 可能有助于清理网格。

指定材质

参考

模式:

编辑

面板:

属性编辑器(Properties) ‣ 材质(Materials)

要使不同的字符获得不同的材质,每个字符都必须有一个不同的 材质编号

可以键入指定编号,或者在选择文本块并点击 材质 面板中的 分配 按钮后指定编号。

../../_images/modeling_texts_editing_material-index-example.png

红绿蓝文本示例。