Deshacer y Rehacer

Las herramientas enumeradas abajo permiten deshacer una acción accidental, rehacer la última acción, o restaurar un punto específico, eligiendo de una lista de acciones recientes registradas por Blender.

Undo (Deshacer)

Referencia

Modo

Todos los Modos

Menú

Edit ‣ Undo

Atajo de Teclado

Ctrl-Z

Para deshacer la última acción, simplemente hay que presionar Ctrl-Z.

Ver también

La sección Preferencias de Edición sobre deshacer para cambiar la configuración predeterminada.

Redo (Rehacer)

Referencia

Modo

Todos los Modos

Menú

Edit ‣ Redo

Atajo de Teclado

Shift-Ctrl-Z

Para tirar para atrás una acción Undo, se presionará Shift-Ctrl-Z.

Adjust Last Operation (Ajustar la Última Operación)

Referencia

Modo

Todos los Modos

Menú

Edit ‣ Adjust Last Operation…

Atajo de Teclado

F9

Después de completar una operación se pueden retocar los parámetros de la operación a posteriori. En editores que lo soportan, existe un panel de visualización emergente abajo a la izquierda basado en la última operación realizada, dependiente del modo y contexto. Alternativamente, se puede crear un emergente con F9 que hace lo mismo.

Por ejemplo, si la última operación ha sido una rotación en Modo Objeto, Blender mostrará el último valor del ángulo cambiado (véase la figura Rotación (Modo Objeto, 60 grados). izquierda), donde se puede descartar la última acción completamente tecleando Numpad0. Hay otras opciones útiles, basadas en el operador, y se puede no solo deshacer las acciones, sino cambiarlas completamente utilizando las opciones disponibles.

En Modo Edición, Blender también cambiará su contenido en función de la última operación efectuada. En el segundo ejemplo (a la derecha), la última operación ha sido un Movimiento en Modo Objeto; pero en Modo Edición, un Escalado sobre una Cara, y como puede verse, el contenido de Adjust Last Operation es distinto, debido al modo (Edición). Véase la figura Escala (Modo Edición, Redimensionar cara). derecha.

Adjust Last Operation.
../_images/interface_undo-redo_redo-last-object-mode.png

Rotación (Modo Objeto, 60 grados).

../_images/interface_undo-redo_redo-last-edit-mode.png

Escala (Modo Edición, Redimensionar cara).

Truco

Algunas operaciones producen resultados especialmente útiles usando Adjust Last Operation. Por ejemplo, añadiendo un Círculo en el 3D Viewport; reduciendo los Vértices a tres, se consigue un triángulo equiátero perfecto.

Truco

La región Adjust Last Operation puede ocultarse mediante View ‣ Adjust Last Operation.

Undo History (Historial de Deshacer)

Referencia

Modo

Todos los Modos

Menú

Edit ‣ Undo History

../_images/interface_undo-redo_undo-history-menu.png

El menú Undo History.

Existe también un Historial de las últimas acciones efectuadas, registrado por Blender.

La parte superior de la lista corresponde a las acciones más recientes. Un pequeño icono de un punto junto a una de las entradas indica el estado actual. Retroceder acciones usando la característica de Undo History lleva a la acción elegida. Similar al modo de alternar entre retroceder en el tiempo con Deshacer y luego avanzar con Rehacer se puede ir saltando por la línea temporal de Deshacer tanto como se quiera, siempre y cuando no se realice un cambio nuevo. Una vez se hace un cambio nuevo, el Historial de Deshacer se trunca en ese punto. Seleccionar una de las entradas de la lista lleva el estado actual a esa posición.

Repeat Last (Repetir Último)

Referencia

Modo

Todos los Modos

Panel

Edit ‣ Repeat Last

Atajo de Teclado

Shift-R

La característica Repeat Last repetirá la última acción al presionar Shift-R.

En las imágenes de ejemplo abajo, se ha duplicado una malla Mono y se ha movido ligeramente el objeto. Utilizando repetir Shift-R, el Mono también resulta duplicado y movido.

../_images/interface_undo-redo_repeat-last1.png

Suzanne.

../_images/interface_undo-redo_repeat-last2.png

Tras Shift-D con desplazamiento.

../_images/interface_undo-redo_repeat-last3.png

Tras Shift-R.

Repeat History (Historial de Repeticiones)

Referencia

Modo

Todos los Modos

Menú

Edit ‣ Repeat History…

../_images/interface_undo-redo_repeat-history-menu.png

El menú Repeat History.

La característica Repeat History presenta una lista con las últimas acciones repetidas, y se pueden elegir las acciones que se deseen repetir. Funciona igual que el Historial de Deshacer, explicado arriba, pero la lista contiene solo acciones repetidas.

Importante

Al salir de Blender, la lista completa de acciones se pierde, incluso guardando el archivo antes de salir.

Ver también

Sección de solución de problemas sobre Recuperar trabajo perdido.