Seleccionar

This page discusses specific selecting tools for curve objects in Edit Mode. The Curve Edit more also uses the general select tools used which are described in the interface section.

Curve selection in Edit Mode has fewer options than with meshes. Mainly this is, because there is only one selectable element type, the control points (no select mode needed here…). These points are a bit more complex than simple vertices, however, especially for Bézier curves, as there is the central vertex, and its two handles…

The basic tools are the same as with meshes, so you can select a simple control point with the LMB, add to current selection with Shift-LMB, Box Select B, and so on.

One word about the Bézier control points: when you select the main central vertex, the two handles are automatically selected too, so you can move it as a whole, without creating an angle in the curve. However, when you select a handle, only this vertex is selected, allowing you to modify this control vector…

Note that, unlike mesh edges, you cannot directly select a segment. Instead, select all of the control points that make up the segment you want to edit.

Menú Seleccionar

With curves, all «advanced» selection options are grouped in the Select menu of the 3D Viewport header.

Todo A

Seleccionar todo.

Ninguno Alt-A

Seleccionar nada.

Invertir Ctrl-I

Selects all the geometry that are not selected, and deselect currently selected components.


Selección de Caja B

Selección de caja interactiva.

Selección de Círculo C

Selección de círculo interactivo.

Selección de Lazo

Selección interactiva de forma libre.


Seleccionar Aleatoriamente

Select random control points.

Deseleccionar en Damero

Select every Nth control point.

Seleccionar Vinculado Ctrl-L

Select control points that are connected to the current selection.

Seleccionar Similar Mayús-G

Select control points that have similar properties to the current selection.


(De)select First/Last

Toggle the selection of the first or last control point(s).

Select Next/Previous

Selects the next or previous control points.


Seleccionar Más/Menos

Select objects based on their parent child relationships.

Seleccionar Aleatorio

Referencia

Modo

Modo Edición

Menú

Seleccionar ‣ Seleccionar Aleatorio

Select Random control points.

Porcentaje

Selects the defined percentage of control points.

Semilla Aleatoria

Seed used by the pseudo-random number generator.

Acción

Controls whether the operator Selects or Deselects control points.

Deseleccionar en Damero

Referencia

Modo

Modo Edición

Menú

Select ‣ Deseleccionar en Damero

Esta herramienta aplica un patrón de cuadros alternante seleccionado/deseleccionado. Esto sólo funciona si ya tiene más de un punto de control seleccionado.

Funciona cambiando la selección actual de modo que sólo uno de cada N puntos de control permanecerá seleccionado, a partir del activo.

Deseleccionados

El número de elementos deseleccionados en cada repetición de patrón.

Seleccionado

El número de elementos seleccionados en cada repetición del patrón.

Desplazamiento

Desplazamiento desde el punto de inicio.

Seleccionar Vinculado

Referencia

Modo

Modo Edición

Menú

Seleccionar ‣ Seleccionar Vinculado

Atajo

L, Ctrl-L, Mayús-L

L (or Ctrl-L for all) will add to the selection the cursor’s nearest control point, and all the linked ones, i.e. all points belonging to the same curve. Note that for Bézier, using L with a handle selected will select the whole control point and all the linked ones.

Seleccionar Similar

Referencia

Modo

Modo Edición

Menú

Select ‣ Seleccionar Similar

Atajo

Mayús-G

Selecciona puntos de control que tienen ciertas propiedades similares al activo. El panel Ajustar Última Operación proporciona varias opciones de selección:

Tipo
Tipo

Selects splines that have the same spline Type i.e. Bézier, NURBS or Poly.

Radio

Selects control points that have a similar Radius value.

Influencia

Selects all points that have a similar Weight value.

Dirección

Selects control points that have a similar handles direction.

Comparar

Para propiedades cuantitativas, esta propiedad selecciona el tipo de comparación entre los dos valores numéricos.

Igual

Seleccione elementos con el mismo valor que la propiedad elegida del elemento activo.

Mayor que

Selecciona elementos con un valor mayor como propiedad elegida del elemento activo.

Menos

Selecciona elementos con un valor menor como propiedad elegida del elemento activo.

Umbral

Para las propiedades cuantitativas, esta propiedad controla qué tan cerca deben estar los valores de la propiedad en la comparación.

(De)select First/Last

Referencia

Modo

Modo Edición

Menú

Select ‣ (De)select First, Select ‣ (De)select Last

These operators will toggle the selection of the first or last control point(s) of the curve(s) in the object. This is useful to quickly find the start of a curve (e.g. when using it as path…).

Select Next/Previous

Referencia

Modo

Modo Edición

Menú

Select ‣ Select Next, Select ‣ Select Previous

These operators will select the next or previous control point(s), based on the current selection (i.e. the control points following or preceding the selected ones along the curve). In case of a cyclic curve, the first and last points are not considered as neighbors.

Seleccionar Más/Menos

Referencia

Modo

Modo Edición

Menú

Select ‣ More/Less

Atajo

Ctrl-NumpadPlus, Ctrl-NumpadMinus

Their purpose, based on the currently selected control points, is to reduce or enlarge this selection.

Más

For each selected control point, select all its linked points (i.e. one or two…).

Menos

For each selected control point, if all points linked to this point are selected, keep this one selected. Otherwise, deselect it.

This implies two points:

  1. When all control points of a curve are selected, nothing will happen (as for Less, all linked points are always selected, and of course, More cannot add any). Conversely, the same goes when no control points are selected.

  2. Second, these tools will never «go outside» of a curve (they will never «jump» to another curve in the same object).

Pick Shortest Path

Referencia

Modo

Modo Edición

Menú

Menu Search ‣ Pick Shortest Path

Atajo

Ctrl-LMB

Selects the curve segments between two control points: the active and the one under the cursor. In the case of a closed curve, the shortest path will be selected.