Rendu de la vue

Viewport rendering utilise le rendu de la Vue 3D pour des rendus rapides d”aperçu.

Cela vous permet d’inspecter votre animatique (pour les mouvements d’objets, les angles alternes, etc.).

Cela peut aussi s’utiliser pour prévisualiser vos animations – dans le cas où votre scène est trop complexe à afficher par votre système en temps réel dans la Vue 3D.

Vous pouvez utiliser Viewport Render pour faire à la fois le rendu d’images et d’animations.

Ci-dessous une comparaison entre le Viewport render et un rendu final avec le moteur de rendu Cycles.

Modèle de © 2016 pokedstudio.com
../../_images/editors_3dview_viewport-render_example-workbench-render.jpg

Rendu de la fenêtrer utilisant le mode Solid.

../../_images/editors_3dview_viewport-render_example-eevee-render.jpg

Rendu de la fenêtre à l’aide du mode Aperçu des matériaux.

../../_images/editors_3dview_viewport-render_example-cycles-render.jpg

Rendu complet.

Astuce

Désactivez les overlays pour faire le rendu de la vue sans aucun overlay supplémentaire.

Bien que cette option ne soit pas spécifique à Viewport rendering, il est souvent utile de l’activer, car elle supprime des données telles que les rigs et les empties qui peuvent être une déviation.

Réglages

Dans l’ensemble, Viewport Render utilise les réglages de la vue courante. Certains réglages se trouvent dans le panneau du moteur de rendu utilisé pour faire le rendu de la vue.

Le mode Solid utilise les réglages de rendu de Workbench; le mode LookDev utilise les réglages d’Eevee.

Les options Sampling et Alpha Transparency peuvent être définies dans Properties ‣ Render ‣ Sampling. Assurez-vous que le moteur de rendu Workbench ou Eevee est sélectionné pour voir les valeurs appropriées.

En outre, certains réglages de rendu sont également utilisés :

  • Dimensions du rendu

  • Aspect du rendu

  • Format de fichier et de sortie (chemin de fichier, format, réglages de compression, etc.).

Rendering (rendu)

L’activation de Viewport Render fera le rendu de la vue active courante. Ceci suppose que si vous n’êtes pas dans une vue caméra active alors une caméra virtuelle est utilisée pour correspondre à la perspective courante. Pour obtenir une image du point de vue de la caméra, entrez dans la vue caméra active avec Pavnum0.

Comme pour un moteur de rendu normal, vous pouvez l’interrompre avec Échap.

Faire le rendu d’une image

Pour faire le rendu d’une image fixe, utilisez 3D Viewport ‣ View ‣ Viewport Render Image.

Faire le rendu d’un animation

pour faire le rendu d’une animation, utilisez 3D Viewport ‣ View ‣ Viewport Render Animation.

Render Keyframes

Pour faire le rendu d’une animation, mais uniquement les images qui ont une image clé, utilisez 3D Viewport ‣ View ‣ Viewport Render Keyframes. Cela rend uniquement les images pour lesquelles les objets sélectionnés ont une clé d’animation. Les autres images sont toujours écrites dans la sortie, mais répéteront simplement la dernière image rendue.

Par exemple, lorsqu’une animation à six images est rendue et que les objets sélectionnés ont une clé sur les images 3 et 5, les images suivantes seront rendues:

  1. La 1ère image est toujours rendue.

  2. La 1ère image est répétée car il n’y a pas de clé sur cette image.

  3. La 3ème image est rendue.

  4. La 3ème image est répétée car il n’y a pas de clé sur cette image.

  5. La 5ème image est rendue.

  6. La 5ème image est répétée car il n’y a pas de clé sur cette image.

Astuce

Vous pouvez limiter le rendu de la fenêtre à une région particulière avec Faire le rendu de régions.