Édition

Insertion de trames clés.

Référence

Mode

Mode Objet

Panneau

Tool Shelf ‣ Animation ‣ Animation ‣ Keyframes: Insert

Menu

Object ‣ Animation ‣ Insert Keyframe…

Raccourci

I

Il existe plusieurs méthodes pour ajouter de nouvelles clés, à savoir :

  • Dans la Vue 3D, la pression sur I va ouvrir un menu pour choisir à quoi ajouter une trame clé.

  • En glissant la souris au dessus d’une propriété et en pressant I ou dans le menu contextuel en pressant RMB sur une propriété et en choisissant Insert Keyframe dans le menu.

Auto Keyframe

../../_images/editors_timeline_keyframes-auto.png

Timeline Auto Keyframe.

Auto Keyframe est le bouton rouge d’enregistrement dans l’entête de la Timeline. Auto Keyframe ajoute des trames clés automatiquement à la trame définie si la valeur des propriétés de type de transformation change.

Voir Timeline Keyframe Control pour plus d’informations.

Suppression de trames clés (Delete Keyframes)

Référence

Mode

Mode Objet

Panneau

Tool Shelf ‣ Animation ‣ Animation ‣ Keyframes: Remove

Menu

Object ‣ Animation ‣ Delete Keyframes…

Raccourci

Alt-I

Il y a plusieurs méthodes pour supprimer des trames clés :

  • Dans la Vue 3D, pressez Alt-I pour supprimer les clés des objets sélectionnés sur la trame courante.

  • Quand la souris est sur une valeur, pressez Alt-I.

  • RMB sur une valeur et choisissez Delete Keyframe dans le menu.

Effacement de trames clés (Clear Keyframes)

Référence

Mode

Mode Objet

Menu

Object ‣ Animation ‣ Clear Keyframes…

Supprime toutes les trames clés de l’objet sélectionné.

Édition de trames clés

Les trames clés peuvent être éditées dans deux éditeurs. Pour ce faire, allez dans l”Éditeur Graph ou dans le Dope Sheet.

Exemples

Animation de trames clés

Cet exemple vous montre la manière d’animer la position, la rotation et l’échelle d’un cube.

  1. D’abord dans la Timeline, ou autres éditeurs d’animation, fixez la trame à 1.

  2. Avec le Cube sélectionné en Mode Objet, pressez I dans la Vue 3D.

  3. Depuis le menu Insert Keyframe sélectionnez LocRotScale. Ceci va enregistrer l’emplacement, la rotation et l’échelle du Cube sur la trame 1.

  4. Fixez la trame à 100.

  5. Utilisez Grab/Move G, Rotate R, Scale S, pour transformer le cube.

  6. Pressez :kbd:`I dans la Vue 3D. Dans le Insert Keyframe Menu, sélectionnez LocRotScale.

Pour tester l’animation, pressez Alt-A pour la lire.

../../_images/animation_keyframes_editing_keyframe-animation-examples.png

L’animation aux trames 1, 50 et 100.