Asset Browser (Navigateur d’assets)

Cette section décrit Asset Browser, le navigateur d’assets, qui est l’interface principale pour l’organisation et l’utilisation des assets.

Le navigateur d’assets a été introduit dans Blender 3.0 et sera amélioré et étendu dans plusieurs versions ultérieures.

Voir aussi

Bibliothèques d’Assets

Pour des informations générales sur le système de bibliothèque d’assets de Blender, y compris comment créer et éditer des assets et les choix de conception.

Catalogues d’assets

Pour organiser les assets.

Pose Library

Construire au-dessus du navigateur d’assets.

Interface

../_images/asset_browser-gold-material.png

Navigateur d’assets, affichant les matériaux dans une bibliothèque d’assets.

Région principale

La région principale de l”Asset Browser agit de la même manière que le File Browser intégré à Blender. Il affiche les assets contenus dans le catalogue sélectionné.

Cliquer sur un asset pour le sélectionner et l’activer. Sélectionner la case en faisant glisser LMB ou étendre la sélection avec Shift-LMB pour sélectionner plusieurs assets.

Région de la Source List

La région Source List peut être utilisée pour la navigation et l’utilisation des assets (Using Assets)

Bibliothèque

Affiche la librairie d’assets active et permet de basculer entre les bibliothèques d’assets. La bibliothèque “Current File” est spéciale et affichera toujours les assets du fichier-blend actuel, qu’il fasse ou non partie d’une bibliothèque d’assets.

Copy Asset Bundle to Library

Affiché lorsque le Library Selector est défini sur Current File, le fichier-blend actuel est considéré comme un Asset Bundle et n’est pas encore situé dans une Asset Library.

L’opérateur Copy Asset Bundle simplifie la copie du fichier dans la bibliothèque d’assets. Les catalogues de l’ensemble des assets seront fusionnés dans la bibliothèque d’assets.

Catalog

Vue arborescente des catalogs de la bibliothèque d’assets active.

Les catalogues peuvent être renommés en double-cliquant sur leur nom. Un catalogue peut également être imbriqué dans un autre en le faisant glisser et en le déposant dans un autre.

Les modules complémentaires (add-ons) et les fonctionnalités telles que la Pose Library peuvent afficher des panneaux personnalisés ici.

Région des détails de l’asset

La région Asset Details sur la droite affiche les métadonnées de l’asset actif. Seules les métadonnées des assets contenus dans le fichier-blend actuel peuvent être modifiées.

Name

Le nom du bloc de données de l’asset. Ce nom est unique pour le type de données d’asset dans le même fichier-blend.

Source

Le chemin complet du fichier-blend qui contient l’asset.

Open Blend File

Ce bouton démarrera une nouvelle instance de Blender et ouvrira le fichier-blend qui contient l’asset. En arrière-plan, Blender continuera de surveiller cette nouvelle instance de Blender; à sa fermeture, le navigateur d’assets sera actualisé pour afficher tous les assets mis à jour.

Description

Champ facultatif pour la description de l’asset. Non utilisé par Blender lui-même.

Auteur

Champ facultatif pour l’auteur de l’asset. Non utilisé par Blender lui-même.

Preview

Affiche l’image d’aperçu de l’asset. Voir Aperçus des assets.

Load Custom Preview

Ouvre une fenêtre avec le navigateur de fichiers pour sélectionner une image pour l’aperçu de l’asset.

Generate Preview

Générer/mettre à jour un aperçu de l’asset.

Preview

Menu d’opérateurs de prévisualisation supplémentaires.

Render Active Object

Génère un aperçu en fonction de l’objet Active de la fenêtre 3D. C’est utile pour les groupes de nœuds, en particulier pour les nœuds de géométrie, qui ne peuvent pas générer automatiquement leur propre aperçu.

Tags

Panneau pour afficher et éditer les balises d’asset. Celles-ci n’ont aucune signification pour Blender et peuvent être choisies librement. Lors de l’utilisation du champ de recherche pour filtrer les assets, ceux dont les balises correspondent (partiellement) à la chaîne de recherche seront également affichés.

Note

Selon le mode d’objet actuel et les types d’assets sélectionnés, d’autres panneaux peuvent apparaître. Par exemple, voir Pose Library.

Utilisation des assets

En règle générale, un asset peut être utilisé en le faisant glisser du navigateur d’assets vers l’emplacement souhaité. Les objets et les mondes peuvent être glissés depuis le navigateur de ressources vers la scène, les matériaux peuvent être glissés sur l’objet qui doit les utiliser. L’utilisation des éléments de pose est différente et est décrite dans Pose Library.

Plusieurs événements peuvent se produire lorsqu’un asset est utilisé, selon la configuration du type d’importation du navigateur d’assets:

Link

Identique à File ‣ Link…

L’asset sera lié au fichier-blend actuel et sera donc en lecture seule. Les modifications ultérieures apportées au fichier d’asset seront reflétées dans tous les fichiers qui lui sont liés.

Append

Identique à File ‣ Append…

Tout l’asset et toutes ses dépendances seront ajoutés au fichier actuel. Faire glisser un matériau dans la scène trois fois se traduira par trois copies indépendantes. Faire glisser un objet dans la scène trois fois entraînera également trois copies indépendantes.

“Dependencies” dans ce cas signifie tout ce à quoi l’asset fait référence. Pour un objet, cela peut être son maillage et ses matériaux, mais aussi d’autres objets utilisés par des modificateurs, des contraintes ou des pilotes.

Étant donné que le fichier possède désormais sa propre copie de l’asset, les modifications ultérieures apportées au fichier d’asset ne seront pas reflétées dans le fichier auquel il est ajouté (append).

Append (Reuse Data)

Spécifique au navigateur d’assets.

La première fois qu’un asset est utilisé, il sera ajouté, y compris ses dépendances, comme décrit précédemment. Cependant, Blender gardera une trace de son origine et la prochaine fois que l’asset sera utilisé, autant de données que possible seront réutilisées. Faire glisser un matériau dans la scène trois fois ne le chargera qu’une seule fois et affectera simplement le même matériau trois fois. Faire glisser un objet dans la scène trois fois créera trois copies de l’objet, mais toutes les copies partageront leurs données de maillage, leurs matériaux, etc.

Étant donné que le fichier possède désormais sa propre copie de l’asset, les modifications ultérieures apportées au fichier d’asset ne seront pas reflétées dans le fichier auquel il est ajouté (append).

Instancing Collections

Imite l’option Collections d’instances lors de l’ajout

Certains types d’assets tels que les collections peuvent être créés en tant que collection instanciée. Pour ce faire, sélectionnez l’option Instance lorsque vous faites glisser les actifs de la collection dans la fenêtre 3D. En sélectionnant cette option, un objet vide est ajouté et crée une instance de la collection.

Notez que toutes les opérations régulières de Blender sont disponibles une fois que l’asset a été ajouté au fichier actuel. Par exemple, vous pouvez choisir de lier un objet à la scène; cela liera également son Mesh et ses Materials. Par la suite, vous pouvez rendre l’objet lui-même local (Object ‣ Relations ‣ Make Local… ‣ Selected Objects), tout en gardant le maillage et les matériaux liés aux fichiers d’assets. Cela se traduira par un objet local, donc modifiable et maintiendra automatiquement le maillage et les matériaux à jour avec toutes les modifications apportées à la bibliothèque d’assets.

Aperçus des assets

../_images/asset-browser-preview-panel.png

Panneau d’aperçu dans le navigateur des assets.

Les images d’aperçu sont généralement générées automatiquement lorsque vous marquez un bloc de données comme asset. L’aperçu généré automatiquement tente de capturer l’objet de face. Cependant, cela ne fonctionne que si la géométrie est disposée de manière à correspondre à ce que Blender considère comme étant l’avant. C’est-à-dire que la géométrie qui devrait être l’avant doit pointer vers le bas de l’axe -Y de l’objet. Il peut être nécessaire d’appliquer une rotation pour obtenir le résultat attendu. Les collection d’assets utilisent l’axe global -Y comme avant (au lieu de l’axe local, car les collections elles-mêmes n’ont pas de rotation).

Il est également possible de charger des fichiers image à partir du disque, pour remplacer les aperçus générés automatiquement.

Pour des aperçus des assets de pose, voir Contrôler l’apparence des images d’aperçu.

Ensembles d’assets

Les Asset Bundles sont des fichiers-blend qui ne font référence à aucun autre fichier et dont le nom se termine par _bundle.blend. Toutes les textures et autres fichiers externes doivent être compressés dans le fichier-blend actuel.

Les Asset Bundles peuvent être installés via le Asset Browser:

  • Ouvrez le fichier blend de regroupement d’assets.

  • Basculez son navigateur d’assets sur le fichier actuel (s’il n’est pas déjà défini).

  • Cliquez sur Copy Bundle to Asset Library.

  • Choisissez la bibliothèque d’assets dans laquelle le copier.

  • Un navigateur de fichiers s’ouvrira, affichant les fichiers de la bibliothèque d’assets sélectionnée. Choisissez l’emplacement souhaité du fichier-blend et cliquez sur le bouton Copy to Asset Library.

  • Le fichier-blend sera enregistré à l’emplacement choisi et tous les catalogues de l’ensemble d’assets seront fusionnés dans la bibliothèque d’aassets cible.

Note

Le mot “asset” et le mot “bundle” sont tous deux couramment utilisés, et pas nécessairement avec la même signification que celle décrite ici. Tout ce “qui est présenté comme un “asset bundle” n’aura pas la fonctionnalité “Copy to Asset Library”; pour cela, le fichier “bundle” doit adhérer à la définition ci-dessus.