Structure

Pour les maillages, tout est construit à partir de trois structures de base : vertices, edges et faces (sommets, arêtes, faces).

../../_images/modeling_meshes_structure_example.svg

Exemple de structure de maillage.

Vertices (Sommets)

La partie la plus élémentaire d’un maillage est le sommet qui est un point ou une position unique dans l’espace 3D. Les sommets sont représentés dans la Vue 3D en mode Édition sous forme de petits points. Les sommets d’un objet sont enregistrés sous forme de tableau de coordonnées.

Astuce

Ne confondez pas l’origine d’un objet avec un sommet. Il peut sembler similaire, mais il est plus grand et ne peut pas être sélectionné.

../../_images/modeling_meshes_structure_cube-example.png

Le sommet est étiqueté « A »; l’origine de l’objet est étiquetée « B ».

Edges (Arêtes)

Une arête relie toujours deux sommets par une ligne droite. Les arêtes sont les « fils » que vous voyez lorsque vous regardez un maillage en vue filaire. Ils sont généralement invisibles sur l’image rendue. Elles servent à construire des faces.

Faces

Faces are used to build the actual surface of the object. They are what you see when you render the mesh. If this area does not contain a face, it will simply be transparent or nonexistent in the rendered image.

Une face est définie par la région bordée par trois (triangles), quatre (quadrangles) ou plus de sommets (n-gons), avec une arête sur chaque côté. Les faces sont souvent abrégées en tris, quads et n-gons.

Les triangles sont toujours plats et donc faciles à calculer. En revanche, les quadrangles « se déforment bien » et sont donc préférés pour l’animation et la modélisation avec subdivision.

Normals (Normales)

En géométrie, une normale est une direction ou une ligne perpendiculaire à quelque chose, généralement un triangle ou une surface, mais peut aussi être relative à une ligne, une tangente à un point sur une courbe ou un plan tangent à un point sur une surface.

../../_images/modeling_meshes_structure_viewport.png

La visualisation des normales de faces d’un tore.

Dans la figure ci-dessus, chaque ligne bleue représente la normale à une face du tore. Les lignes sont chacune perpendiculaire à la face sur laquelle elles reposent. La visualisation peut être activée, en Mode Édition, dans le panneau Mesh Display Viewport Overlays.

Propriétés

Référence

Panneau

Properties ‣ Object Data ‣ Normals

../../_images/modeling_meshes_structure_normals-panel.png

Panneau Normals.

Auto Smooth

Les arêtes dont l’angle entre les faces est inférieur à celui spécifié dans le champ Angle seront lissées, lorsque l’ombrage de ces parties du maillage est réglé sur smooth. C’est une façon plus facile de combiner des arêtes lisses et des arêtes vives.

../../_images/modeling_meshes_structure_example-auto-smooth.png

Exemple de maillage avec Auto Smooth activé.

Notion avancée de Smooth Shading et Sharp Edges

Par défaut dans Blender, avec un comportement informatique normal de base, une arête vive est toujours définie comme une arête non multiple ou ayant au moins une de ses faces définie comme plate.

L’activation du réglage Auto Smooth ajoute un paramètre supplémentaire pour définir une arête vive, le seuil Angle entre deux faces voisines, au-dessus duquel l’arête sera toujours considérée comme vive.

Auto Smooth active également la gestion des Custom Split Normals, qui peuvent être soit définies (et éditées) comme couche de données de maillage, ou générées à la volée par des modificateurs. Dans tous les cas, quand un maillage a des normales personnalisées, elles remplacent toujours celles calculées par défaut par Auto Smooth.

Des arêtes vives peuvent toujours être utilisées par les modificateurs de normales personnalisés pour calculer leurs normales, en fonction de leurs paramètres.

Custom Split Normals

Custom Split Normals est un moyen de modifier/fausser l’ombrage en orientant les normales vers d’autres directions que celles par défaut, calculées automatiquement. Il est surtout utilisé dans le développement de jeux, où elle permet de contrebalancer certains problèmes générés par des objets à faible polarité (les exemples les plus courants sont les arbres, les buissons, l’herbe, etc. à faible polarité et les coins « arrondis »).

Blender prend en charge les normales personnalisées sur une base d’une « ventilation lisse », définie comme un ensemble de coins de faces voisines partageant le même sommet et « reliées » par des arêtes lisses. Cela signifie que vous pouvez avoir des normales pour chaque coin de face, pour chaque ensemble de coins de face voisins ou pour chaque sommet.

Activation des normales de division personnalisées

Référence

Mode

Mode Édition

Menu

Mesh ‣ Normals ‣ Split

Permet d’obtenir des normales de division personnalisées. De plus, tous les outils d’édition des normales personnalisées (voir ci-dessous) permettent, par commodité, d’activer les normales personnalisées si elles ne sont pas déjà activées.

Note

Cela a pour effet secondaire d’activer le Lissage Automatique, car cela est nécessaire pour utiliser les normales personnalisées. Une fois que vous avez des normales personnalisées, le seuil d’angle du comportement d”Auto Smooth est désactivé – toutes les arêtes non tranchantes et non marquées seront considérées comme lisses, sans tenir compte de l’angle entre leurs faces.

Édition des normales de division personnalisées

Référence

Mode

Mode Édition

Menu

Mesh ‣ Normals

Raccourci

Alt-N

Il existe un grand nombre d’outils pour éditer les normales de division personnalisées. Les outils d’édition de maillage pour les normales personnalisées affectent toutes les normales (par défaut), ou seulement celles sélectionnées. Pour sélectionner une normale personnalisée associée avec un sommet et une face particuliers :

  • Validez le mode de sélection des éléments sur Vertex ET Face (utilisez Maj-LMB pour activer le second).

  • Sélectionnez un sommet ou plus, puis sélectionnez une face. Ceci peut être répété pour sélectionner plus de points et une face différente et ainsi de suite. Il est plus facile de voir l’effet de ces outils si vous activez l’option Display vertex-per-face normals as lines dans Overlays en Mode Édition.

Voir aussi

Édition des normales.

Importer des normales de division personnalisées

Certains outils, en particulier ceux utilisés dans CAD, ont tendance à générer une géométrie irrégulière lors de la mosaïque de leurs objets en maillages (triangles très fins et longs, etc.). Les normales auto-calculées sur une telle géométrie donnent souvent de mauvais artefacts, il est donc important de pouvoir importer et utiliser les normales telles que générées par l’outil de CAO lui-même.

Note

Actuellement, seuls les FBX Importer et Alembic Importer sont capables d’importer des normales personnalisées.

Topology (Topologie)

Boucles (Loops)

../../_images/modeling_meshes_structure_edge-face-loops.png

Boucles d’arêtes et de faces.

Les boucles Edge et face sont des ensembles de faces ou d’arêtes qui forment des « boucles » continues comme le montre la figure Boucles d’arêtes et de faces..

Dans l’image ci-dessus, les boucles qui ne se terminent pas par des pôles sont cycliques (1 et 3). Elles commencent et se terminent au même sommet et divisent le modèle en deux partitions. Les boucles peuvent être un outil rapide et puissant pour travailler avec des régions spécifiques et continues d’un maillage et sont une condition préalable à l’animation organique de personnages. Pour une description détaillée de la façon de travailler avec des boucles dans Blender, voir : Edge Loop Selection.

Note

Notez que les boucles (2 et 4) ne font pas le tour de tout le modèle. Les boucles s’arrêtent à ce qu’on appelle des pôles, car il n’y a pas une façon unique de continuer une boucle à partir d’un pôle. Les pôles sont des sommets qui sont reliés à trois, cinq ou plusieurs arêtes. Par conséquent, les sommets connectés à exactement un, deux ou quatre bords ne sont pas des pôles.

Edge Loops (Boucles d’arêtes)

Les boucles (1 et 2) dans Fig. Boucles d’arêtes et de faces. sont des Edge Loops. Elles connectent des sommets de sorte que chacun d’eux sur la boucle ait exactement deux voisins qui ne sont pas sur la boucle et placés des deux côtés de la boucle (à l’exception des sommets de début et de fin dans le cas des pôles).

Les Edge Loops sont un concept important, en particulier dans la modélisation organique (subsurface) et l’animation de personnages. Lorsqu’elles sont utilisées correctement, elles vous permettent de construire des modèles avec relativement peu de sommets qui ont l’air très naturels lorsqu’ils sont utilisés comme surfaces de subdivision et se déforment très bien dans l’animation.

Prenez à titre d’exemple la Fig. Boucles d’arêtes et de faces. en modélisation organique : les boucles d’arêtes suivent les contours naturels et les lignes de déformation de la peau et des muscles sous-jacents. Les boucles sont plus denses dans les zones qui se déforment davantage lorsque le personnage bouge, par exemple au niveau des épaules ou des genoux.

Des détails supplémentaires sur le travail avec les boucles d’arêtes se trouvent dans Sélection de boucles d’arêtes.

Face Loops (Boucles de faces)

Elles sont le prolongement logique des boucles d’arêtes en ce sens qu`elles sont constituées par les faces situées entre deux boucles d’arêtes, comme le montrent les boucles (3 et 4) de la figure Boucles d’arêtes et de faces.. Notez que pour les boucles non circulaires (4), les faces contenant les pôles ne sont pas incluses dans une boucle de faces.

Des détails supplémentaires sur l’utilisation des Boucle de faces se trouvent dans Sélection de Boucle de faces.

Poles

Voir N-poles & E-poles.

Non-Manifold

Voir Non-manifold.