Mode Édition de particule

Using Particle Edit Mode you can edit the keyed points (keyframes) and paths of Baked Hair, Particle, Cloth, and Soft Body simulations. (You can also edit and style hair before baking).

Since working in Particle Edit Mode is pretty easy and very similar to working with vertices in the 3D View, we will show how to set up a particle system and then give a reference of the various functions.

Utilisation

Astuce

Seules les trames précalculées en mémoire sont éditables !

Si vous ne pouvez pas éditer les particules, vérifiez que vous n’êtes pas en train de précalculer dans un Cache de disque.

Configuration pour les particules Hair

  1. Créez un système de particules Hair.
  2. Donnez-lui une vitesse initiale dans la direction Normal.
  3. Créez une simulation.
  4. Cochez la case Hair Dynamics
../../_images/physics_particles_mode_example.png

Édition de mèches de cheveux en Mode Édition de particule.

Configuration pour les simulations de Particle, Cloth, et Soft Body

  1. Utilisez les particules Emitter, ou une simulation cloth/soft-body.
  2. Créez une simulation en configurant les objets et/ou les émetteurs, définissez votre intervalle de temps (utilisez un petit intervalle si vous débutez et vous expérimentez), configurez la simulation selon vos désirs, en utilisant Alt-A pour la prévisualiser.

Précalcul de la simulation

Une fois que vous êtes satisfait de la simulation générale, précalculez la simulation depuis le Mode Objet. La simulation doit être précalculée pour activer l’édition.

Édition de la simulation

Passez à Particle Edit depuis le Menu Mode select dans l’entête de la Vue 3D pour éditer les chemins/trames clés de la particule. Vous aurez peut-être besoin de presser T depuis la Vue 3D pour voir le panneau Particle Edit. Déplacez-vous dans la trame que vous voulez éditer et utilisez les divers outils de Particle Edit pour éditer votre simulation. Travaillez lentement, en prévisualisant vos modifications avec Alt-A, et sauvegardez souvent de manière à ce que vous puissiez revenir sur la version précédente si quelque chose se produit, ou que vous n’aimez pas les toutes dernières modifications que vous avez faites.

Astuce

Pour être capable de voir clairement votre travail en cours :

  1. Ouvrez le panneau Options dans le Tool Shelf.
  2. Sélectionnez Point select mode (voir ci-dessous) dans l’entête de la Vue 3D. Ceci va afficher les points clés sur le chemin des particules.

Sélection

  • Single: RMB.
  • All: A.
  • Linked: Move the mouse over a keypoint and press L.
  • Border select: B.
  • First/last: Specials ‣ Select First / Select Last.

Vous pouvez aussi utiliser le Menu Select.

Astuce

Sélections

Les sélections sont extrêmement utiles pour modifier les seules particules que vous désirez. Passez au dessus d’un chemin de particules et pressez L pour le lier-sélectionner, passez au dessus du suivant et pressez L pour ajouter ce chemin à la sélection. Pour supprimer un chemin, tenez Maj et pressez L. Pour déselectionner tout (Deselect All) pressez A.

La méthode pour sélectionner des poins individuels est la même qu’en Mode Édition. RMB pour sélectionner, Maj-RMB pour ajouter/supprimer un point de la sélection.

Select Random

Sélectionne aléatoirement des particules.

Percent
Pourcentage de particules à sélectionner aléatoirement.
Random Seed
Valeur de graine (seed) à utiliser pour la sélection.
Action
Sélectionner au hasard peut être utilisé pour sélectionner ou désélectionner des particules.
Type
Selects either hair or points. Here these terms can be confusing because hair/point does not refer to the particle type but the path/points of the hair/particle.

Modes de sélection

../../_images/physics_particles_mode_select-modes.png

Modes de sélection.

Path
Aucun point clé n’est visible, vous ne pouvez que sélectionner/désélectionner toutes les particules.
Point
Vous voyez toutes les points clés.
Tip
Vous pouvez seulement voir et éditer (y compris les brosses) l’extrêmité des particules, càd. le dernier point clé.

Brush

Référence

Mode:Mode Édition de particule
Panneau:Tool Shelf ‣ Tools ‣ Brush

Avec les boutons vous pouvez sélectionner le type de l’utilitaire « Comb » que vous voulez utiliser.

None
Pas d’outil spécial, éditez simplement les points clés comme des sommets « normaux ».
Comb
Déplace les points clés (semblable à « proportional editing »).
Smooth
Segments adjacents visuellement parallèles.
Add

Ajoute de nouvelles particules.

Count
Le nombre de nouvelles particules par étape.
Interpolate
Interpoler la forme des nouveaux poils à partir des poils existants.
Steps
Nombre de pas de brosse.
Keys
le nombre de clés pour faire de nouvelles particules.
Length
met à l’échelle les segments, ainsi il rend les poils plus longs avec Grow or plus court avec Shrink.
Puff

Rotates the hair around its first keypoint (root). So it makes the hair stand up with Add or lay down with Sub.

Puff Volume
Apply puff to unselected end points, (helps maintain hair volume when puffing root).
Cut
Met à l’échelle les segments jusqu’à ce que le dernier point clé atteint la brosse.
Weight
This is especially useful for soft body animations, because the weight defines the soft body Goal. A keypoint with a weight of 1 will not move at all, a keypoint with a weight of 0 subjects fully to soft body animation. This value is scaled by the GMin to GMax range of soft body goals…

Options communes

Au dessous des types de brosses, leur réglage apparaît :

Radius F
Fixer la rayon de la brosse.
Strength Shift-F
Fixe la puissance de l’effet broaas (pas pour Add brush).
Add/Sub Grow/Shrink
Définit la brosse à laquelle ajouter l’effet ou l’inverser.

Options

Référence

Mode:Mode Édition de particule
Panneau:Tool Shelf ‣ Tools ‣ Options
Deflect Emitter

Particules cheveux uniquement – ne pas déplacer les points clés à travers les maillage émetteur.

Distance
The distance to keep from the Emitter.
Keep
Length
Conserve la longueur des segments entre les points clés lors du peignage ou du lisage des cheveux. C’est fait en déplaçant tous les autres points clés.
Root
Conserve la première clé inchangée, ainsi vous ne pouvez transplanter des cheveux.
Correct
Velocity
Recalculer la vitesse des particules selon leur chemin édité. Autrement, les valeurs de vitesse initiale restent inchangées indépendamment de la distance réellement parcourue par les particules.
X Mirror
Activer l’édition mirror à travers l’axe X local.
Shape Object

A mesh object which boundary is used by the Shape Cut tool.

Shape Cut
This grooming tool trims hairs to a shape defined by the Shape Object. This is a quicker way of avoiding protruding hair sections from lengthening than using the Cutting tool. It works especially well for characters with extensive fur, where working in a single plane with the Cutting tool becomes tedious.
Exemple de Shape Cut.
../../_images/physics_particles_mode_shapecut-before.png

Avant.

../../_images/physics_particles_mode_shapecut-after.png

Après.

Draw

Path Steps
Drawing steps, sets the smoothness of the drawn path.
Particles
Trace les particules actuelles sur les chemins.
Fade Time

Estomper les chemins et les clés loin du temps courant.

Frames
Le nombre de trames à estomper.
Show Children
Trace aussi les enfants des particules. Ceci permet d’ajuster finement les particules et voir leurs effets sur le résultat, mais cela peut ralentir votre système si vous avez beaucoup d’enfants.

Édition

Avertissement

Méfiez-vous de Undo !

L’utilisation de Undo en Mode Particle Edit peut avoir des résultats étranges. Rappelez-vous de sauvegarder souvent !

Déplacement de points clés ou de particules

  • Puour déplacer les points clés sélectionnés, pressez G, ou utilisez une des diverses autres méthodes pour saisir des sommets.
  • Pour déplacer la racine d’une particule, vous devez éteindre G, ou tourner Keep Root dans le Tool Shelf.
  • Vus pouvez faire beaucoup des choses comme avec des sommets, y compris la mise à l’échelle, la rotation et la suppression (particules complètes ou clés simples).
  • Vous ne pouvez dupliquer ou extruder les clés ou les particules, mais vous pouvez subdiviser des particules, ce qui ajoute des points clés Specials ‣ Subdivide ou Pavnum2.
  • Alternatively you can rekey a particle Specials ‣ Rekey or Numpad1 and choose the number of keys.

How smoothly the hair and particle paths are displayed depends on the Path Steps setting in the Tool Shelf. Low settings produce blocky interpolation between points, while high settings produce a smooth curve.

Mirror

Référence

Mode:Mode Édition de particule
Menu:Particle ‣ Mirror

Si vous voulez créer une coupe de cheveux symétrique par rapport à l’axe X, vous devez suivre les étapes suivantes :

  1. Sélectionner toutes les particules avec A
  2. Créer les particules en miroir avec Ctrl-M, ou utiliser le menu Particle ‣ Mirror.
  3. Activer X Mirror dans le panneau **Brush.

It may happen that after mirroring two particles occupy nearly the same place. Since this would be a waste of memory and render time, you can Remove doubles either from the Specials W or the Particle menu.

Longueur d’unité

Référence

Mode:Mode Édition de particule
Menu:Particle ‣ Unify Length, Specials ‣ Unify Length

Cet outil est utilisé pour rendre tous les cheveux sélectionnés uniformes en trouvant la longueur moyenne.

Show/Hide

Référence

Mode:Mode Édition de particule
Menu:Particle ‣ Show/Hide

Le fait de cacher et de révéler des particules fonctionne de la même manière qu’avec les sommets dans la Vue 3D. Sélectionnez un ou plusieurs points clés de la particule que vous voulez cacher et pressez H. La particule ne s’évanouit pas en fait, seulement les points clés.

Les particules cachées (càd. les particules dont les points clés sont cachés) ne réagissent pas sur les diverses brosses. Mais :

Si vous utilisez Mirror Editing même les particules avec des points clés cachés peuvent être déplacées, si leur partenaire en miroir est déplacé.

Pour révéler toutes les particules cachées, pressez Alt-H.