Motion Paths

Référence

Éditeur

3D View, Properties editor

Mode

Mode Objet

Panneau

Tool Shelf ‣ Animation ‣ Animation ‣ Motion Paths: Calculate

Panneau

Properties editor ‣ Object ‣ Motion Paths

Référence

Éditeur

3D View, Properties editor

Mode

Mode Pose

Panneau

Tool Shelf ‣ Tools ‣ Pose Tools ‣ Motion Paths: Calculate

Panneau

Properties editor ‣ Armature ‣ Motion Paths

Menu

Pose ‣ Motion Paths

../_images/animation_motion-paths_example-object.png

Un cube animé avec son motion path affiché.

L’outil Motion Paths vous permet de visualiser les mouvements de points comme des chemins sur une série de trames. Ces points peuvent être des origines d’objets ou des articulations d’os.

Avant que nous examinions ses options, voyons d’abord comment afficher/cacher ces chemins. À la différence de Ghost, vos devez le faire manuellement et vous devez d’abord sélectionner les os dont vous voulez afficher/cacher les motion paths. Puis :

  1. Pour afficher les chemins (ou les mettre à jour, si nécessaire), cliquez sur le bouton Calculate Path.

  2. Pour cacher les chemins, cliquez sur le bouton Clear Paths.

Note

Rappelez-vous que seuls les os sélectionnés et leur chemin sont affectés par ces actions !

Les chemins sont tracés dans une nuance de gris clair pour les points non sélectionnés, et dans un gris bleu pour ceux sélectionnés. Autour de la trame courante un éclat indique la direction du mouvement : bleu vers les trames futures et vert vers le passé. Chaque trame est représentée par un petit point blanc sur les chemins.

Comme avec les ghosts, les chemins sont automatiquement mis à jour quand vous éditez vos poses/trames clés, et ils sont aussi actifs durant la diffusion de l’animation. Alt-A est seulement utile quand l’option Around Current Frame est activée.

Options

../_images/animation_motion-paths_panel.png

Le panneau Motion Paths dans l’onglet Armature.

Type
Around Frame

Afficher les chemins de points dans un nombre fixé de trames autour de la trame courante. Quand vous activez ce bouton, vous obtenez les chemins pour un nombre donné de trames avant et après celle courante (de nouveau, comme avec les ghosts).

In Range

Affiche les chemins de points dans un intervalle spécifié.

Display Range
Before, After

Nombre de trames à afficher avant et après la trame courante (seulement pour la méthode Onion-skinning Around Current Frame).

Start, End

Les trames de début et de fin d’une série de chemins pour afficher/calculer (pas pour Around Current Frame de la méthode Onion-skinning).

Step

C’est le même paramètre que Step pour les fantômes. Il vous permet d’afficher seulement sur le chemin une trame par série de n trames. Principalement utile quand vous activez l’affichage du numéro de trame (voir ci-dessous), pour éviter d’encombrer les Vues 3D.

Cache/Cache for Bone
From, To

Ce sont les trames de début/fin de la série dans laquelle les motion paths sont dessinés. Vous ne pouvez pas modifier cette série sans supprimer d’abord le motion path.

Calculate/Update Paths

Si aucun chemin n’a été calculé, Calculate Paths va créer un nouveau motion path en cache en se basant sur les options spécifiées dans le menu déroulant ou le panneau Operator.

Si un chemin a été déjà calculé, Update Paths va mettre à jour la forme du chemin de l’animation courante. Pour modifier la série de trames du chemin calculé, vous devez supprimer le chemin et le recalculer.

Start, End

Ce sont les trames de début/fin de la série dans laquelle les motion paths sont dessinés. Vous devez appuyer de nouveau sur Calculate Paths si vous modifiez ce réglage, pour mettre à jour les chemins dans les Vues 3D. Notez que contrairement aux ghosts, la trame de début est incluse (càd si vous fixez Start à 1, vous allez réellement voir la trame 1 comme point de départ des chemins…).

Bake Location

Os seulement – par défaut, vous obtenez les chemins des pointes. En modofoant ce réglage à Tails, vous obtiendrez les chemins des racines de l’os (rappelez-vous que dans l’Ui de Blender, les racines d’os sont appelées « têtes »…). Vous devez à nouveau presser sur Calculate Paths si vous modifiez ce réglage, pour mettre à jour les chemins dans les Vues 3D.

Clear Paths X

Élimine les chemins de tous les objets/os, ou seulement ceux qui sont sélectionnés si Maj est enfoncé.

Show

Numéros de trame

Si l’option est activée, un petit numéro apparaît à côté de chaque point/trame sur le chemin, qui est bien entendu le numéro de la trame correspondante.

Line

Toggles whether the lines between the points are drawn.

Thickness, Color (color wheel icon)

Épaisseur et couleur personnalisées pour les lignes.

Trames clés

Si l’option est activée, de gros points jaunes carrés sont tracés sur les motion paths, montrant les trames clés de leurs os (càd que seuls les chemins des os ayant des trames clés à une trame donnée reçoivent un point jaune à cette trame).

+ Non-Grouped Keyframes

For bone motion paths, it searches the whole Action for keyframes instead of in groups with matching name only (this is slower).

Numéros de trame clé

Si l’option est activée, vous verrez les numéros des trames clés affichées, aussi il est évident que cette option est uniquement valide quand l’option Show Keys est activée.

Exemple

../_images/animation_motion-paths_example-armature.png

Un exemple de motion path d’une armature.