Viewport Render – Рендер Оглядвікна

Рендеринг оглядвікна використовує рендеринг оглядвікна 3D Viewport для швидких рендерів передогляду.

Це дозволяє вам перевіряти ваш аніматик – animatic (на відповідність переміщення об’єктів, зміни кутів тощо).

Це можна також використовувати для передогляду ваших анімацій – коли ваша сцена є надто складною для вашої системи для програвання в режимі реального часу в оглядвікні 3D Viewport.

Ви можете використовувати Viewport Render для рендера як зображень, так і анімацій.

Нижче є порівняння між рендером оглядвікна Viewport render та фінальним рендером, використовуючи рендерер Cycles Renderer.

Модель від © 2016 pokedstudio.com
../../_images/editors_3dview_viewport-render_example-workbench-render.jpg

Рендер оглядвікна з використанням режиму суцільного відтінення Solid Mode.

../../_images/editors_3dview_viewport-render_example-eevee-render.jpg

Рендер оглядвікна з використанням режиму передогляду матеріалу Material Preview Mode.

../../_images/editors_3dview_viewport-render_example-cycles-render.jpg

Full Render – Рендер Повністю.

Порада

Вимикання накладів для рендера оглядвікна без будь-яких додаткових накладів.

Хоча цей варіант не є специфічним для рендерингу Оглядвікна, він часто корисний для вмикання, оскільки вилучає такі дані, як оснастки та порожняки, що можуть відволікати.

Settings – Устави

Здебільшого, Viewport Render використовує устави поточного оглядвікна. Деякі устави розміщені в панелі рендера рушія рендера, який використовується для рендерення огляду.

Режим суцільно Solid використовує устави рендера для Workbench; режим передогляду матеріалу Material Preview використовує устави рендера для Eevee.

Опції відбору Sampling та режиму прозорості альфа Alpha Transparency Mode можуть установлюватися в Properties ‣ Render ‣ Sampling – «Властивості > Рендер > Відбір». Переконайтеся, що вибрано відповідний рушій рендера, Workbench або Eevee, щоб бачити відповідні значення.

Додатково, використовуються також деякі устави рендера:

  • Render Dimensions – Розмірності Рендера

  • Render Aspect – Аспект Рендера

  • File Format – Формат Файлу та Output – Вивід (шлях до файлу, формат, устави стиснення тощо)

Rendering – Рендеринг

Активування Viewport Render буде рендерити з поточного активного огляду. Це означає, що якщо ви не знаходитеся в активному огляді камери, то буде використовуватися віртуальна камера, що відповідає поточній перспективі. Для отримання зображення з точки огляду камери увійдіть в активний огляд камери за допомогою Numpad0.

Як і для звичайного рендера, ви можете переривати його за допомогою Esc.

Render a Still Image – Рендер Статичного Зображення

Для рендерення статичного зображення використовуйте 3D Viewport ‣ View ‣ Viewport Render Image — «3D Оглядвікно > Огляд > Рендер Оглядвікна Зображення».

Render an Animation – Рендер Анімації

To render an animation, use 3D Viewport ‣ View ‣ Viewport Render Animation.

Render Keyframes – Рендер Ключкадрів

Для рендерення анімації, але лише тих кадрів, що мають ключкадр, використовуйте 3D Viewport ‣ View ‣ Viewport Render Keyframes – «3D Оглядвікно > Огляд > Рендер Оглядвікна Ключкадри». Це рендерить лише ті кадри, для яких вибрані об’єкти мають ключ анімації. Інші кадри все ще записуються у вивід, але будуть просто повторювати останньо рендерений кадр.

Наприклад, коли рендериться шестикадрова анімація, а вибрані об’єкти мають ключ на кадрах 3 та 5, то виводитися будуть наступні кадри:

  1. 1-й кадр завжди рендериться.

  2. Повторюється 1-й кадр, оскільки на цьому кадрі немає ключа.

  3. 3-й кадр рендериться.

  4. Повторюється 3-й кадр, оскільки на цьому кадрі немає ключа.

  5. 5-й кадр рендериться.

  6. Повторюється 5-й кадр, оскільки на цьому кадрі немає ключа.

Порада

Ви можете лімітувати рендер оглядвікна певним регіоном за допомогою регіону рендера – Render Regions.