glTF 2.0

Reference – Довідка

Category – Категорія

Import-Export – Імпорт-Експорт

Menu – Меню

File ‣ Import/Export ‣ glTF 2.0 (.glb, .gltf) – «Файл > Імпорт/Експорт > glTF 2.0 (.glb, .gltf)»

Usage – Використання

glTF™ (GL Transmission Format) використовується для передачі та завантажування 3D моделей у веб та нативні застосунки. glTF зменшує розмір 3D моделей та обробку під час виконання, необхідні для розпакування та рендерення цих моделей. Цей формат поширено використовується у веб та має підтримку в різних 3D рушіях, таких як Unity3D, Unreal Engine 4 та Godot.

Цей імпортер/експортер підтримує наступні функції glTF 2.0:

  • Meshes – Сіті

  • Materials (Principled BSDF) – Матеріали та Shadeless (Unlit) – Безвідтінковість

  • Textures – Текстури

  • Cameras – Камери

  • Punctual lights – Пунктуальні освітлювачі (точковий – point, прожектор – spot та направлений – directional)

  • Extensions – Розширення (перелічені нижче)

  • Extras – Добавки (кастомні властивості)

  • Animation – Анімація (ключкадр – keyframe, ключ форми – shape key та покривання – skinning)

Meshes – Сіті

glTF внутрішня структура імітує буфери пам’яті, що поширено використовуються графічними чіпами при рендерингу в режимі реального часу, таким чином, що активи можуть подаватися на стільницю, веб або мобільних клієнтів, та негайно показуватися з мінімальною обробкою. Як результат, чотирибічники та n-кутники автоматично конвертуються у трикутники при експортуванні в glTF. Переривчасті UVи та плоско відтінені краї можуть призводити до помірно високих рахунків вершин у glTF у порівнянні з Blender, оскільки такі вершини відокремлюються для експорту. Так само, дані кривих та інших не-сітей не зберігаються, і повинні конвертуватися в сіті перед експортом.

Materials – Матеріали

Ядро системи матеріалів у glTF підтримує робпотік типу металічність/шорсткість фізично базованого рендерингу – PBR з наступними каналами інформації:

  • Base Color – Базовий Колір

  • Metallic – Металік

  • Roughness – Шорсткість

  • Baked Ambient Occlusion – Запечена Загорода Оточення

  • Normal Map – Розкладка Нормалей (простір тангенса, +Y уверх)

  • Emissive – Емісійне

Some additional material properties or types of materials can be expressed using glTF extensions. The complete is can be found in _Extensions_ part of this documentation.

../../_images/addons_import-export_scene-gltf2_material-channels.jpg

Приклад різних розкладок зображення, доступних в основному форматі glTF 2.0. Це модель зразка пляшки з водою – water bottle sample model, показана поруч з краяннями її різних розкладок зображень.

Imported Materials – Імпортовані Матеріали

Система матеріалів glTF відрізняється від власних матеріалів Blender’а. Коли файл glTF імпортується, то додаток створить набір вузлів Blender для відтворення кожного матеріалу glTF так точно, наскільки це можливо.

The importer supports Metal/Rough PBR (core glTF), Spec/Gloss PBR (KHR_materials_pbrSpecularGlossiness) and some extension materials. The complete is can be found in _Extensions_ part of this documentation.

Порада

Досліджування результату процесу імпорту матеріалу є хорошим способом побачити приклади типів вузлів матеріалів та устав, що можуть бути експортовані у glTF.

Exported Materials – Експортовані Матеріали

Експортер підтримує Metal/Rough PBR – Металічність/Шорсткість ФБР (core glTF) та Shadeless – Безвідтінкові (KHR_materials_unlit) матеріали. Він буде створювати матеріал glTF на основі вузлів, які він розпізнає в матеріалі Blender. Процес експорту матеріалів обробляє устави, описані нижче.

Примітка

Коли текстури зображень використовуються матеріалами, glTF вимагає, щоб зображення були у форматі PNG або JPEG. Додаток автоматично конвертує зображення з інших форматів, збільшуючи час експорту.

Base Color – Базовий Колір

Базовий колір glTF визначається шляхом шукання уводу Base Color на вузлі Principled BSDF. Якщо цей увід нез’єднаний ні з чим, то стандартний колір уводу (поле кольору поруч з нез’єднаним сокетом) використовується як Base Color для матеріалу glTF.

../../_images/addons_import-export_scene-gltf2_material-base-color-solid-green.png

Суцільний базовий колір може визначатися безпосередньо на вузлі.

Якщо вузол Image Texture – Текстура Зображення виявлено під’єднаним до уводу Base Color – Базовий Колір, то це зображення буде вжите як базовий колір glTF.

../../_images/addons_import-export_scene-gltf2_material-base-color-image-hookup.png

Зображення використовується як базовий колір glTF.

Metallic and Roughness – Металік та Шорсткість

Ці значення зчитуються з вузла Principled BSDF. Якщо обидва ці уводи нез’єднані ні з чим, то вузол покаже повзунки для керування їх відповідними значеннями між 0.0 та 1.0, і ці значення будуть скопійовані в glTF.

При використанні зображення, glTF очікує, що значення металічності закодовані у синьому (B) каналі, а шорсткість закодована у зеленому (G) каналі того самого зображення. Якщо зображення з’єднуються з вузлом Blender способом, що не дотримується цієї умовності, то додаток може спробувати пристосувати зображення до коректної форми під час експортування (зі збільшенням часу експорту).

У дереві вузлів Blender рекомендується використовувати вузол Separate RGB – Відокремлення RGB для відокремлення каналів від вузла Image Texture – Текстура Зображення та з’єднати зелений (G) канал зі шорсткістю Roughness, а синій (B) з металік Metallic. Експортер glTF розпізнає цю розставу як відповідність стандарту glTF, і це дозволить йому просто скопіювати текстуру зображення у файл glTF під час експорту.

Для цього Вузол Image Texture – Текстура Зображення повинен мати уставу Color Space – Колірний Простір, установлену як Non-Color – Не-Колір.

../../_images/addons_import-export_scene-gltf2_material-metal-rough.png

Зображення металічності/шорсткості, під’єднане способом, узгодженим зі стандартом glTF, дозволяє йому використовуватися дослівно всередині експортованого файлу glTF.

Baked Ambient Occlusion – Запечена Загорода Оточення

glTF is capable of storing a baked ambient occlusion map. Currently there is no arrangement of nodes that causes Blender to use such a map in exactly the same way as intended in glTF. However, if the exporter finds a custom node group by the name of glTF Material Output, and finds an input named Occlusion on that node group, it will look for an Image Texture attached there to use as the occlusion map in glTF. The effect need not be shown in Blender, as Blender has other ways of showing ambient occlusion, but this method will allow the exporter to write an occlusion image to the glTF. This can be useful to real-time glTF viewers, particularly on platforms where there may not be spare power for computing such things at render time.

../../_images/addons_import-export_scene-gltf2_material-occlusion-only.png

Попередньо запечена розкладка загороди оточення, під’єднана до вузла, що не рендериться, але буде експортуватися у glTF.

Порада

Найлегший спосіб створити кастомну групу вузлів – це імпортувати наявну модель glTF, що містить розкладку загороди, наприклад, пляшку для води – water bottle або інша наявна модель. Вручну створена кастомна група вузлів може також бути використана.

glTF зберігає загороду у каналі червоного (R), дозволяючи факультативно співволодіти тим самим зображенням каналам шорсткості та металічності.

../../_images/addons_import-export_scene-gltf2_material-orm-hookup.png

Ця комбінація вузлів імітує спосіб, яким glTF пакує значення загороди, шорсткості та металічності в єдине зображення.

Порада

The Cycles render engine has a Bake panel that can be used to bake ambient occlusion maps. The resulting image can be saved and connected directly to the glTF Material Output node.

Normal Map – Розкладка Нормалей

Для використання розкладки нормалей у glTF, під’єднайте вивід кольору вузла Image Texture з уводом кольору вузла Normal Map, і потім під’єднайте вивід нормалі цього вузла Normal Map до уводу нормалі вузла Principled BSDF. Вузол Image Texture для цього повинен мати його властивість Color Space установленою як Non-Color.

Вузол Normal Map повинен залишатися з його стандартною властивістю простору тангенса Tangent Space, оскільки це єдиний тип розкладки нормалей, підтримуваний glTF. Сила розкладки нормалей може наладнуватися на цьому вузлі. Експортер не експортує ці вузли безпосередньо, але буде використовувати їх для виявлення коректного зображення та буде копіювати уставу сили в glTF.

../../_images/addons_import-export_scene-gltf2_material-normal.png

Зображення розкладки нормалей під’єднується таким чином, що експортер виявить його та скопіює у файл glTF.

Порада

Рушій рендера Cycles має панель запікання Bake, що може використовуватися для запікання розкладок нормалей з простором тангенса з майже будь-якої розстави вузлів з векторами нормалей. Перемкніть тип запікання Bake на Normal. Зберігайте стандартні устави простору (space: Tangent, R: +X, G: +Y, B: +Z) при використанні цієї панелі запікання для glTF. Результатне запечене зображення можна зберегти та під’єднати до нового матеріалу за допомогою вузла Normal Map, як описано вище, дозволяючи йому експортуватися коректно.

Дивіться: Cycles Render Baking

Emissive – Емісійне

Вузол Image Texture може бути з’єднаним з уводом емісії Emission на вузлі Principled BSDF для включення емісійної розкладки з матеріалом glTF. Альтернативно, вузол Image Texture може бути з’єднаним з вузлом шейдерів Emission, і факультативно скомбінований з властивостями з вузла Principled BSDF за допомогою вузла Add Shader.

Якщо емісійна розкладка в матеріалі одна, то найкраще встановити базовий колір Base Color стандартно як чорний, а шорсткість Roughness стандартно як 1.0. Це мінімізує вплив інших каналів, якщо вони не потрібні.

../../_images/addons_import-export_scene-gltf2_material-emissive.png

Ця розстава підтримується для зворотної сумісності. Простіше використовувати вузол Principled BSDF безпосередньо.

If any component of emissiveFactor is > 1.0, KHR_materials_emissive_strength extension will be used.

Полакованість – Clearcoat

Коли увід Clearcoat на вузлі Principled BSDF має ненульове стандартне значення або під’єднаний до нього вузол Image Texture, то розширення KHR_materials_clearcoat для glTF буде включено в експорт. Це розширення буде також включати значення або Image Texture з уводу Clearcoat Roughness, якщо доступно.

Якщо використовуються вузли Image Texture, то glTF вимагає, щоб значення полакованості були записані у червоному (R) каналі, а шорсткості полакованості Clearcoat Roughness – у зеленому (G) каналі. Якщо монохромні зображення під’єднані, то експортер перерозкладе їх на ці колірні канали.

Увід нормалі полакованості Clearcoat Normal приймає ті самі види, як базовий увід нормалі Normal, зокрема, розкладку нормалей з простором тангенса з +Y уверх, а також користувачем визначену силу. Цей увід може повторно використовувати ту ж розкладку нормалей, яку використовує базовий матеріал, або для нього може призначена своя розкладка нормалей, або він може залишитися ні з чим нез’єднаним для згладженого покриття.

Усі вузли Image Texture, що використовуються для полакованого відтінювання, повинні мати їх колірний простір Color Space установлений, як не-колір Non-Color.

../../_images/addons_import-export_scene-gltf2_material-clearcoat.png

Приклад складного застосування полакованості, що буде експортуватися коректно в glTF. Набагато простіше, гладке покриття може бути застосоване просто із самого вузла Principled BSDF.

Блиск – Sheen

When the Velvet BSDF node is used in addition to Principled BSDF node, the KHR_materials_sheen glTF extension will be included in the export. The Sheen Color will be exported from Color socket of Vevlet node. Sheen Roughness will be exported from Sigma socket.

If a Sheen Rougness Texture is used, glTF requires the values be written to the alpha (A) channel.

../../_images/addons_import-export_scene-gltf2_material-sheen.png

Порада

Velvet BSDF node is only available on Cycles render engine. You may have to temporary switch to Cycles to add this node, and get back to Eevee.

Примітка

Because the node tree is adding 2 Shaders (Principled and Sheen), the resulting shader is not fully energy conservative. You may find some difference between Blender render, and glTF render. Sheen models are not fully compatible between Blender and glTF. This trick about adding Velvet Shader is the most accurate approximation (better that using Sheen Principled sockets).

Блік – Specular

When the Specular or Specular Tint input of Principled BSDF node have a non default value or Image Texture node connected, the KHR_materials_specular glTF extension will be included in the export.

Примітка

Specular models are not fully compatible between Blender and glTF. By default, Blender data are converted to glTF at export, with a possible loss of information. Some conversion are also performed at import, will a possible loss of information too.

At import, a custom node group is created, to store original Specular data, not converted.

../../_images/addons_import-export_scene-gltf2_material_specular-custom-node.png

At export, by default, Specular data are converted from Principled BSDF node.

You can export original Specular data, enabling the option at export. If enabled, Principled Specular data are ignored, only data from custom node are used.

../../_images/addons_import-export_scene-gltf2_material_specular-export-option.png

Порада

If you enable Shader Editor Add-ons in preferences, you will be able to add this custom node group from Menu: Add > Output > glTF Material Output

Transmission – Пропускання

Коли увід пропускання Transmission на вузлі Principled BSDF має ненульове стандартне значення або до нього під’єднаний вузол Image Texture, то розширення KHR_materials_transmission для glTF буде включене в експорт. Коли використовується текстура, то glTF зберігає значення у червоному (R) каналі. Колірний простір Color Space повинен бути установлений як не-колір Non-Color.

Пропускання відрізняється від змішування альфа, оскільки пропускання дозволяє повно-сильні блікові відбиття. У glTF, змішування альфа призначене для представлення фізичних матеріалів, що частково відсутні у визначеній геометрії, такій як медична марлева пов’язка. Пропускання призначене для представлення фізичних матеріалів, що твердотілими, але дозволяють не бліково відбитому світлу пропускатися через матеріал, як скло.

glTF не пропонує окремо шорсткості пропускання «Transmission Roughness», але базова шорсткість матеріалу може використовуватися для розмиття пропускання, як матове скло.

Порада

Типово режим змішання альфа пропускального матеріалу повинен залишатися безпрозорим «Opaque», стандартна устава, допоки цей матеріал не лише частково покриває визначену геометрію.

Примітка

У рушіях з режимом реального часу, де підтримується пропускання, різні технічні обмеження в рушії можуть визначати, які частини сцени є видимі через пропускальну поверхню. Зокрема, пропускальні матеріали можуть не бути видимими позаду інших пропускальних матеріалів. Ці обмеження впливають на фізичного-базоване пропускання, але не на не-пропускальні зі змішанням альфа матеріали.

Попередження

Пропускання є складним для імплементування для рушіїв рендерингу в режимі реального часу, і підтримка для розширення KHR_materials_transmission для glTF не є ще розповсюдженою.

IOR – Показник Заломлення

At import, there are two different situation:

  • if KHR_materials_ior is not set, IOR value of Principled BSDF node is set to 1.5, that is the glTF default value of IOR.

  • If set, the KHR_materials_ior is used to set the IOR value of Principled BSDF.

At export, IOR is included in the export only if one of these extensions are also used:

  • KHR_materials_transmission

  • KHR_materials_volume

  • KHR_materials_specular

IOR of 1.5 are not included in the export, because this is the default glTF IOR value.

Volume – Об’єм

Volume can be exported using a Volume Absorption node, linked to Volume socket of Output node. Data will be exported using the KHR_materials_volume extension.

  • For volume to be exported, some transmission must be set on Principled BSDF node.

  • Color of Volume Absorption node is used as glTF attenuation color. No texture is allowed for this property.

  • Density of Volume Absorption node is used as inverse of glTF attenuation distance.

  • Thickess can be plugged into the Thickess socket of custom group node glTF Material Output.

  • If a texture is used for thickness, it must be plugged on (G) Green channel of the image.

../../_images/addons_import-export_scene-gltf2_material-volume.png

glTF Variants

Примітка

For a full Variants experience, you have to enable UI in Add-on preferences

There are two location to manage glTF Variants in Blender

  • In 3D View, on glTF Variants tab

  • For advanced settings, in Mesh Material Properties (see Advanced glTF Variant checks)

The main concept to understand for using Variants, is that each material slot will be used as equivalent of a glTF primitive.

glTF Variants switching

After importing a glTF file including KHR_materials_variants extension, all variants can be displayed.

../../_images/addons_import-export_scene-gltf2_material_variants-switch.png

You can switch Variant, by selecting the variant you want to display, then clicking on Display Variant.

You can switch to default materials (when no Variant are used), by clicking on Reset to default.

glTF Variants creation

You can add a new Variant by clicking the + at right of the Variant list. Then you can change the name by double-clicking.

After changing Materials in Material Slots, you can assign current materials to the active Variant using Assign to Variant.

You can also set default materials using Assign as Original. These materials will be exported as default material in glTF. This are materials that will be displayed by any viewer that don’t manage KHR_materials_variants extension.

Advanced glTF Variant checks

If you want to check primitive by primitive, what are Variants used, you can go to Mesh Material Properties.

../../_images/addons_import-export_scene-gltf2_material_variants-detail.png

The glTF Material Variants tab refers to the active material Slot and Material used by this slot. You can see every Variants that are using this material for the given Slot/Primitive.

You can also assign material to Variants from this tab, but recommandation is to perform it from 3D View tab.

Double-Sided / Backface Culling – Двостороннє / Відкидання Тилу

Для матеріалів, де лише передні грані будуть видимі, вмикайте відкидання тилу Backface Culling на панелі устав Settings матеріалу для Eevee. При використанні інших рушіїв (Cycles, Workbench) ви можете тимчасово перемикатися на Eevee для конфігурування цієї устави, а потім перемикатися назад.

Залишайте цей стяг не увімкненим для двосторонніх матеріалів.

../../_images/addons_import-export_scene-gltf2_material-backface-culling.png

Інверсія цієї устави керується стягом DoubleSided для glTF.

Blend Modes – Режими Змішання

Увід базового кольору Base Color може факультативно подавати значення альфа. Те, як ці значення обробляються glTF, залежить від вибраного режиму змішання.

Коли вибрано рушій рендера Eevee, то кожен матеріал має режим змішання Blend Mode на панелі устав матеріалів. Використовуйте цю уставу для визначення того, як значення альфа з каналу базового кольору Base Color обробляються в glTF. Три устави підтримуються glTF:

Opaque – Безпрозоре

Значення альфа ігноруються.

Alpha Blend – Змішання Альфа

Нижчі значення альфа спричиняють змішування з об’єктами фону.

Alpha Clip – Відсік Альфа

Значення альфа нижче устави Clip Threshold – «Поріг Відсіку» будуть призводити до того, що частини матеріалу не будуть рендеритися взагалі. Все інше рендериться як безпрозоре.

../../_images/addons_import-export_scene-gltf2_material-alpha-blend.png

При обраному рушії Eevee режими змішання матеріалу можна конфігурувати.

Примітка

Майте на увазі, що прозорість (або режим Alpha Blend mode) є складним для рендерення рушіями в режимі реального часу і може поводитися неочікувано після експорту. Де це можливо, використовуйте натомість режим Alpha Clip або поміщайте полігони з Opaque позаду лише одного шару полігонів з Alpha Blend.

UV Mapping – Розкладання UV

Контроль над вибором розкладки UV та трансформації доступні шляхом з’єднання вузла UV Map – Розкладка UV та вузла Mapping – Розкладання із будь-яким вузлом Image Texture – Текстура Зображення.

Устави з вузлів Mapping експортуються за допомогою розширення для glTF з назвою KHR_texture_transform. Вгорі є вибірник типу розкладання. Point – «Точка» є рекомендованим типом для експорту. Texture – «Текстура» та Vector – «Вектор» також підтримуються. Підтримуваними зсувами є:

  • Location – Локація - X та Y

  • Rotation – Обертання - Z лише

  • Scale – Масштаб - X та Y

Для типу Texture – Текстура, Scale – Масштаб X та Y повинні бути однаковими (рівномірне масштабування).

../../_images/addons_import-export_scene-gltf2_material-mapping.png

Обміркований вибір розкладання UV.

Порада

Ці вузли є факультативними. Не всі читачі glTF підтримують одночасно кілька розкладок UV або трансформ текстур.

Factors – Фактори

Будь-які вузли Image Texture можуть факультативно множитися на сталі колір або скаляр. Вони будуть записані як фактори у файлі glTF, які є числами, що множаться на визначені текстури зображень. Вони не є поширеними.

Example – Приклад

Одиничний матеріал може використовувати все з вищезазначеного одночасно, за бажанням. Ця ілюстрація показує типову структуру вузлів, коли різні з вищезазначених опцій застосовуються одночасно:

../../_images/addons_import-export_scene-gltf2_material-principled.png

Матеріал на основі Principled BSDF з емісійною текстурою.

Exporting a Shadeless (Unlit) Material – Експортування Безвідтінкового (Неосвітленого) Матеріалу

Для експорту неосвітленого матеріалу змішуйте через промінь камери та уникайте використовування вузла Principled BSDF.

../../_images/addons_import-export_scene-gltf2_material-unlit.png

Одна з кількох подібних розстав вузлів, що буде експортувати KHR_materials_unlit та рендерити безвідтінковість у Blender.

Extensions – Розширення

Основний формат glTF 2.0 може розширятися додатковою інформацією за допомогою розширень glTF. Це дозволяє цьому формату файлів містити деталі, що не вважалися універсальними на момент першої публікації Не всі зчитувачі glTF підтримують всі розширення, але деякі досить поширені.

Певні функціональності Blender можуть експортуватися в glTF лише через ці розширення. Наступні розширення glTF 2.0 extensions підтримуються безпосередньо цим додатком:

Import – Імпорт

  • KHR_materials_pbrSpecularGlossiness

  • KHR_materials_clearcoat

  • KHR_materials_transmission

  • KHR_materials_unlit

  • KHR_materials_emissive_strength

  • KHR_materials_volume

  • KHR_materials_sheen

  • KHR_materials_specular

  • KHR_materials_ior

  • KHR_materials_variants

  • KHR_lights_punctual

  • KHR_texture_transform

  • KHR_mesh_quantization

Export – Експорт

  • KHR_draco_mesh_compression

  • KHR_lights_punctual

  • KHR_materials_clearcoat

  • KHR_materials_transmission

  • KHR_materials_unlit

  • KHR_materials_emissive_strength

  • KHR_materials_volume

  • KHR_materials_sheen

  • KHR_materials_specular

  • KHR_materials_ior

  • KHR_materials_variants

  • KHR_texture_transform

Third-party glTF Extensions – Сторонні Розширення glTF

Можливим є для розробників на Python додавати підтримку в Blender для додаткових розширень glTF шляхом написання їх власного стороннього додатку без модифікування цього додатку glTF. Для отримання додаткової інформації see the example on GitHub та якщо потрібно, register an extension prefix.

Custom Properties – Кастомні Властивості

Кастомні властивості завжди імпортуються, і будуть експортуватися з більшості об’єктів, якщо опція Include ‣ Custom Properties – «Включення > Кастомні Властивості» вибрана перед експортом. Вони зберігаються у полі extras на відповідному об’єкті у файлі glTF.

На відміну від розширень glTF, кастомні властивості (extras) не мають визначеного простору імен і можуть використовуватися для будь-яких користувачем визначених або для застосунку специфічних цілей.

Animation – Анімація

Анімація glTF змінює трансформи об’єктів або позових кісток, або значення ключів форм. Одна анімація може впливати на кілька об’єктів, і може бути кілька анімацій у файлі glTF.

Import – Імпорт

Імпортовані моделі укладаються так, що перша анімація у фалі програється автоматично. Прошкрябуйте часолінію Timeline, щоб бачити, як вона програється.

Коли файл містить кілька анімацій, то решта з них буде організовуватися за допомогою редактора нелінійної анімації Nonlinear Animation Editor. Кожна анімація стає дією, запасеною у відстеження NLA. Ім’я цього відстеження є іменем анімації glTF. Щоб зробити анімацію цього відстеження видимою, клацніть Solo (іконка із зіркою) поруч з відстеженням, яке ви хочете програти.

../../_images/addons_import-export_scene-gltf2_animation-solo-track.png

Ось зразок моделі лисиці – fox sample model з показом її анімації «Run» для бігу.

Якщо анімація впливає на кілька об’єктів, вона буде розбита на кілька частин. Частина анімації, що впливає на один об’єкт, стає дією, запасеною на такому об’єкті. Використовуйте імена відстежень, щоб визначати, які дії є частиною однією і тієї ж анімації. Для програвання всієї анімації вам потрібно увімкнути Solo (іконка із зіркою) для всіх її відстежень.

Примітка

Поточно не існує способу бачити неанімовану позу моделі, що мала анімації.

Export – Експорт

Ви можете експортувати анімації шляхом створення дій. Як анімації glTF робляться з дій, керується опцією експорту Animation ‣ Group by NLA Track.

Group by NLA Track on (default) – Увімкнено «Групувати за Відстеженням НЛА» (стандартно)

Дія буде експортуватися, якщо вона є активною дією на об’єкті або вона запасена на відстеженні НЛА (наприклад, за допомогою кнопок Stash або Push Down в редакторі дій Action Editor). Дії, які не асоційовані з об’єктом одним з цих способів, не експортуються. Якщо ви маєте кілька дій, які ви хочете експортувати, переконайтеся, що вони запасені!

Анімація glTF може мати ім’я, яке є іменем дії стандартно. Ви можете замістити його шляхом перейменування її відстеження НЛА з NLATrack/[Action Stash] на ім’я, яке ви хочете використовувати. Наприклад, модель лисиці, ілюстрація fox model, буде експортуватися з трьома анімаціями, оглядання «Survey», ходьба «Walk» та біг «Run». Якщо ви перейменовуєте два відстеження на двох об’єктах однаковим іменем, то вони стануть частиною однієї й тієї анімації glTF та будуть програватися разом.

Імпортер організує дії так, що вони будуть експортуватися коректно за допомогою цього режиму.

Group by NLA Track off – Вимкнено «Групувати за Відстеженням НЛА»

У цьому режиму організація НЛА не використовується, і лише одна анімація експортується, використовуючи активні анімації на всіх об’єктах.

Примітка

Для обох режимів пам’ятайте, що лише певні типи анімації підтримуються:

  • Трансформа об’єкта (локація, обертання, масштаб)

  • Позові кістки

  • Значення ключів форм

Анімація інших властивостей, як фізика, освітлювачі або матеріали, буде проігнорована.

Примітка

Щоб відібрати анімації ключів форм, що керуються драйверами, що використовують трансформації кісток, вони повинні бути на об’єкті сіті, що є безпосереднім нащадком арматури цих кісток.

File Format Variations – Варіації Формату Файлів

Специфікація glTF ідентифікує різні способи, якими дані можуть бути збережені. Імпортер обробляє всі ці способи. Експортер буде запитувати користувача про вибір однієї з наступних форм:

glTF Binary (.glb)

Це продукує єдиний файл .glb з усіма даними сіті, текстурами зображення та пов’язаною інформацією, запакованими в одиничний двійковий файл.

Порада

Використання єдиного файлу полегшує співволодіння та копіювання моделі на інші системи та сервіси.

glTF Separate (.gltf + .bin + текстури)

Це продукує у форматі JSON текст-базований файл .gltf, що описує загальну структуру, разом із файлом .bin, що містить дані сітей та векторів, а також факультативно ряд файлів у форматах .png або .jpg, що містять текстури зображення, на які посилається цей файл .gltf.

Порада

Наявність асортименту окремих файлів значно полегшує для користувача можливість повернутися та редагувати будь-які JSON або зображення після того, як експорт завершено.

Примітка

Знайте, що спільне використання цього формату вимагає спільного використання всіх цих окремих файлів разом як групи.

glTF Embedded (.gltf)

Це продукує на тексті базований JSON файл .gltf, з усіма даними сітей та даними зображень, закодованими (за допомогою Base64) у цьому файлі. Ця форма корисна, якщо актив повинен спільно використовуватися через з’єднання «лише звичайний текст».

Попередження

Це найменш ефективна з доступних форм, і повинна вживатися лише тоді, коли це необхідно.

Properties – Властивості

Import – Імпорт

Pack Images – Упакування Зображень

Запаковуються всі зображення у файл blend.

Shading – Відтінювання

Як нормалі обчислюються під час імпорту.

Guess Original Bind Pose – Здогадка Оригінальної Пози Прив’язання

Визначає позу для кісток (і, отже, покритих сітей) у режимі редагування Edit Mode. При увімкненні намагається вгадати позу, що використовувалася для обчислення матриць інверсного прив’язання.

Bone Direction – Напрям Кістки

Змінює евристику, яку імпортер використовує для вирішення, де розміщати верхівки кісток. Зауважте, що устава Fortune може спричиняти неточності в моделях, що використовують не-рівномірне масштабування. Інакше, це чисто естетично.

Export – Експорт

Format – Формат

Дивіться: File Format Variations.

Textures – Текстури

Тека, для поміщення в неї файлів текстур. Відносно до gltf-файлу.

Copyright – Авторське право

Юридичні права та умови для моделі.

Remember Export Settings – Пам’ятання Устав Експорту

Зберігаються устави експорту цьому blend-файлі, щоб вони були викликані наступного разу, коли цей файл відкриється.

Include – Включення

Selected Objects – Вибрані Об’єкти

Експортуються лише вибрані об’єкти.

Visible Objects

Export visible objects only.

Renderable Objects

Export renderable objects only.

Active Collection – Активна Колекція

Export objects from active collection only.

Active Scene

Export active scene only.

Custom Properties – Кастомні Властивості

Кастомні властивості експорту як добавки glTF.

Cameras – Камери

Експортуються камери.

Punctual Lights – Пунктуальні Освітлювачі

Експортуються направлені, точкові та прожекторні освітлювачі. Використовує розширення KHR_lights_punctual для glTF.

Transform – Трансформа

Y Up – Y Уверх

Експорт вживає умовність glTF, +Y уверх.

Geometry – Геометрія

Apply Modifiers – Застосування Модифікаторів

Export objects using the evaluated mesh, meaning the resulting mesh after all Modifiers have been calculated.

UVs – UVи

Експортуються UVи (координати текстур) із сітями.

Normals – Нормалі

Експортуються нормалі вершин із сітями.

Tangents – Тангенси

Експортуються тангенси вершин із сітями.

Vertex Colors – Кольори Вершин

Export Color Attributes with meshes.

Loose Edges – Незв’язані Ребра

Експорт незв’язаних країв як ліній, з використанням матеріалу з першого слота матеріалів.

Loose Points – Незв’язані Точки

Експорт незв’язаних точок як точок glTF points, з використанням матеріалу з першого слота матеріалів.

Materials – Матеріали

Export full materials, only placeholders (all primitives but without materials), or does not export materials. (In that last case, primitive are merged, lossing material slot information).

Images – Зображення

Output format for images. PNG is lossless and generally preferred, but JPEG might be preferable for web applications due to the smaller file size. If None is chosen, materials are exported without textures.

Compression – Стиснення

Стискаються сіті за допомогою Google Draco.

Compression Level – Рівень Стиснення

Вище стиснення призводить до повільнішого закодовування та розкодовування.

Quantization Position – Позиція Квантизації

Вищі значення призводять до кращого стиснення.

Normal – Нормаль

Вищі значення призводять до кращого стиснення.

Texture Coordinates – Координати Текстур

Вищі значення призводять до кращого стиснення.

Color – Колір

Вищі значення призводять до кращого стиснення.

Generic – Узагальнене

Вищі значення призводять до кращого стиснення.

Animation – Анімація

Use Current Frame – Вжиття Поточного Кадру

Export the scene in the current animation frame. For rigs, when off, rest pose is used as default pose for joints in glTF file. When on, the current frame is used as default pose for joints in glTF file.

Animation – Анімація

Експортує активні дії та стежки НЛА як анімації glTF.

Limit to Playback Range – Лімітування Діапазоном Програвання

Обрізає анімації відповідно до вибраного діапазону програвання.

Sampling Rate – Частота Відбору

Як часто обчислювати анімовані значення (у кадрах).

Always Sample Animations – Завжди Вибірка Анімацій

Застосовується відбір до всіх анімацій.

Group by NLA Track – Групування за Відстеженням НЛА

Чи експортувати анімації смужок НЛА.

Optimize Animation Size

Reduce exported file-size by removing duplicate keyframes.

Export Deformation Bones Only – Експорт Лише Деформувальних Кісток

Export deformation bones only.

Shape Keys – Ключі Форм

Експортуються ключі форм (цілі морфів).

Shape Key Normals – Нормалі Ключів Форм

Експортуються нормалі вершин із ключами форм (цілі морфів).

Shape Key Tangents – Тангенси Ключів Форм

Експортуються тангенси вершин із ключами форм (цілі морфів).

Skinning – Покривання

Експортуються дані покривання (арматура).

Include All Bone Influences – Включення Усіх Впливів Кісток

Дозволяються більше, ніж 4 сполучених впливи вершин. Моделі можуть показуватися некоректно у багатьох оглядачах.

Contributing – Здійснення внеску

Цей імпортер/експортер розробляється через репозиторій glTF-Blender-IO repository, де ви можете подавати звіти про вади, пропонувати запити про функції або вносити код.

Обговорення та розроблення власне формату glTF 2.0 відбувається у групі Khronos Group glTF GitHub repository, і відгук там вітається.